Jump to content


Photo

Configuring a Netgear WG311 WLAN on Suse 9.0


  • Please log in to reply
15 replies to this topic

#1 taeuler

taeuler

    journeyman

  • Members
  • 94 posts

Posted 30 December 2003 - 02:58 AM

I purchased a netgear wg311 wireless card, but I have not been able to install the prism gt driver. I am running Suse 9.0, with kernel 2.4.21. Are there any ohter drivers that will work?

#2 Dapper Dan

Dapper Dan

    Pooh-Bah

  • Moderators
  • 1703 posts

Posted 30 December 2003 - 03:59 AM

Found this for you...

#3 taeuler

taeuler

    journeyman

  • Members
  • 94 posts

Posted 30 December 2003 - 09:37 AM

Thanks. I downloaded the file, although I'm not sure how to build the file.

#4 Dapper Dan

Dapper Dan

    Pooh-Bah

  • Moderators
  • 1703 posts

Posted 30 December 2003 - 04:37 PM

I'm afraid I can't help you with that, sorry. Can anyone else help taeuler figure out how to build this?

#5 Admiral LSD

Admiral LSD

    old hand

  • Members
  • 991 posts

Posted 30 December 2003 - 07:27 PM

Looking at the README it looks like just a simple matter of running make && make install in the top level of the source tree. You only need to fiddle with the makefiles if you're building for another architecture.

#6 taeuler

taeuler

    journeyman

  • Members
  • 94 posts

Posted 01 January 2004 - 02:44 AM

I read through the README, but I could not change the pathname from its default. Also the REAdME said after configureing to do: make. I tried this on Makefile.inc and madwifi-20030802, both returned the error "***No rule to make target '/lib/modules/2.4.21-99-smp/build/.config '. Stop ". The pathname it returned is that of the kernel. Does anyone have an idea on how to do this make?

#7 Admiral LSD

Admiral LSD

    old hand

  • Members
  • 991 posts

Posted 01 January 2004 - 08:28 AM

Do you have the kernel source (for the exact kernel you're runnin) installed? It should be either some where on your distro CDs or on SuSE's FTP archive.

#8 taeuler

taeuler

    journeyman

  • Members
  • 94 posts

Posted 05 January 2004 - 08:45 AM

I tried to do the make again after installing the kernel source from the CD, but i still got the same error. One other possible problem I noticed was that the makefile couldn't be altered, to specify the kernel location, instead of the default, which attemps to determine the kernel location. I also a Redhat 9 partion I could try this on but I can't seem to see the contents of the madwifi folder.

#9 Admiral LSD

Admiral LSD

    old hand

  • Members
  • 991 posts

Posted 05 January 2004 - 01:46 PM

The 'build' directory in the modules directory is actually a symlink that points back to the directory containing the source that was used to compile the kernel. Have you checked it and verified that it points back to the correct directory (creating it if it doesn't already exist)?

#10 taeuler

taeuler

    journeyman

  • Members
  • 94 posts

Posted 06 January 2004 - 07:45 AM

I checked the build directory in the kernel, it is a link, to an unkown destination, which also has the lock symbol onthe icon. This is the state immidesatly after installing the scource. I replaced the build directory, although it is empty; I still get the same error as before. Do I need to create a directory, or file called " .config ' " in the build directory?

#11 Admiral LSD

Admiral LSD

    old hand

  • Members
  • 991 posts

Posted 08 January 2004 - 08:51 PM

nonono, don't replace the build directory it should remain as a symlink but try and find out where it's pointing to (you can do this in a terminal using the command ls -l) and if it's not your installed kernel source change it to point to the source. It's using that symlink to try and find the kernel source and not being able to find it could be one of the reasons the build is failing. The .config file used to build the kernel should be provided somwhere, either with the source or installed as part of the binary kernel image in /boot (it'l be called something like <kernelversion>.config). Just copy it into your source dir as .config and that should be it.

You also mention that you see a lock on the icon for this particular symlink. That leads me to believe you're not doing this stuff as root - that's also important. You need to be root to access a lot of these directories and the compiler may be confusing lack of permission to access with lack of existence. You can quite easily elevate yourself to root priveliges temporarily by using the su command in a terminal. After entering it you'll be prompted for the root password after which you'll be in a shell that's virtually indistinguishable from one root opened itself.

#12 taeuler

taeuler

    journeyman

  • Members
  • 94 posts

Posted 29 February 2004 - 08:09 AM

I finally abandoned Suse and got a working Gentoo install. The atheros driver built perfectly, I think, but the card is not configured. When i do
Code:
/sbin/ifconfig ath0

The card shows up although it is not configured. I tried doing
Code:
net-setup ath0
but net-setup seems to be a program from the live-cd. What is the best way setup the card. The atheros driver is installed.

#13 futurewizard

futurewizard

    stranger

  • Members
  • 2 posts

Posted 18 March 2004 - 04:16 PM

Hi folks....I'm new to linux, I download drivers from MadWifi and when I try to install I get some error like run make config, as your modules are disabled...well I went inside lib/src/<version> and run make config.

it came up with questions, i patiently answered questions, but after couple of 100 q i selected all defaults.

then I tried to run make script, well this time it actually run but finished with error.

Do u have any idea what should I do?

I'm very fresh on linux, and spoiled by windows.


Regs
Rohit

#14 futurewizard

futurewizard

    stranger

  • Members
  • 2 posts

Posted 18 March 2004 - 04:18 PM

HI folks here is out put when I tried to install madwifi drivers

[root@localhost madwifi]# make
for i in ./ath_hal ./wlan ./driver; do \
(cd $i; make); \
done
make[1]: Entering directory `/usr/download/prism54-cvs-latest/madwifi/ath_hal'
uudecode ./../hal/linux/i386-elf.hal.o.uu
make[1]: uudecode: Command not found
make[1]: *** [hal.o] Error 127
make[1]: Leaving directory `/usr/download/prism54-cvs-latest/madwifi/ath_hal'
make[1]: Entering directory `/usr/download/prism54-cvs-latest/madwifi/wlan'
make -C /lib/modules/2.4.22-1.2115.nptl/build SUBDIRS=/usr/download/prism54-cvs-latest/madwifi/wlan modules
make[2]: Entering directory `/usr/src/linux-2.4.22-1.2115.nptl'
make -r -f tmp_include_depends all
make[3]: Entering directory `/usr/src/linux-2.4.22-1.2115.nptl'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory `/usr/src/linux-2.4.22-1.2115.nptl'
make -C /usr/download/prism54-cvs-latest/madwifi/wlan CFLAGS="-D__KERNEL__ -I/usr/src/linux-2.4.22-1.2115.nptl/include -Wall -Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -fomit-frame-pointer -pipe -mpreferred-stack-boundary=2 -march=pentium4 -DMODULE -DMODVERSIONS -include /usr/src/linux-2.4.22-1.2115.nptl/include/linux/modversions.h" MAKING_MODULES=1 modules
make[3]: Entering directory `/usr/download/prism54-cvs-latest/madwifi/wlan'
ld -o wlan.o -r if_media.o rc4.o if_ieee80211subr.o if_ieee80211wireless.o
make[3]: Leaving directory `/usr/download/prism54-cvs-latest/madwifi/wlan'
make[2]: Leaving directory `/usr/src/linux-2.4.22-1.2115.nptl'
make[1]: Leaving directory `/usr/download/prism54-cvs-latest/madwifi/wlan'
make[1]: Entering directory `/usr/download/prism54-cvs-latest/madwifi/driver'
make -C /lib/modules/2.4.22-1.2115.nptl/build SUBDIRS=/usr/download/prism54-cvs-latest/madwifi/driver modules
make[2]: Entering directory `/usr/src/linux-2.4.22-1.2115.nptl'
make -r -f tmp_include_depends all
make[3]: Entering directory `/usr/src/linux-2.4.22-1.2115.nptl'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory `/usr/src/linux-2.4.22-1.2115.nptl'
make -C /usr/download/prism54-cvs-latest/madwifi/driver CFLAGS="-D__KERNEL__ -I/usr/src/linux-2.4.22-1.2115.nptl/include -Wall -Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -fomit-frame-pointer -pipe -mpreferred-stack-boundary=2 -march=pentium4 -DMODULE -DMODVERSIONS -include /usr/src/linux-2.4.22-1.2115.nptl/include/linux/modversions.h" MAKING_MODULES=1 modules
make[3]: Entering directory `/usr/download/prism54-cvs-latest/madwifi/driver'
gcc -D__KERNEL__ -I/usr/src/linux-2.4.22-1.2115.nptl/include -Wall -Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -fomit-frame-pointer -pipe -mpreferred-stack-boundary=2 -march=pentium4 -DMODULE -DMODVERSIONS -include /usr/src/linux-2.4.22-1.2115.nptl/include/linux/modversions.h -include ./../include/compat.h -I./../include -I./../hal -I./../hal/linux -I./../ath_hal -I./../wlan -I./.. -DAH_BYTE_ORDER=AH_LITTLE_ENDIAN -fomit-frame-pointer -nostdinc -iwithprefix include -DKBUILD_BASENAME=if_ath_pci -DEXPORT_SYMTAB -c if_ath_pci.c
if_ath_pci.c:38:20: opt_ah.h: No such file or directory
In file included from /usr/src/linux-2.4.22-1.2115.nptl/include/linux/prefetch.h:13,
from /usr/src/linux-2.4.22-1.2115.nptl/include/linux/list.h:6,
from /usr/src/linux-2.4.22-1.2115.nptl/include/linux/module.h:12,
from if_ath_pci.c:46:
/usr/src/linux-2.4.22-1.2115.nptl/include/asm/processor.h:257:1: warning: "EISA_bus" redefined
In file included from /usr/src/linux-2.4.22-1.2115.nptl/include/linux/modversions.h:141,
from <command line>:10:
/usr/src/linux-2.4.22-1.2115.nptl/include/linux/modules/i386_ksyms.ver:228:1: warning: this is the location of the previous definition
make[3]: *** [if_ath_pci.o] Error 1
make[3]: Leaving directory `/usr/download/prism54-cvs-latest/madwifi/driver'
make[2]: *** [_mod_/usr/download/prism54-cvs-latest/madwifi/driver] Error 2
make[2]: Leaving directory `/usr/src/linux-2.4.22-1.2115.nptl'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/usr/download/prism54-cvs-latest/madwifi/driver'
make: *** [all] Error 2
[root@localhost madwifi]#

#15 taeuler

taeuler

    journeyman

  • Members
  • 94 posts

Posted 19 March 2004 - 11:51 AM

What distribution and kernel are using? Regardless, here is some advice on configuring and compiling a kernel. Be careful when doing this, and consider cheking other documentation, this can hose your system. Try
Code:
cd  /usr/src/linux-<version> 

or, if the kernel source is not there try:
Code:
cd lib/src/<version>

then once in the kernel directory
Code:
make menuconfig


Make menuconfig is easier to work with than make config, I think. You can also do make xconfig

Then go to loadable module support.
This brings up five options. Select
Code:
Enable loadable module support
Module unloading
Automatic kernel module loading


Select field with "y" when the bracket is highlighted.

After configuring the kernel, I think you will have to compile it.
Here is a helpful guide on confiuring and compiling a 2.4.x kernel.

If you bootloader is grub instead of lilo edit grub.conf, either in /etc/grub.conf, or /boot/grub.conf, depends on the distro.
Add these lines
title=<your distribution>
root (hd0,0) --if you have it installed on hda0
kernel (hd0,0)/<version> root=/dev/<hd title>

This is how I have my grub.conf from grub-0.93

Then try doing
Code:
make && make install
from within the madwifi folder.

#16 ursusmaj

ursusmaj

    stranger

  • Members
  • 1 posts

Posted 20 April 2004 - 07:38 PM

I suspect you worked this out already, but the issue with your "make install" is that the uudecode utility is not installed. You can find this in the sharutils rpm package in SuSE. If you install this, then the first command to uudecode a file in the make process will succeed as will the copy of the relevant header file that the complie error is bitching about.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq