Jump to content


Photo

[gentoo-announce] [ GLSA 201401-07 ] libxslt: Denial of Service


  • Please log in to reply
No replies to this topic

#1 News

News

    stranger

  • Members
  • 63537 posts

Posted 10 January 2014 - 05:49 PM

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201401-07
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: libxslt: Denial of Service
Date: January 10, 2014
Bugs: #433603, #436284, #463236, #496114
ID: 201401-07

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple Denial of Service vulnerabilities have been found in libxslt.

Background
==========

libxslt is the XSLT C library developed for the GNOME project. XSLT is
an XML language to define transformations for XML.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 dev-libs/libxslt < 1.1.28 >= 1.1.28

Description
===========

Multiple vulnerabilities have been found in libxslt:

* Multiple errors exist in pattern.c and functions.c (CVE-2012-2870,
CVE-2012-6139).
* A double-free error exists in templates.c (CVE-2012-2893).
* A NULL pointer dereference in keys.c (CVE-2012-6139).
* An error in handling stylesheets containing DTDs (CVE-2013-4520).

Impact
======

A remote attacker could entice a user to process a specially crafted
file in an application linked against libxslt, possibly resulting in a
Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All libxslt users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-libs/libxslt-1.1.28"

Packages which depend on this library may need to be recompiled. Tools
such as revdep-rebuild may assist in identifying some of these
packages.

References
==========

[ 1 ] CVE-2012-2870
http://nvd.nist.gov/...e=CVE-2012-2870
[ 2 ] CVE-2012-2893
http://nvd.nist.gov/...e=CVE-2012-2893
[ 3 ] CVE-2012-6139
http://nvd.nist.gov/...e=CVE-2012-6139
[ 4 ] CVE-2013-4520
http://nvd.nist.gov/...e=CVE-2013-4520

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gent...a-201401-07.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security ( -at -) gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2014 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommo...enses/by-sa/2.5







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq