Jump to content


Photo

How to share files with WinXP?


  • Please log in to reply
6 replies to this topic

#1 ox1222

ox1222

    stranger

  • Members
  • 19 posts

Posted 25 December 2003 - 07:59 AM

Hello,

I know that in order to share files between WinXP and Linux, I need to resore files in FAT32 format. But I don't know how to retrieve the file which is restored in FAT32 format when my PC is in the Linux (Mandrake 9.2) environment.

Can someone please teach me how to do retrieve a file in FAT32 from the Linux environmnet?

Thank you.

#2 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 25 December 2003 - 12:30 PM

Of course the best way to do this is to have a fat32 partition on the hard drive set up before installing Mandrake. Then Mandrake will auto add the partition in fstab.

But, use a fat32 partition for a share drive. Save all your files that you would like to share in that partition. Again, if you already have an existing fat32 partition, then you can use this.

Create a directory in the /mnt directory, say share. You can either use the file manager to do this, or at a command line type mkdir /mnt/share. Make sure there is a space between mkdir and /mnt.

Mount the share partition by typing in a konsole, as root user,

mount -t vfat /dev/hdxx /mnt/share, where xx equals the partition that is the fat32 one.

Fore example, if the fat32 partition is on the "windows" c: drive, on the third partition, then it would be hda3. If you only have one hard drive n the system, then it will be hda, (whatever the partition designation is).

Use your file manager to navigate to the /mnt/share directory and your files should be visable.

Setting this up automatically, if you don't have an existing partition available is a little more tricky with Mandrake, but let us know what your system has currently.

#3 ox1222

ox1222

    stranger

  • Members
  • 19 posts

Posted 25 December 2003 - 05:22 PM

Thank you for your clear explaination.

Now I know that the window's FAT32 is in the Linux's mnt folder.

#4 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 26 December 2003 - 03:28 AM

As long as you are sure that the partition is a fat32, and not NTFS, you should be able to mount the partition. Linux will not allow sharing files with Win XP, if it is an NTFS filesystem. If it is not auto-mounted (you are not able to see the partition when you click on the correct /mnt folder in the file manager), navigate to /etc/fstab in the file manager, click on the /etc/fstab file and read the cooresponding lines that have vfat as the filesystem. Then see if it has a mount point in /mnt.

This will tell you which partition the vfat partition is on. Then try to mount the partition and see if you can view it in the file manager.

#5 ox1222

ox1222

    stranger

  • Members
  • 19 posts

Posted 27 December 2003 - 07:21 AM

In the Red Hat 9, I cannot find where is the vfat partition.
Red Hat 9 seems not setting up these FAT32 folders in /mnt automatically.
And I'm not able to create a directory by using the function mkdir.

here is the info in the /etc/fstab:

LABEL=/ / ext3 defaults 1 1
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda8 swap swap defaults 0 0
/dev/sda /mnt/floppy auto noauto,owner,kudzu 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0

#6 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 27 December 2003 - 12:18 PM

Thank you for posting the fstab, this helps seeing how RedHat mounts partitions and drives.

If you are using the command line, do so as root. So type in a konsole;

su (hit the enterkey)

You should be prompted for your root password that you selected during the install, not your user password. Enter the password and hit the enter key.

Then try the mkdir command.

Then try to mount the partition command.

If you on't have multiple partitions or hard drives; and only have windows installed, then it is probably hda1.

#7 trankillooo

trankillooo

    stranger

  • Members
  • 1 posts

Posted 27 August 2004 - 02:14 AM

Hi all
Worked great for me, now I can save and share audio samples from one to another (files too of course).
here is what I did:

- installed win2K
* with 100kb for boot loader non-formatted (hda1)
* with no partition on a 5G drive (c:/hda2)
* format FAT32 on 5G on second drive

- installed linux with an extra partition in vfat
* on 10G drive (hdb1)
* vfat as/ on the FAT32 (5G) (f:/hdb2)

in linux:
- logged in as /root su
- created share dir: mkdir share
- mounted hdb2 with: mount -t vfat /dev/hdb2 /mnt/share

the link works

when rebooting it doesn`t work, so...
edited fstab with emacs:
- emacs /etc/fstab
and added /dev/hdb2 /mnt/share vfat default 0 0 in it

now works great!
THX for the tip!
I`ll try to implement with XP next...
FYI the distro I use is Fedora Core 3 Test and it rocks as far as I`m concerned!

Good luck!
==========

In the past, on a dual boot with XP I encountered the following on reboot:

Rootnoverify(hd0,0)
Chainloader +1


here is what I did to recover:
sfdisk -d /dev/hda | sfdisk --force -H255 /dev/hda

more infos can be found at the following url:
http://lwn.net/Articles/86835/




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq