Jump to content


Photo

Fedora, Kernel 2.6, Nvidia driver install issues.


  • Please log in to reply
5 replies to this topic

#1 Tekchip

Tekchip

    journeyman

  • Members
  • 84 posts

Posted 19 December 2003 - 09:11 AM

I installed Fedora with no problems. Installed the rpm version of kernel 2.6 with no problems. Now I seem to be having some issues getting the Nvidia drivers installed. According to everthing I've looked up you have to patch the nvidia driver source before running a make install. The patch and instructions are found at www.minion.de. I followed the instructions to a T with no problems till I get to the make install at the end. Then it gives me the error :

You appear to be building the NVIDIA kernel module with a
compiler different from the one that was used to build the
running kernel. This may be perfectly fine, but there are
cases where this can lead to unexpected behaviour and
system crashes.

If you know what you are doing and want to override this
check, you can do so by setting IGNORE_CC_MISMATCH.

In any other case, set the CC environment variable to the
name of the compiler that was used to build the kernel.

make: *** [cc-sanity-check] Error 1

I'm guessing this is due to the fact that the kernel rpm was i686 and the kernel source rpm was i386 and so there's a difference in the headers apparently. If any one might be able to make some suggestions on how to make these drivers work it would be much appreciated. Thanks in advance.

#2 Tekchip

Tekchip

    journeyman

  • Members
  • 84 posts

Posted 19 December 2003 - 01:06 PM

Ok I found that you can do an export IGNORE_CC_MISMATCH=1 and the driver will recompile and state that it was able to install the module. I then try X with the driver name changed to nvidia in my XF86Config. The X server still wont load.

I then ran across another post that suggests that you run make in the NVIDIA-Lin.../usr/src/nv and then run make install in the root of that NVIDIA-Lin... directory in order to put everything where it should be. I attempted this revision of the install and changed my XF86config again and still no luck.

Does any one have any other suggestions? I've tried both processes with both the 4496 and the 4620 drivers with no luck.

#3 Admiral LSD

Admiral LSD

    old hand

  • Members
  • 991 posts

Posted 20 December 2003 - 09:46 AM

Are you loading the relevant AGPGART module for your motherboard and the nVidia driver module before you try and start the X server? Also, has the Direct Rendering Manager been compiled out of your RPM'd kernel?

#4 noxorc

noxorc

    stranger

  • Members
  • 4 posts

Posted 20 December 2003 - 03:31 PM

can you post that location of the Fedora 2.6 kernel?

thanks..


-nox

#5 jjcohen

jjcohen

    newbie

  • Members
  • 30 posts

Posted 31 December 2003 - 06:59 AM

Try rebuilding the kernel, then building the Nvidia kernel module.

#6 Degenerate

Degenerate

    stranger

  • Members
  • 5 posts

Posted 31 December 2003 - 03:17 PM

It should be best if you compiled the kernel completely from source. The problem with RPMs is that they're created with what the packager thinks are most useful, but not everything you'll need won't be supported by just installing the package. Even if it takes longer, just take the time to configure your kernel correctly and compile it. It'll save lots of problems in the long run.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq