Jump to content


Photo

Suse 9.0 and the mouse


  • Please log in to reply
2 replies to this topic

#1 awilisch

awilisch

    stranger

  • Members
  • 4 posts

Posted 16 December 2003 - 04:56 PM

I have a Satallite 5105-s607 and put Suse 9 professional on it. An excellent distribution that amazingly everything seems to work.

however I'm having a serious problem. Whenever xwindows resets my mouse vanishes. I know the bloody thing is still there cause if I right click somewhere a menu pop's up. Plus if I just do the blind drag down and left I can click and open the menu. This seems to happen everytime xwindows has to restart itself, like when I logout of my laptop to get it back to a login prompt, or even worse, if I open a terminal and open one of my other linux server or sparcstation's desktops using X :1 -query <host>. As soon as the new xwindow session pops up with the remote desktop the mouse is gone, and it STAYS gone. So while I can usually feel around, logout, and kill the xsession, I still have to completely reboot the laptop to get the mouse back. I havn't tried taking it to run level 3 and then back to 5 to see if that works, but I have done the old three finger salute (ctrl alt bksp) to force xwindows to restart.

Anyone who has any ideas I'm forever in your debt. While I love mandrake 9.2 (it has it's own issues like acpi not working), Suse 9 has some really great things that make it a very good choice (for the moment).

Thanks in advance
Aric

#2 chrispope

chrispope

    newbie

  • Members
  • 29 posts

Posted 22 January 2004 - 07:01 PM

I run a Toshiba Satellite Pro M15-S405 and had the exact same problem.
Do you use the online system update? If not, try that, when I was still experimenting with the SuSE 9.0 installation I found that the xfree86 and nvidia drivers were the cause of the situation.
I'm happily able to logout from the X server and login with a different user, etc., without having to reboot or switch runlevels to regain my cursor.

#3 awilisch

awilisch

    stranger

  • Members
  • 4 posts

Posted 23 January 2004 - 02:57 PM

Actually I eventually sucked those down and it did fix the problem. It took me a while to do that because someone somewhere told me that the nvidia drivers off of their site were just bad news. Apparently that person just must have had a bad trip or something cause I've pulled them down a couple times now and they've worked everytime.

The only problem I'm having now is when I plug in my external usb mouse. It'll autodetect it like it's supposed to, pop up, run through the install, then it'll work fine. But if for some reason I unplug it, or boot up without it attached suddenly I have no mouse, and suse's installation isn't exactly setup to get around easily with keyboard shortcuts (unless I happen to have a term window open). Don't suppose anyone knows how I can get this system to keep not only the touchpad mouse but the usb mouse and just use whichever one is plugged in?

Other than that little issue, I'm really happy with this distribution. The keyboard bounce fix doesn't seem to work ALL the time, and every now and then when typing it doubles up my keys (rather annoying, but it might get fixed one day).

Aric




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq