Jump to content
Compatible Support Forums
Sign in to follow this  
Tekchip

How to make ATI drivers work in RH9/Fedora

Recommended Posts

Spent more than a few nights trying to figure out how to make it happen. I've yet to see if the AIW tv functonality works and I havn't tested dual monitors. This is a basic guide and may be not even the right way but since I hadn't found any place else describe how to do it I figured I'd post.

 

Hit up this site for those instructions.

Share this post


Link to post
Share on other sites

That sounds about right, the need to enable agpgart is well known among nForce2 users as it was a source of much aggravation until nVidia provided AGPGART support for nForce2 to the 2.6 kernel team and later backported it to 2.4.

 

If they'd searched around they'd have probably found a quicker way to get them up and running:

 

http://www.linuxquestions.org/questions/showthread.php?s=&threadid=83035

 

Yes, it's for Slackware but it should have work just as well (if not better as you avoid the need to use the godawful RPM) on Red Hat/Fedora.

 

And I can't help but think they're doing something wrong in the way they're using fglrxconfig as I've been using it here on Gentoo for ages and never had a single problem with the configuration files it creates.

 

edit: oops, I didn't realise that was actually your site, I somehow got the idea you'd just mirrored the actual info hence the wording of my posts. Sorry about that.

Share this post


Link to post
Share on other sites

See here's the thing. In Redhat or Fedora some sort of a DRM kernel module gets loaded on boot up which means that weather you run fglrxconfig or not you cant start X because the fglrx module wont load. I personally am not a kernel hacker and havn't gotten to a point where I can easily recompile my own kernel. Which means I cant hunt down or remove that DRM module. Most new users are at or near the point I'm currently at with the kernel. Not being able to run 3d applications just because you cant hunt down and remove kernel modules really isn't an option for us newbs. So I had to do a little config/bootup hacking to get the fglrx driver and the agpgart external modules to load before what ever the DRM module is. This corrected the issues I was having and got the drivers to work. I figured knowing how to by pass the issue with out doing anything to the kernel was a good thing that I should share.

 

Believe me I spent a good solid 8 hours the other night reading about the subject and trying to find a straight forward way to make them work. I eventually ran across something on the suse message boards that said something about moving those to the head of the line in the startup. I then had to go figure out where the RH/Fedora startup file was(which wasnt tough) and add them. Turns out it worked.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×