Jump to content


Photo

How to get nforce2 audio and networking to work


  • Please log in to reply
3 replies to this topic

#1 hollywoodb

hollywoodb

    stranger

  • Members
  • 1 posts

Posted 04 December 2003 - 07:43 PM

nVidia has released drivers for the nforce2 motherboards, available at nvidia.com's driver download page. If you follow the instructions there you won't have a problem.

However:
The nvaudio driver can be a little buggy at times. It is based on the ac97_codec and i810_audio OSS drivers which are part of newer kernels. I recommend if you are not going to use ALSA to use the ac97_codec and i810_audio (AC'97 and Intel 8x0 audio) compiled as modules.

I recommend above all to use ALSA. again, the intel 8x0 alsa driver works fine with nforce audio. ALSA is a bit more complicated to configure, but if you follow the directions on alsa-project.org you shouldn't have any trouble. ALSA is now available as part of the 2.6.x series kernel releases. That means that you can use menuconfig or xconfig and select nforce audio to be compiled into the kernel or as modules with the new kernel series.

The nvnet driver may not compile against newer kernel versions (like the 2.6.x series). However there is a solution. A couple of good people in the opensource world have reverse-engineered the driver. That means you can add nforce2 onboard ethernet support to 2.4.x and 2.6.x kernels without using nvnet. They call this GPL'd driver "forcedeth". It is available as a kernel patch, with instructions on how to apply this patch available.

Once you apply the forcedeth patch to your kernel it will be listed as 'expiremental' under network devices and onboard ethernet controllers. It has a couple very minor bugs which won't affect most users, and it takes a second or two longer to init the driver, but I've been using it with no problems.

My current configuration is:
2.6.0-beta11 kernel with forcedeth patch applied
using alsa compiled into the kernel (not as modules because I never have a need to unload the driver)
using forcedeth to enable nforce ethernet (also compiled into kernel)
works flawlessly.

I have also used the OSS (ac97 and i810) modules with kernel versions 2.4.x along with nvnet with no problems except that it seems sound quality and support is a little better with alsa.

I have also used nvaudio and nvnet in conjunction with 2.4.x series kernels, and would recommend using the OSS modules mentioned above instead of nvaudio.

I have also used the alsa driver and nvnet in conjunction with 2.4.x series kernels. In theory it should work as well as alsa compiled with the 2.6.x kernels, but for some reason I seem to have fewer issues using the 2.6.x kernels. However I still recommend using alsa over nvaudio or the OSS modules with any kernel, especially since alsa supports OSS emulation.

My best experience by far has been using the 2.6.0-beta11 kernel with forcedeth for ethernet and alsa compiled in, as I mentioned above.

NOTE: Gentoo users, there is a 2.6 kernel with the forcedeth patch applied in the portage tree. It is actually the very kernel I'm using. the ebuild is:
sys-kernel/gentoo-dev-sources/gentoo-dev-sources-2.6.0_beta11-r1.ebuild

Feel free to contact me with any questions. cheers.

#2 Admiral LSD

Admiral LSD

    old hand

  • Members
  • 991 posts

Posted 05 December 2003 - 08:35 AM

nForce boards are relatively easy to set up under Linux, particularly now that virtually all of the necessary patches (such as AGPGART and IDE support) are now part of the stable kernel tree. The big problem (this is going to sound like a rant and it many ways it is so I'll apologise for it in advance) now is, and I see this a lot over at nForcersHQ, is users who aren't used to dealing with drivers in the way Linux handles them. This isn't helped by distros such as Red Hat who paint over a lot of this inherent complexity with graphical tools that work great when they work but get in the way and are a royal PITA when they don't (which is frequently the case when you introduce drivers outside the stock set). The other problem is nVidia insisting in supplying the drivers in the godawful RPM format without really mentioning the fact the packages are fairly kernel specific. This leads to a whole load of RPM BS and kernel/driver mismatches that could have been easily avoided had they compiled the drivers from the "sources" nVidia provide.

With that out of the way, there's been a 2.5/2.6 patch for nvnet floating around for a while now. There's a sticky about it in the nForce Linux forum at nForcersHQ. forcedeth obsoletes it somewhat but it's still a useful bit of info nonetheless.

Although it'll be the real winner when it arrives as far as nForce2 support goes, 2.6 isn't strictly necessary for decent support now. A lot of the nForce-specific enhancements have been backported into the stable kernel tree and anything from about 2.4.20 up can be coaxed into support nForce boards fairly well without an awful lot of trouble.

ALSA hasn't given me all that much trouble under 2.4 either. There was a period there with ALSA 0.9.7 where it would act up (the sound device would just lock up, the system would continue to run fine but anything that tried to use sound got caught in a loop) and require a hard reboot (shutting the system down would fail when it tried to unload the ALSA modules) but that was fixed in about ALSA 0.9.7c and hasn't appeared to return since (I'm now using ALSA 1.0-rc1). ALSA is definitely worth the trouble though, it's far better than any of the OSS drivers and it's the direction sound in Linux is heading. ALSA's inclusion in the 2.6 kernels means that OSS support is now deprecated and will ultimately be removed entirely.

I'm running Gentoo Linux on an EPoX 8RDA+ motherboard running a 2.4.23 kernel using forcedeth for LAN (although I never really had a problem with nvnet) and ALSA for sound and it's solid as a rock, even with the notoriously troublesome APIC support enabled. AGPGART support, which is necessary to get hardware 3D acceleration on my Radeon 9500 Pro, is hassle-free as well.

#3 bobk

bobk

    stranger

  • Members
  • 2 posts

Posted 30 December 2003 - 10:20 PM

I just installed an ASUS A7N8XE which has two NIC ports on it, a Marvell Gigalan and an 10/100 nForce2. The Marvell is up and running fine. The nForce2 is not doing so well. I'm trying to determine if it is a harware problem or a driver problem and at this point, I have no idea how to know.

I've installed nVidia's latest driver and when tryign to activate the card, I get the following error: "nvnet device eth3 does not seem to be present, delaying initialization."

I'm not sure how to proceed to determine if it is a hardware problem or that the chip is not compatibl;e with Linux.

Help!

#4 bobk

bobk

    stranger

  • Members
  • 2 posts

Posted 30 December 2003 - 11:48 PM

Recompiled the nVidia drivers. I am using the Fedoa release and I was trying to use the Redhat rpm.

Everything is working great!!!!!!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq