Jump to content
Compatible Support Forums
Sign in to follow this  
Rocco

installing suse 8.2 with an old bios.

Recommended Posts

Hi, i am new to Linux and would greatly appreciate some help with installing it. I have stated off with burning the boot.iso image. and have tried installing Linux with it. Booting into Linux is no problem. However me networkcard, a realtek, does not get discovered, I found out this is because my bios version is to old (99) and aspi is disabled. I also know that to overcome this problem is by running aspi=force in the command line, but because of the fact that use a cd, I cannot make any changes to files. My questions are as follows:

 

Is there a way to burn a cd copy with aspi fored to on?

What are the parameters for installing the realtek 8139 card?

My future Linux server is at the moment a win2000 server, can I copy the linux files tree to this server, boot my Pc using the Linux boot cd, and install from the network? The c: partition is NTFS.

 

Really appreciate your help!

Share this post


Link to post
Share on other sites

Let's start with the network card. I just looked at the SuSE 9.0 boot image file. What you most likely need to do is load the module for the realtek card, during the install process. It should be, I think, the 8139too module. Then the network setup process should be started. Make sure that DHCP is enabed as you go through the process. This should allow the network install to proceed, as long as you have the ISP addess and directory of a SuSE server.

 

NTFS is only supported read only, if at all in SuSE 8.2. You may want to check out the 9.0 version boot image iso, which was just released. This may have better NTFS support. See the news section of this site for details. Distrowatch also has a howto section in their most recent newsletter for version 9.0, that may be of some help.

Share this post


Link to post
Share on other sites

Thanks for the reply. I did work out that I could load the network card module, and you are right this should be the 8139too module. The problem is that when I install this driver, it asks for the driver parameters, I do not know what they are, the module will not install without the correct parameters.

 

I will try the 9.0 boot image.

Share this post


Link to post
Share on other sites

You may not have the actual module. The install should not need the parameters. However, I am having problems with the 9.0 install, as well, failing at the YAST panel "media error." Could be that the servers are overloaded.

 

A good howto is located at http://www.linuxquestions.org/questions/archive/5/2003/08/3/71137.

 

If I am able to install, I will let you know.

Share this post


Link to post
Share on other sites

OK, mine is installed.

 

I had a thought. If the 8139too module does not work, trey the one just before that one, especially if you have an older Realtek card.

 

For acpi, when you get the initial SuSE install login screen, scroll down to the manual install option. You will note that there is a cursor at the bottom. Type in the cursor area pci=acpi. See if that works. Then try the install, first loading the 8139too module. If this fails, try the Realtek one just before the 8139too one.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×