Jump to content
Compatible Support Forums
Sign in to follow this  
rowdyonegh

Toshiba Compatibilty Question

Recommended Posts

I have the current system:

 

Toshiba Satellite 2435-S255

About 6 months old

Pentium 4 2.4 gig

512 megs of DDR RAM

Firewire

USB 2.0

Firewire

2 PCMIA slots

 

My question is, I have Windows XP installed - as this was the OS that came with the laptop. I have tried serveral times to install Linux 8.0 on the system, which install correctly but will never boot to that partition.

 

I have tried to different versions of Knoppix, which boot in my dell desktop just fine. These CD's will not boot either, I never even get the penguin at the begining where it starts processing. I just get a blank screen and it just sits there.

 

Just wondered if anyone has any suggestions about this and what I can do, I would like to have Linux or at the very least knoppix to run on my laptop. I can't figure out why it won't.

 

Glenn

Share this post


Link to post
Share on other sites

I've been through this a few times myself.

 

First, what exact distro of Linux do you have? RedHat, Mandrake...

 

Secondly, most likely, Win XP was installed with the NTFS filesystem, which Linux has trouble with. Many laptops also have hidden partitions with bios information on them which complicates the process.

 

Did you pre-format a partition in ext2, ext3 or fat32 for the installation BEFORE installing Linux? Or, did you try to use the partitioning tool during the install? Again, the NTFS issue.

 

If this does not make you crazy, I found that one needs to burn the Linux ISO's with a burn speed of 8X or less, or the iso's may fail to burn properly. This could explain why the Knoppix CD's fail.

 

Finally, I also found that it is wise to use the same CDRW drive that you burned the CD to do the install. There can be compatibility problems with different CDRW drives on different systems. So, if you burned the CD-R on one system and tried to install on the laptop CD drive, this could be a problem. If you did al the above, you may find that using a CDRW disk rather than a CD-R disk to burn the iso may make a difference.

 

If you do have a fat32 or linux partition for the install, try doing the install and making a floppy boot disk at the end of the install, not using lilo. See if the boot floppy allows the system to boot properly. This will narrow down where the problem may be coming from.

Share this post


Link to post
Share on other sites

I ran into similar bootloader problems when upgrading our Toshiba Satellite from Morphix Gnome 4.0 to 4.1. I finally formatted the XP/NTFS partition to Fat32, and installed my old unused copy of 98. The best solution for us would be to have NO Windows partitions at all, but Morphix doesn't get along with the Satellite's winmodem, and we may need a 56k connection if we ever want to use it outside the range of our wireless network.

Share this post


Link to post
Share on other sites

I'd just like to point out here that any issues Linux may have with NTFS are most likely specific to certain distributions. I had absolutely NO trouble whatsoever getting my Gentoo install to play nice with my XP NTFS partition. I also have 3 other distros on here (Slackware, Arch and Sourcemage) but since they boot using the version of GRUB installed by Gentoo they don't really count except maybe to say that I've installed Slack (and many other distros, Red Hat and Mandrake are two recent - as in the last 12-18 months - examples that come to mind) alongside Windows 2k and XP on NTFS before without any trouble.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×