Jump to content


Photo

How to access files second hard drive


  • Please log in to reply
6 replies to this topic

#1 adwan001

adwan001

    stranger

  • Members
  • 4 posts

Posted 25 October 2003 - 05:36 PM

I am a new Linux user. I have RedHat Linux 9.0. I need some help knowing how to access my files on a second hard drive partitioned and formated as FAT32 & NTFS and running windows xp. Also I can't access a partition on the same hard drive that is running Linux. Thank you.

#2 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 26 October 2003 - 01:32 AM

Generally speaking, Linux does not like NTFS partitions. Historically, even if you can access the partition in Linux, you are not able to read and write to the partition.

If Win XP is on a NTFS partition, this is only supported if the kernel that comes with your RedHat version supports it. I do not know if this is the case with RedHat.

Accessing Fat 32 partiitions is not difficult, nor is other Linux partitions, as long as you know where the partitions are. If RedHat did not auto set-up some of the links already, then we can guide you through this.

Is the Win XP partition on a fat 32 or NTFS partition?

#3 adwan001

adwan001

    stranger

  • Members
  • 4 posts

Posted 26 October 2003 - 05:30 AM

Thanks for your response. My Windows XP is installed on a FAT32 formatted partition. It's more important to me to learn how to access the FAT32 partitions at this time because that's where my files are. I don't know if my kernel version supports NTFS access or not (I am new to this you know). In any case the kernel version that I get out of the command "uname -r" is 2.4.20-8.
By the way, when I go to disk management all I can see in the list is the CD ROM drives, Zip drive, and floppy disk drives. I don't think that Linux did an automatic set up of links to the drives because when I installed it I did manual partition and formatting of the Linux partiotions.
again thanks for your help.

#4 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 26 October 2003 - 12:43 PM

Sounds like you have some good knowledge of Linux already! I will assume that you know where the fat32 partition is for your win xp partition. On most systems, it is at hda1. But be aware that on some systems, hda1 is reserved for a small utility partiition, such as on Compaq computers. If you are sure that hda1 is correct, then you can proceed. The following link will serve as a guide. I realize that RedHat may have a utility to do this, but this will give you some basics using the command line functions.

You can make a new directory either with the file manager (assuming you have KDE in this case) or by using the command line. Assuming that you know where the fat 32 partiton is.


http://www.digitalin...dhat/mount.html

See if this helps first. If not let us know. If it does, post back what the results are and we will get it to automount on boot.

My quick example on a fat 32 partition on hda1;

1.Go to a konsole (root or superuser)

2. type in mkdir /mnt/win32

3. then type mount -t vfat /dev/hda1 /mnt/win32

4. Go to your file manager and navigate to the /mnt/win32 directory and enter it.

Do you see your files?

Reference: http://www.europe.re...g.php3#MOUNTING

#5 adwan001

adwan001

    stranger

  • Members
  • 4 posts

Posted 26 October 2003 - 07:16 PM

Hello again,
The website you referred me to was very helpful and contained easy to follow instructions. I successfully mounted all FAT32 and Linux partitions (except the swap partition). As you expect, my Kernel did not support the NTFS partition.
I was able to see and read the files on the mounted partitions, however I don't seem to be able to write to these partition (I can't paste a file in them for example) when I am logged in not as a root. I tried to set the permissions as a root to allow others read, write, and execute, but every time I click on the check box it goes blank again. I am not sure what i am doing wrong here. The other thing you suggested was doing automount on startup. Could you tell me how?
THanks for your help.

#6 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 27 October 2003 - 12:18 PM

I found this thread on LinuxQuestions.org regarding RedHat 9;

Quote:
OH yeah I forgot to add if you want the drive mounted at boot add the following line to your /etc/fstab file. Remember to be in root when you edit.

/dev/hda2 /mnt/partition vfat defaults,umask=0000 0 0

if the drive is fat or fat32

and

/dev/hda2 /mnt/partition ntfs auto, ro, umask =0222 0 0

if the drive is NTFS.

Thats only if the partitions are windows drives!! Not ext2 or ext3 drives!

These two options work fine on my system (RH9/XPpro). Remember to alter hda and partition names to suit your system!


So, it seems that you can mount and read NTFS partitions with a RPM package that offers this support. See the thread at;

http://linuxquestion...s/history/85451

See if the partition can be written to, or copied from once the fstab is in place. You may have to use the file manager in superuser mode to do so. Again, I don't have ReHat on my system, but it is usuallly found in the start menu under "system".

#7 adwan001

adwan001

    stranger

  • Members
  • 4 posts

Posted 28 October 2003 - 01:51 PM

It worked just fine. All the partitions are now mounted automatically on startup. Thank you very much for your help laugh




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq