Jump to content
Compatible Support Forums
Sign in to follow this  
boym1

Nvidia Configuration

Recommended Posts

Hello,

 

I am new to linux so forgive me if this a dumb question. Nvidia was set up on my Redhat system and was working then something happened. Now when I boot I see everything on both of my monitors until the point where it goes to the gui login then it changes to one monitor.- arg .. Can anyone tell me how to correct this problem??

Share this post


Link to post
Share on other sites

Hi Michelle,

Seems extremely strange. Two things though. U would do well to list atleast the relevant hardware ( video card, monitor, etc. ) and two, probably re-installing ur graphics driver ( hope ur using the latest one version 4363 ).

If that doesnt help maybe a glance thru the readme or head over to www.nvnews.net or www.nforceHQ.com

Sorry I couldnt be more helpful. Luck with UR stuff.

See ya,

 

madmax.

Share this post


Link to post
Share on other sites

# XFree86 4 configuration created by redhat-config-xfree86

 

Section "ServerLayout"

Identifier "Default Layout"

Screen 0 "Screen0" 0 0

InputDevice "Mouse0" "CorePointer"

InputDevice "Keyboard0" "CoreKeyboard"

InputDevice "DevInputMice" "AlwaysCore"

EndSection

 

Section "Files"

 

# RgbPath is the location of the RGB database. Note, this is the name of the

# file minus the extension (like ".txt" or ".db"). There is normally

# no need to change the default.

# Multiple FontPath entries are allowed (they are concatenated together)

# By default, Red Hat 6.0 and later now use a font server independent of

# the X server to render fonts.

RgbPath "/usr/X11R6/lib/X11/rgb"

FontPath "unix/:7100"

EndSection

 

Section "Module"

Load "dbe"

Load "extmod"

Load "fbdevhw"

Load "glx"

Load "record"

Load "freetype"

Load "type1"

EndSection

 

Section "InputDevice"

 

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))

# Option "Xleds" "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.

# Option "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the

# lines below (which are the defaults). For example, for a non-U.S.

# keyboard, you will probably want to use:

# Option "XkbModel" "pc102"

# If you have a US Microsoft Natural keyboard, you can use:

# Option "XkbModel" "microsoft"

#

# Then to change the language, change the Layout setting.

# For example, a german layout can be obtained with:

# Option "XkbLayout" "de"

# or:

# Option "XkbLayout" "de"

# Option "XkbVariant" "nodeadkeys"

#

# If you'd like to switch the positions of your capslock and

# control keys, use:

# Option "XkbOptions" "ctrl:swapcaps"

# Or if you just want both to be control, use:

# Option "XkbOptions" "ctrl:nocaps"

#

Identifier "Keyboard0"

Driver "keyboard"

Option "XkbRules" "xfree86"

Option "XkbModel" "pc105"

Option "XkbLayout" "us"

EndSection

 

Section "InputDevice"

Identifier "Mouse0"

Driver "mouse"

Option "Protocol" "IMPS/2"

Option "Device" "/dev/psaux"

Option "ZAxisMapping" "4 5"

Option "Emulate3Buttons" "no"

EndSection

 

Section "InputDevice"

 

# If the normal CorePointer mouse is not a USB mouse then

# this input device can be used in AlwaysCore mode to let you

# also use USB mice at the same time.

Identifier "DevInputMice"

Driver "mouse"

Option "Protocol" "IMPS/2"

Option "Device" "/dev/input/mice"

Option "ZAxisMapping" "4 5"

Option "Emulate3Buttons" "no"

EndSection

 

Section "Monitor"

Identifier "Monitor0"

VendorName "Monitor Vendor"

ModelName "Visual Sensa"

DisplaySize 350 260

HorizSync 30.0 - 95.0

VertRefresh 50.0 - 160.0

Option "dpms"

EndSection

 

Section "Device"

Identifier "Videocard0"

Driver "nvidia"

VendorName "Videocard vendor"

BoardName "NVIDIA GeForce 4 MX (generic)"

EndSection

 

Section "Screen"

Identifier "Screen0"

Device "Videocard0"

Monitor "Monitor0"

DefaultDepth 24

SubSection "Display"

Depth 16

Modes "800x600" "640x480"

EndSubSection

SubSection "Display"

Depth 24

Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600"

"640x480"

EndSubSection

EndSection

 

Section "DRI"

Group 0

Mode 0666

EndSection

 

 

 

OK I am really new to linux can you tell me how to get the other information you requested?

 

Thanks,

Michelle

Share this post


Link to post
Share on other sites

NFORCE2: IDE controller at PCI slot 00:09.0

NFORCE2: chipset revision 162

NFORCE2: not 100% native mode: will probe irqs later

ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hda:DMA, hdb:DMA

ide1: BM-DMA at 0xf008-0xf00f, BIOS settings: hdc:DMA, hdd:DMA

 

 

 

i810: NVIDIA nForce Audio found at IO 0xdc00 and 0xd800, MEM 0x0000 and 0x0000,

19:00:02 PST 2003

i810: NVIDIA nForce Audio found at IO 0xdc00 and 0xd800, MEM 0x0000 and 0x0000,

IRQ 5

i810_audio: Audio Controller supports 6 channels.

Share this post


Link to post
Share on other sites
Code:
cat /roc/driver/nvidia/version

this will show driver version here is mine as an example.
Code:
bash-2.05b$ cat /proc/driver/nvidia/versionNVRM version: NVIDIA Linux x86 NVdriver Kernel Module  1.0-3123  Tue Aug 27 15:56:48 PDT 2002GCC version:  gcc version 3.2.2

the driver version is in this case 3123

At a quick glance at your XF86Config-4 you are missing a line in the "Device" section.
Code:
Option "TwinView"

You are also missing the config of your second monitor.
Configuring XF86Config by hand is hard for those with little experience.
I advise you to install a program called "yanc"
http://yanc.sourceforge.net/index-en.html
Its a grafical interface for configuring the XF86Config-4 file, very intuitive.
Once you have this file properly configured I advise that you do 2 things.
first make the file read only by typing as root
Code:
chmod 444 /etc/X11/XF86Config-4

and secondly make a security copy of it on a disk.
I last piece of advice NEVER NEVER execute Xfree as root.

Share this post


Link to post
Share on other sites

Taking a best guess as I do not have the manual for the monitor I entered Horiz freq 30-86 and Vert Freq 50 -150 and i get an error message when attempting to save the configuration with yanc of "No MetaModes definitions found The XF86Config will NOT be saved" What am I doing wrong??

 

 

Also Thank You very much for all your help

Share this post


Link to post
Share on other sites

8)

 

Well I am closer -- I do have a twin view but the functionalty is not what I expected.. It shows my desk top on both screens but it use to let me use the second screen as additional works space Ex I could open a terminal window and drag it to my second monitor and have my email up on my first monitor.

 

Any thoughts??

 

 

Thanks,

Mcihelle

Share this post


Link to post
Share on other sites

you are missing this line in your Device section

Code:
Option"TwinViewOrientation" "LeftOf"

 

As far as the Meta mode goes add:-

1280x1024, 1280x1024 (if you are using 19" monitors).

1024x768, 1024x768 (if you are using 17" monitors).

 

So in Yanc > MetaModes

Values for the 1st monitor

1280x1024 @ 1024x768

Value for 2nd monitor

1280x1024 @ 1024x768

 

please read README ftp://download.nvidia.com/XFree86/Linux-x86/1.0-4363/README.txt

Share this post


Link to post
Share on other sites

Arg - ok I am not getting something correct still.. Now my 1st display can scroll from side to side and nothing is on my second monitor. . I am tired and going home frown Thanks

 

 

 

 

 

# XFree86 4 configuration created by redhat-config-xfree86

 

Section "ServerLayout"

Identifier "D# XFree86 4 configuration created by redhat-config-xfree86

 

Section "ServerLayout"

Identifier "Default Layout"

Screen 0 "Screen0" 0 0

InputDevice "Mouse0" "CorePointer"

InputDevice "Keyboard0" "CoreKeyboard"

InputDevice "DevInputMice" "AlwaysCore"

EndSection

 

Section "Files"

 

# RgbPath is the location of the RGB database. Note, this is the name of the

# file minus the extension (like ".txt" or ".db"). There is normally

# no need to change the default.

# Multiple FontPath entries are allowed (they are concatenated together)

# By default, Red Hat 6.0 and later now use a font server independent of

# the X server to render fonts.

RgbPath "/usr/X11R6/lib/X11/rgb"

FontPath "unix/:7100"efault Layout"

Screen 0 "Screen0" 0 0

InputDevice "Mouse0" "CorePointer"

InputDevice "Keyboard0" "CoreKeyboard"

InputDevice "DevInputMice" "AlwaysCore"

EndSection

 

Section "Files"

 

# RgbPath is the location of the RGB database. Note, this is the name of the

# file minus the extension (like ".txt" or ".db"). There is normally

# no need to change the default.

# Multiple FontPath entries are allowed (they are concatenated together)

# By default, Red Hat 6.0 and later now use a font server independent of

# the X server to render fonts.

RgbPath "/usr/X11R6/lib/X11/rgb"

FontPath "unix/:7100"

EndSection

 

Section "Module"

Load "dbe"

Load "extmod"

Load "fbdevhw"

Load "glx"

Load "record"

Load "freetype"

Load "type1"

EndSection

 

Section "InputDevice"

 

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))

# Option "Xleds" "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.

# Option "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the

# lines below (which are the defaults). For example, for a non-U.S.

# keyboard, you will probably want to use:

# Option "XkbModel" "pc102"

# If you have a US Microsoft Natural keyboard, you can use:

# Option "XkbModel" "microsoft"

#

# Then to change the language, change the Layout setting.

# For example, a german layout can be obtained with:

# Option "XkbLayout" "de"

# or:

# Option "XkbLayout" "de"

# Option "XkbVariant" "nodeadkeys"

#

# If you'd like to switch the positions of your capslock and

# control keys, use:

# Option "XkbOptions" "ctrl:swapcaps"

# Or if you just want both to be control, use:

# Option "XkbOptions" "ctrl:nocaps"

#

Identifier "Keyboard0"

Driver "keyboard"

Option "XkbRules" "xfree86"

Option "XkbModel" "pc105"

Option "XkbLayout" "us"

EndSection

 

Section "InputDevice"

Identifier "Mouse0"

Driver "mouse"

Option "Protocol" "IMPS/2"

Option "Device" "/dev/psaux"

Option "ZAxisMapping" "4 5"

Option "Emulate3Buttons" "no"

EndSection

 

Section "InputDevice"

 

# If the normal CorePointer mouse is not a USB mouse then

# this input device can be used in AlwaysCore mode to let you

# also use USB mice at the same time.

Identifier "DevInputMice"

Driver "mouse"

Option "Protocol" "IMPS/2"

Option "Device" "/dev/input/mice"

Option "ZAxisMapping" "4 5"

Option "Emulate3Buttons" "no"

EndSection

 

Section "Monitor"

Identifier "Monitor0"

VendorName "Monitor Vendor"

ModelName "Visual Sensa"

DisplaySize 350 260

HorizSync 30.0 - 95.0

VertRefresh 50.0 - 160.0

Option "dpms"

EndSection

 

Section "Device"

Identifier "Videocard0"

Driver "nvidia"

VendorName "Videocard vendor"

BoardName "NVIDIA GeForce 4 MX (generic)"

Option "TwinView"

Option "TwinViewOrientation" "Leftof"

Option "NvAGP" "1"

Option "CursorShadow" "1"

Option "DigitalVibrance" "94"

Option "TwinView" "1"

Option "SecondMonitorHorizSync" "30-50"

Option "SecondMonitorVertRefresh" "60"

Option "TVStandard" "NTSC-M"

Option "MetaModes" "1280x1024 @1280x1024,600x600 @600x600;1280x1024@1280x1024,800x600@800x600"

EndSection

 

Section "Screen"

Identifier "Screen0"

Device "Videocard0"

Monitor "Monitor0"

DefaultDepth 24

SubSection "Display"

Depth 16

Modes "800x600" "640x480"

EndSubSection

SubSection "Display"

Depth 24

Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600"

"640x480"

EndSubSection

EndSection

 

 

 

 

 

Section "DRI"

Group 0

Mode 0666

EndSection

Share this post


Link to post
Share on other sites

If your second monitor is a tv which it appears to be you cannot use any resolution above 800x600 depending on exact card model some do support 1024x768.

try in:-

Yanc > MetaModes

Values for 1st monitor

1024x768 @ 800x600

Values for 2nd monitor

800x600 @ 640x480

 

Edit

 

This is a config that I have tryed and works with a 19" monitor and a tv

Code:
Section "Device"    Identifier "device1"    VendorName "NVidia"    BoardName "NVIDIA GeForce (fbdev)"    Driver "nvidia"    Option "DPMS"    Option "TwinView"    Option "SecondMonitorHorizSync"    "30-50"    Option "SecondMonitorVertRefresh"  "60"    Option "MetaModes"   "1280x1024 @1280x1024, 800x600 @800x600"    Option "TVStandard"  "PAL-B"    Option "TwinViewOrientation"       "LeftOf"    Option "NoLogo" "1"EndSection

Share this post


Link to post
Share on other sites

I'll give it a try smile

 

My second monitor is a Magview looks like 15inch listed as VM700E Model 772 100-240v 60/50hz on the back.

 

Have to try this one later.

 

I can not thank you for all your help.. this one just makes working hard the two monitors were great when they were working.

 

Thanks,

Michelle

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×