Jump to content


Photo

LinkSys Router: Internet Access Issue


  • Please log in to reply
3 replies to this topic

#1 Myke

Myke

    enthusiast

  • Members
  • 384 posts

Posted 05 January 2010 - 11:48 PM

I have a remote site that uses a LinkSys Wirelss-G (model WRT54GS) router. The 2 machines out there are hard wired to the router, so wireless security shouldn't be the problem. The router is connected to the an ISP's modem, which is then connected to the Internet.

Here's the issue:

We had to reset the router and reprogram the security and settings into it, as there was a service issue with the ISP, and the router stopped responding properly. After getting everything configured, it looked like everything was working properly. The clients in the office use GoToMyPC to connect to the main office hosts, which they access via an icon on their desktop. This icon automatically creates a connection with the host machine, instead of forcing the user to use IE to log into GoToMyPC.com and then connect manually. This works without a problem. However, the users cannot browse the Internet locally, which doesn't make sense as the GoToMyPC icons work just fine. And I mean they cannot browse at all. Currently, they are using the host machine to browse, which makes for a slow browsing experience, which you can image is frustrating.

Again, this makes no sense. If a client can successfully connect to a remote host, then there is an Internet connection. If this connection exists, then browsing should not be an issue.

The last time this happened, I disabled the firewall on the router, and access was granted. We were so caught up with issues that I never got a chance to revisit the problem. However, I don't want to keep the firewall disabled for obvious reasons. To my memory, I do not think that disabling the client's firewall worked, so it appears to be a setting on the router itself. I haven't tried restricting access to the router via client MAC addresses, but that would restrict any wireless clients that would need access, which destroys the whole point of having wireless access in that office.

I'm hoping that maybe I'm thinking too hard or too outside the box and that there is a simple step that I missed. As always, thank you in advance for any help or insight that you can offer. My apologies for such a long post.

Additional information:
OS: Windows XP Professional SP3 (fully patched)
Default Gateway: normal - 192.168.1.1
Wireless security used: WPA Personal
I swear, troubleshooting is a science: the best discoveries are always on accident...

#2 jmmijo

jmmijo

    veteran

  • Members
  • 1550 posts

Posted 07 January 2010 - 09:30 PM

Have one of these client connections test the DNS outbound from a Gotomypc connection to your local ISP gateway and then to Inet sites like www.yahoo.com and www.google.com

You should be able to ping the DNS addresses, if you can't then that local machine is missing some manual DNS entries or not getting proper resolution from your ISP.

Also, have you tried the OpenDNS server addresses or even the new Public Google DNS addresses yet ???

Some ISP's don't like you to use anything but their DNS servers but sometimes an ISP's DNS servers are not always reliable or updated....
No matter where you go, there you are...

#3 Myke

Myke

    enthusiast

  • Members
  • 384 posts

Posted 07 January 2010 - 11:23 PM

I'm going to try using the public Google DNS servers and see if that works. Thanks for the tip; hadn't thought of that.
I swear, troubleshooting is a science: the best discoveries are always on accident...

#4 Myke

Myke

    enthusiast

  • Members
  • 384 posts

Posted 08 January 2010 - 12:27 AM

Using the public Google DNS servers worked. Unfortunately, this is going to have to be a temporary remedy, as any machine that connects to that network will have to change their DNS settings. I suppose I could set up the router to use a static IP, but I'd like to find a permanent resolution.

Regardless, thank you, jmmijo. At least the clients are able to browse without problem. I appreciate your help.
I swear, troubleshooting is a science: the best discoveries are always on accident...




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq