Jump to content


Photo

I enabld proprtary NVidia driver boots blnk screen


  • Please log in to reply
4 replies to this topic

#1 MarcyDee

MarcyDee

    stranger

  • Members
  • 3 posts

Posted 09 February 2008 - 06:51 AM

My Kubuntu 7.10 (AMD64) boots to blank screen after enabling the nvidia proprietary driver. How can I reset it to the standard linux OS driver? is there any way to force a boot to "Last known good configuration"?

TIA for any suggestions...

#2 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 11 February 2008 - 11:08 AM

I have not played with Kubuntu in a while, but I will give it a shot.

Let us be clear. You installed the drivers from the NVIDIA web page and not the Ubuntu drivers from the repository?

Did you install the correct drivers for your video card model?

Do you have a live CD of any Linux distro available, or another flavor of Linux installed on the system?
"I love it when a plan comes together." - Hannibal Smith

#3 MarcyDee

MarcyDee

    stranger

  • Members
  • 3 posts

Posted 12 February 2008 - 02:51 AM

Thank you, and Hello Danleff,
I actually merely downloaded (and after many times remembering that it might be risky, and NOT enabling) the NVidia proprietary driver, I believe from the kubuntu (ubuntu) repository.
After I forgot my concerns for one short second, and "Enabled" it in the section controlling the non-free drivers, I lost it all when I rebooted.
I do have a ubuntu bootable disk that I can use to look at the HDD directories, but the system will not let me change anything.
It appears that, IF I could, - changing the xorg.conf.1 file back to xorg.conf would make this boot as it used to. The system will not allow me to do that, whether I boot to the ubuntu CD, or boot the kubuntu into recovery mode and use the terminal.
The system has kubuntu V7.10 installed.

#4 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 12 February 2008 - 11:52 AM

Take a look at this Ubuntu thread

Read it carefully, especially Tuxcantflys posts. You have Kubuntu, so take note of the gdm vs. kdm starts of the gui.

The last post suggestions should work getting into gedit and changing the nvidia entry to nv or vesa.

Quote:

anyhow, use sudo /etc/init.d/gdm start

as for the fallback drivers, do this:

sudo gedit /etc/X11/xorg.conf

find the line that says "nvidia" under the section "device"

change it to "nv"

then do sudo /etc/init.d/gdm start


Hopefully this will get it going.
"I love it when a plan comes together." - Hannibal Smith

#5 MarcyDee

MarcyDee

    stranger

  • Members
  • 3 posts

Posted 13 February 2008 - 05:23 AM

Hello and MANY thanks,
I was finally able to get this. The "gedit" program is NOT on this system. I did some looking for "info commands", and found that the editor is called "nano" on this version of kubuntu. I am not sure if this also is true on installations of ubuntu V7.10, but this finally got me started.

THANK you again,

I truly appreciate it....
MarcyDee




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq