Jump to content


Photo

New install of Ubuntu 5.10-No internet connection


  • Please log in to reply
9 replies to this topic

#1 dannyBee

dannyBee

    stranger

  • Members
  • 6 posts

Posted 15 November 2007 - 02:52 AM

Hi —

I've just installed Ubuntu 5.10 on a Compaq Armada M700 laptop. The installation went smoothly, except that I can't connect to the internet—the connection times out before any connection is made. The ethernet connection is set to Active, and network settings are set to DHCP (I'm working off wireless router with a cable (no wireless card). I've checked with my ISP to see whether my settings are correct, she assures me they are—says it must be I need a patch. Is this a patch issue? What am I missing? (Need I add that I'm 100% new to Linux?)

Thanks for any suggestions,
DJB

#2 cantabile

cantabile

    stranger

  • Members
  • 5 posts

Posted 15 November 2007 - 11:50 AM

Your ISP should be able to see if anything is going on their end. Try pinging their server if your ISP is one that does not block pinging. I presume because you've installed Ubuntu that you are reasonably experienced. If your installation was from a burned disk, it may be worth checking that there is no corruption in your files. I believe you can have this checked, but I have never done this so perhaps someone else out there can advise.

#3 dannyBee

dannyBee

    stranger

  • Members
  • 6 posts

Posted 15 November 2007 - 05:52 PM

Thanks for your reply—I've got a connection through the modem/router (both of which I've reset a couple of times, with no luck, still) with two other machines, so I know the connection is good.

Sudo lshw shows the ethernet port, and system monitor shows very small (50kb) receive activity if I try to open a website, but it's only a little spike before it returns to the flatline.

How would I determine whether there was corruption in the install disk?

Thanks for any help,
DJB

#4 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 16 November 2007 - 11:43 AM

It is unlikely that there was corruption in the installation disk, if Ubuntu installed all the way. Otherwise, it would not have allowed a complete installation. The problem is more likely how your connection is set up.

Is this ISP's truely dynamic, or on all the time?

Are you required to log into the connection?

When you say that that the ISP rep. said that your settings are fine, what do you mean? What settings? Static or dynamic?

If you are connected all the time, say by cable like RoadRunner or Verizon Fios, then you only need to set auto DHCP and allow the software to find a valid IP address. This assumes that the correct driver (module) is loaded at boot time.

I don't use Ubuntu much, but you can also check the status of your settings (and if they are working) by typing into a console (terminal) window, the command;

sudo ifconfig

This will give you information about such things as if an IP address is set etc. What does that show?

Many ISP providers don't know much about Linux and an easy out is to say that you may need a patch.

Also, you can check to see if the module is working for the internal LAN card. It should work, from what I have read about this laptop, if the module (driver) is loaded automatically at boot time.

I think your card may use the eepro100 module. You can use the command in a console sudo modprobe eepro100 to see if it is loaded. If you just get a return to the command prompt, then see if the connection works.
"I love it when a plan comes together." - Hannibal Smith

#5 dannyBee

dannyBee

    stranger

  • Members
  • 6 posts

Posted 16 November 2007 - 04:23 PM

Hi danleff -

Thanks for your help. About my connection: the network settings are DHCP, and I don't have to log in to the connection—it's always on through the modem/router, and I've got two other machines getting internet off that router, so I know it's not a network issue. As far as my computer, eth0 is active and the connection is set to DHCP, but no matter what I do (restarting machine, restarting modem & router) there's still nothing doing if I try to load a website.

Here's the output from sudo ifconfig:

Eth0
link encap: Ethernet HWaddr 00:D0:59:15:74:30
inet addr: 192.168.1.2 Bcast: 192.168.1.255 Mask: 255.255.255.0
inet6 addr: fe80::2d:59ff:fe15:7430/64 Scope: Link
UP BROADCAST RUNNING MULTICAST MTU:1500 MEtric: 1
RX packets: 33 errors: 0 dropped: 0 overruns: 0 frame: 0
TX packets: 43 errors: 0 dropped: 0 overruns: 0 carrier: 0
collisions: 0 txqueuelen: 1000
Rx bytes: 3827 (3.7 kiB) TX bytes: 367 (3.5 KiB)

lo
Link encap: local loopback
inet addr: 127.0.0.1 Mask: 255.0.0.0
inet6 addr: ::1/128 Scope: Host
UP LOOPBACK RUNNING MTU: 16436 Metric: 1
RX packets: 8791 errors: 0 dropped: 0 overruns: 0 frame: 0
TX packets: 8791 errors: 0 dropped: 0 overruns: 0 carrier: 0
collisions: 0 txqueuelen: 0
RX bytes: 673814 (658.0 Kib) TX bytes: 673814 (658.0 KiB)

modprobe eepro100 did in fact return me to the prompt, but I still don't get anything loading. I did ping www.hotmail.com yesterday, and that went out and back, but other pings did not. Still, nothing but the 'about Ubuntu' startup page displays. Everything else times out.

So. I was beyond my expertise when I started this little project, and even though I've learned a lot about the ins and outs of internet connections, this issue is still beyond anything I understand--any suggestions would still be greatly appreciated.

Cheers,
DJB



#6 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 17 November 2007 - 08:48 PM

Sounds like you did learn a lot! I'm a bit rusty on Ubuntu, but it looks like you have aquired an IP address. I wonder if there is a firewall issue.

What I did find by googling, is that this version of Ubuntu had issues with this LAN card (Intel). The posts seem to indicate that using a newer version of Ubuntu seems to solve the issue. Apparently there are some issues with this version and that LAN card. So, this invalidates my comment about a patch not being needed! Unfortunately, there is no mention of a patch that I can find.

Any chance in trying a newer version of Ubuntu?
"I love it when a plan comes together." - Hannibal Smith

#7 dannyBee

dannyBee

    stranger

  • Members
  • 6 posts

Posted 18 November 2007 - 04:43 PM

Thanks for help—I really love that Linux is an operating system and a network of people. None of my calls to Microsoft—or even Apple-have ever been this helpful...

So it seems like 5.10 is just not going to work with the card I've got—so here are my questions:

I found a forum that mentions a workaround —

"I got around the problem by using route, and now internet is working:

sudo route add -net 128.193.136.0 netmask 255.255.248.0 dev eth0
sudo route add default gw 128.193.136.1"

— but I tried this, and the output said that 'netmask doesn't match route address. (Is that the problem?) I took that netmask value from the output of ifconfig, above (previous post). I ran 'route add default' with the gateway address, but the output said that the route already existed.

—I tried reverting to 5.04 (I don't have enough RAM for 6.06 or above) and the issue persists.

Do I now:

a) get the machine above 256M of RAM and install 6.06 or higher?
B) try a different LAN card? (can you swap these out?)
c) keep researching the networking bug before I do either of these? (i.e. what is the likelihood that this is just a breezy badger issue, and not an issue I'll experience no matter what version I'm using?)

Again, thanks a ton for your help.
DJB

#8 dannyBee

dannyBee

    stranger

  • Members
  • 6 posts

Posted 20 November 2007 - 06:59 PM

PS—I found a way to install a newer version of Ubuntu--Xubuntu is the lightweight version, and I have enough RAM to install it, so I installed it last night. Still no connection, although I can ping some servers and get a response.

One forum discussion about this problem led met to think that it might be the application—switching from Firefox to Ephiphany seemed to be the answer, although that was on a Mac.

Is there a surefire way to determine that this isn't a hardware problem? If ifconfig shows eth0 as activated, is that enough? I don't mind installing a different flavor of Linux (Slackware seems to work well on this particular machine) but I'd like to rule out the hardware before I keep downloading iso files, burning them to disks, and installing them on this very patient computer.

(This is all just the first step: then I still need to install cabextract and wine and IE4Linux, all so I can run the one program that won't run on my Mac.)

Anyway, thanks for all your help so far. I'll let you know if I stumble into any solutions.

Cheers,
DJB

#9 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 22 November 2007 - 10:25 AM

What happens when you run;

sudo route add -net 192.168.1.2 netmask 255.255.255.0 dev eth0

Hmmm...Compaq proprietary hardware!
"I love it when a plan comes together." - Hannibal Smith

#10 dannyBee

dannyBee

    stranger

  • Members
  • 6 posts

Posted 22 November 2007 - 04:58 PM

netmask doesn't match route address.

Can I work with that?

Thanks again...




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq