Jump to content


Photo

Dual Boot problem, 2 HDDs 1-XPpro 2-FC5


  • Please log in to reply
7 replies to this topic

#1 ohbon

ohbon

    stranger

  • Members
  • 6 posts

Posted 23 April 2007 - 12:00 AM

I need advice with finishing installing FC5. During installation when it goes to reboot, XP loads and I do not get an option.
Two HDDs
Master-Active-XPpro
Slave-FC5
I did choose for GRUB to be in MBR.
2nd drive shows Slave as empty with RAW file type.
What do I do next? Thanks greatly.


#2 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 23 April 2007 - 09:38 AM

You most likely installed the Linux bootloader on the secondary drive, not the MBR of your boot drive. See my article here.

Quote:
2nd drive shows Slave as empty with RAW file type.


What utility did you use to view the second drive? If from within Windows Computer Management, undersand that Windows does not see the partitions as you would expect.

What type of filesystem did you select during the FC5 installation? The default?

Are both your hard drivers IDE drives or one or both sata drives?

Let us know if this helps.
"I love it when a plan comes together." - Hannibal Smith

#3 ohbon

ohbon

    stranger

  • Members
  • 6 posts

Posted 26 April 2007 - 03:13 AM

Oops. Pressed the wrong key.
"Remove all partitions". Selected GRUB on /dev/hda. Fedora as default.
Both HDD are IDE on a Gateway Desktop.
I read the article, still no dual boot options. It still goes straight to XP.


#4 ohbon

ohbon

    stranger

  • Members
  • 6 posts

Posted 29 April 2007 - 05:36 AM

I got into the linux rescue and chroot /mnt/sysimage, and type grub-install /dev/hda. It responded with.../dev/hdb1 does not have any corresponding BIOS drive. So i tried the grub bug changes...It responded Error: 23 error while parsing number. I'm stumped.

#5 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 29 April 2007 - 09:33 AM

As I suspected, Fedora treated the installation, as you did it, as if you had one hard drive in the system.

So now you have Grub booting, but with an error, as both drives are not set up in the /boot/device.map file for Grub.

Try getting back into rescue mode and chroot, then try;

grub-install --recheck /dev/hda

...and see what happens when you reboot.

All this assumes that the second hard drive is primary slave, as you said.
"I love it when a plan comes together." - Hannibal Smith

#6 ohbon

ohbon

    stranger

  • Members
  • 6 posts

Posted 01 May 2007 - 11:50 PM

Failed. No such file or directory.
I have found if I press F8 while startup I get the boot option but with only the option for XP to choose from.

#7 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 07 May 2007 - 08:28 AM

Did you get into the chroot enviroment, using the Fedora 1st install disk before trying the fix?

After booting to the command menu;

linux rescue

then when you get to a command line, after making sure you are root user;

chroot /mnt/sysimage

The syntax is also very important, so check it carefully.

grub-install (space) --recheck (space) /dev/hda

Quote:
I have found if I press F8 while startup I get the boot option but with only the option for XP to choose from.


Do you mean that you get the Windows safe mode by pushing f8 while the system is booting, or otherwise?

Look at this thread for a detailed synopsis.
"I love it when a plan comes together." - Hannibal Smith

#8 ohbon

ohbon

    stranger

  • Members
  • 6 posts

Posted 19 May 2007 - 09:49 PM

Ah, finally it is fixed.
I enter the /boot/grub/ file and the boot/grub was commented out. So I uncomment the line and everything is working fine. Thanks for your help.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq