Jump to content
Compatible Support Forums
Sign in to follow this  
boota

dual boot RH9/winxp problem

Recommended Posts

my primary harddisk has xp installed and on secondary i installed RH9. when i opted for partitions to be made on existing free space i got a message that /boot may not be compatible(something like that) and it is strongly recommended to make a bootable disk. that i did nt make. now i am not getting the option to opt either linux or xp. it just boots xp by default. what should i do

Share this post


Link to post
Share on other sites

The first thing to consider is if your hardware is supported in RedHat 9. It is no longer supported ny RedHat, because of the distro's age. If you have fairly new hardware (say made in the last 2-3 years) then this is not a good choice for you.

 

Secondly, when installing to a second hard drive on the system, you must tell Grub (or whatever bootloader being installed) to place the bootloader on the primary disk, which always boots your system. In your case, this is the XP disk.

 

If you know how to do a rescue boot using the first installation CD, then you can probably reconfigure the bootloader.

 

But first, is this what you want to do, considering your system and it's hardware?

 

So, the questions are;

 

1. What hardware are you using? If older and supported by RedHat 9, then;

 

2. What bootloader are you using, Grub?

Share this post


Link to post
Share on other sites

thanks for replying so soon...

i am using amd 4200+ with asus m2tvm board and 256 nvidia geforce card...512 mb of ram... sata 80 gb as primary and 40 gb seagate baracuda as secondary...

 

everything is supported other than my graphics card but it still manages to go fine...

i am using grub...

 

before this i installed FC6 but it removed xp boot option and it just started to boot FC6. then i tried to update my xp but still it didnt worked. if u can tell me how to manage this prob then i will say goodbye to rh9... because FC6 loaded my graphics fine and there was no problem abt the graphics card but just booting prob was there...

 

Share this post


Link to post
Share on other sites

Sounds like you are going in circles with this one. Let's go step by step.

 

When you say that FC6 removed your boot option to boot into Windows, is it really gone, or did the system just boot to fast into FC6? The default is about 5 seconds. Yes, you can change this.

 

Also, if you unchecked the option to boot into XP during the installation phase where you are asked what default boot to use, this could be a problem.

 

Is there an entry in the /boot/grub/menu.lst for XP?

 

Take a look at my guide on FC5, located here. This should get you started.

 

Pay special attention to the section on sata drives, as you gollow through the pages.

 

When you say that you updated Windows, what do you mean by this? Do you mean that you replaced the bootloader, or reinstalled XP?

Share this post


Link to post
Share on other sites

I had not checked /boot/grub/menu.lst for XP option as i didnt know abt it...

right now i hav removed fc6. let me reinstall it and then i will get to u for assistance. for the time being i am lookin ur guide...

 

well i tried to repair my xp. and when the setup restarted first time after copying setup files even then it loaded fc6 by default and there was no menu to select from, the OS not for even single second...

 

i must tell u that this dvd of fc6 was sent to me by third party (partner of the developers of fc6)...

 

thats y i removed fc6 as i am currently user of windows and i am learning linux and another reason is that its my studies req...

 

now what should i do to install bootloader in my c: drive as it is sata hard disk and having winxp. and i am installing linux on another hard disk having free space.

Share this post


Link to post
Share on other sites

The first thing that you need to do is stop trying to install and reinstall your operating systems. We need to exactly what you have doone so far. At first you said;

 

Quote:
now i am not getting the option to opt either linux or xp. it just boots xp by default.

 

This led me to believe that you installed Fedora totally to the second hard drive, along with the /boot partition created during the process.

 

However, then you apparently tryed a repair install of XP, which failed. Now you are getting...

 

 

Quote:
well i tried to repair my xp. and when the setup restarted first time after copying setup files even then it loaded fc6 by default and there was no menu to select from, the OS not for even single second...

 

How did you "remove" Fedora, by just reformating the second hard drive? If so, this will not work IF you actually changed your bootloader to reside on the primary boot drive. in this case, the Grub bootloader is still resident on the MBR of the sata drive and needs Fedora to boot.

 

Let's look at what happens. When you get to the installation screen that allows you to set up your drive(s) you must use caution. If you read my article, then you know that you must pass special directions when installing to a second hard drive. If you did not uncheck your sata drive when partitoning your hard drive and allowed Fedora to alter the sata drive, then a /boot partition may have been created on your sata drive. In this case, then your master boot record could have been altered by the creation of this /boot partition.

 

When you installed Fedora, did you uncheck the sata drive, so that any changes did not affect that drive, but only the second hard drive, that you wanted to install Fedora to?

 

Let us know where you are exactly at this point.

 

Also, you should be able to recover XP's bootloader using the Windows Recovery Mode, if need be. This assumes that you know your admin. password for Windows.

 

But remember, you have tried installing multiple operating systems now on the system, so it is hard to determine what you did during all these install attempts.

 

Share this post


Link to post
Share on other sites

i hav just installed FC6 and now i am not getting my fedora. my system just starts winxp as i start the computer...

 

i checked the /boot/grub/menu.lst for XP and it states something like this...

 

.......

some lines with # in start

.......

default=1

timeout=5

splashimage=(hd1,6)/grub/splash.xpm.gz

hiddenmenu

title Fedora Core(2.6.17-1.2798.fc6)

root(hd1,6)

kernel /.......

quiet

initrd /initrd .....

title winxp

rootnoverify(hd0,0)

chainloader+1

 

i should tell u that i selected the harddisk on which i installed fc and unchecked other harddisk. and when it came to chose default OS booting i selected other and edited it with name winxp and other thing was it's partition was being shown on the same harddisk on which it was gonna installed but bootloader was being installed on the drive with MBR means on which i installed xp.

 

right now i am using linux rescue command....

help me plz...

can i get ur timings to come online so that i can catch u when u r online and ur msn messenger id...

i wil be grateful to u...

 

Share this post


Link to post
Share on other sites

Your bootloader is not installed correctly. It is pointing to the right drives, but is installed on the second drive, not the boot drive? The commented out lines would have told us that.

 

Look at figure 7.2 of my guide here.

 

Does the statement on the top of the bootloader configuration screen say Install bootloader record on /dev/hda Master boot record?

 

Or did it say /dev/sda, which is the sata boot drive?

 

If hda, then it is installed to the IDE drive or the secondary drive on the system.

 

This is why Fedora does not boot and XP comes up.

 

Try getting into rescue mode (root user) and chroot to the installation.

 

Then follow the directions here, but make sure that you point to the sata drive as such;

 

grub-install /dev/sda

 

Share this post


Link to post
Share on other sites

well man i hav just took off the flight on fc6...

i just used grub-install /dev/sda

it gave no error but when i restarted it just had written GRUB on top left corner of the screen and nth else...

 

then i again checked menu.lst and just removed the hash (#)from

12th row and it worked fine...

i am sorry i did not giv u this code because i didnt hav that code with me and did not noted it...

 

 

# grub.conf generated by anaconda

#

# Note that you do not have to rerun grub after making changes to this file

# NOTICE: You have a /boot partition. This means that

# all kernel and initrd paths are relative to /boot/, eg.

# root (hd1,6)

# kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00

# initrd /initrd-version.img

boot=/dev/sda

default=1

timeout=10

splashimage=(hd1,6)/grub/splash.xpm.gz

hiddenmenu

title Fedora Core (2.6.18-1.2798.fc6)

root (hd1,6)

kernel /vmlinuz-2.6.18-1.2798.fc6 ro root=/dev/VolGroup00/LogVol00 rhgb quiet

initrd /initrd-2.6.18-1.2798.fc6.img

title WinXP

rootnoverify (hd0,0)

chainloader +1

 

 

 

thanks its fine now and i also installed speedtouch 330 and now i am using net from fc6. thanks once again... will come to u with some other prob later on...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×