Jump to content


Photo

USB Device Not Recognized (Malfunction)


  • Please log in to reply
227 replies to this topic

#181 EBates

EBates

    stranger

  • Members
  • 2 posts

Posted 12 April 2009 - 05:13 AM

Today I spent most of the morning and into the afternoon trying to get her USB ports to work (Xp pro Desktop). Uninstalled all USB ports, rebooted, No Luck. Reinstalled the mobo mfg provided Drivers. Fumbled around in the Registry, ran various registry tools, but still in Device Manager, I had one USB port with Unknown Device on it and a nagging windows popup saying that the USB stuff had a problem (Gee, I iddn't already know that, You Stupid @#$%#@$. The port would not delete or uninstall and caused the computer to "freeze" during shutdown.
After reading the posts in this forum, I unpluged the power cord let it sit for 30 minutes, and fired that puppy up. I'm proud to report she's purrin' away and momma bear now has moved on to other things to crab about. Thank Ya Lord, and you Good Folks!!

Good Luck
EBates

#182 LEM0N

LEM0N

    stranger

  • Members
  • 1 posts

Posted 02 May 2009 - 10:37 PM

Just wanted to add that the above fix worked for me also. I only uninstalled all USB ports, then powered down, unplugged, and took out the battery. Left it overnight. Booted up this morning and it's working perfectly again. Many thanks to the posters here who contributed!

#183 Brent Newland

Brent Newland

    stranger

  • Members
  • 1 posts

Posted 06 May 2009 - 07:55 AM

I had another computer I serviced in the past that had this issue and I successfully repaired it, but don't quite recall how. I have another one with the same problem that I'm working on right now (remotely) so as soon as I narrow down the solution I'll post.

I'm pretty sure what fixed it for me was resetting all the registry and file permissions in windows. The directions are at http://www.winhelpon...-in-windows-xp/ (under SubinACL) but you need to add the following two lines to your command script:
net localgroup Administrators Local Service /ADD
net localgroup Administrators Network Service /ADD

Otherwise you could have some strange problems. Right click on the command file you made and see if there is an option to "Run as Administrator" (vista) or "Run as..." (xp). Choose either option; if running XP, click that and in the new window that pops up uncheck the "Protect my computer..." check box.


I think the problem is that some part of windows locks the registry to access it and won't let anything else change those keys afterwards; thus, when you want to remove or add a device you can't remove the configuration info in the registry.


Other than that, I do recall right clicking on all the USB devices and uninstalling, but also checking the box to delete the driver (which removes files on the PC and deletes registry info) - but that's vista only.

I may have also manually gone into the registry to delete all the keys matching my USB device ID's, but not sure if I followed through or if it worked or not.

You can also try running Dial-a-Fix, and maybe downloading and installing DriverMax (check bugmenot.com to bypass their annoying registration process). DriverMax will check for updates available for drivers on your computer.


And here's a summary of other people's fixes:

Quote:
In regedt32 go to: HKEY_LOCAL_MACHINE\System\CCS\Enum\USB.

Look in each folder labeled Vid_Xxxx. There should be subfolders containing information about one of your USB devices in each.

Right click on the Vid_Xxxx folder that contains a folder labeled 'Unknown Device' in it and click Properties.

Check Allow Full Control, then right click on the same Vid_Xxxx folder and delete it.


Quote:

I was going to go into c:/windows/system and delete the usbport.sys


Quote:

1)Delete the follwing folders and its contents ( if found) in the :
HKEY_LOCAL_MACHINE\SYSTEM\CURRENTCONTROLSET\ENUM\USB\Vid_xxxx
Note:You need to set permission to delete the folder Vid_xxxx
Right Click on the Vid_xxx and set permission and then do the delete.

2)Go to:
HKEY_LOCAL_MACHINE\SYSTEM\CURRENTCONTROLSET\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services

Check if there is a key name USB, if its not there then create a new key USB

If key found check for any DWORD value name as DisableSelectiveSuspend
if found then set its dword value as 1. If not found, then create a new DWORD value and name it: DisableSelectiveSuspend
Add the value as 1 to it.

3) Check for any chipset driver/inf update available for your motherboard. If found any, do a update them. To know what motherboard and chipset your system has, go to http://www.cpuid.com/ and download the cpuzid utility. a simple good utility to identilfy the chipset and etc. Using the info you can google for the chipset updates.

4) Restart your computer after all these been done. Restart even if there is no chipset drivers to update.
5) go to Start - Run and type in :"devmgmt.msc"(without quotation)and click OK. Device Manager will pop up.

5) In the Device Manager, scroll down to usb serial bus controller. uninstall everthing you see there.

6) now scroll to system devices ( pls note in the System devices, the names may not be exactly the same as listed below)You will be prompted at certain uninstallation to restart, dont restart, keep uninstalling all those in the system devices. At times while you are uninstalling, u will see some getting installed again. No worries. Here is the folowing to uninstall from the System devices:

PCI Bridge
SMBus controller
Microcode Update Device
PCI bus
Plug and Play Software Device Enumerator
System board

7)Once all these is done, restart you pc.
Let the system update and install for hardware found automatically.

8)Once all is done, restart your computer again

9) wait for the system to settle down with all the windows start up process. after a while, plug in your USB device.

10) Windows will detect it perfectly and you wont see the "USB Device Not Recognized".


#184 DJ_Moral

DJ_Moral

    stranger

  • Members
  • 4 posts

Posted 08 May 2009 - 10:30 PM

I am having the same issue also. The source of my problem was a lexmark all in one printer. It froze during a scan and I was forced to end the program, ever since then all of my usb stuff other than my mouse has that annoying bubble pop up.

Ive tried everything on that link, but to no avail. Ill soon follow the most recent instructions on this post just above me.

this sucks, no ipod for me frown

I will definately follow this topic... because my laptop is no longer under warranty AND i dont have a completely legal copy of an OS if you knwo what I mean... lol

#185 bernardc

bernardc

    stranger

  • Members
  • 1 posts

Posted 10 May 2009 - 07:02 PM

After replacing the motherboard and reinstalling Windows, I still had the error. Then I found the trouble: The Das Keyboard. WTF? With it plugged in, USB Device Not Recognized every time for any other USB device. With it NOT plugged in, everything works perfectly. And this is perfectly repeatable.

So one thing to check right away, maybe first: Unplug all unneeded USB devices, and change out the keyboard and mouse.

#186 woofer

woofer

    stranger

  • Members
  • 1 posts

Posted 10 May 2009 - 11:02 PM


The problem is NOT in your operating system ! (that is why reinstalls of the O/S, or changing this or that in the registry, unistalling things in device manager or redetecting them, etc, have not consistently worked).

THE PROBLEM causing repeated "usb device not recognized errors" ORIGINATES WITH YOUR MOTHERBOARD !, specifically the USB chipsets or I/O controller there.

I know because I had this problem a couple years ago and tried everything (like the kinds of things in this forum) to no avail. Finally, completely by chance I was on the phone to an Intel support rep about some other question or problem (I have an Intel DG965WH motherboard), when near the end I mentioned something about this - he told me do to something, and that cleared up the USB problem completely ! Unfortunately I do not remember what that something was (it may have been changing some setting in the bios (maybe disabling something there) - I don't think it was reinstalling chipset drivers or flashing the bios).

Now, 2 years later, plugging in my HP printer (which has worked fine many times), the problem reappeared, which brought me to google things and to this forum. (note I did find a post I saved from 2 years ago where along with some instructions similar to what I've seen on this board, someone said "there is a problem with intel usb chipsets going flaky", which supports what I am saying - this does not mean the problem is unique to intel though).

So that is the very valuable info I am giving everyone here -it's not a software problem in your O/S, but a motherboard problem ! Like I said, unfortunately I do not remember specifically what was done before, so I am the same boat as everyone else. But hopefully this can encourage people to look to the motherboard instead of the operating system, and post some of their experiences and possible solutions.

#187 DJ_Moral

DJ_Moral

    stranger

  • Members
  • 4 posts

Posted 11 May 2009 - 03:29 AM

I just dont understand why this happened though. What could possibly have changed due to a program using a USB device freezing?

It does not make sense. Ive yet to try and fix this problem again since USB isnt the most important thing I have on my laptop (now if my wlan adapter was messing up that would be a different story!!)

This is just one big headache, but I am glad this thread is still alive. My one hope is here.

Woofer, you should call someone up (me being the lazy bastard I am) and try and find out what you did to fix the problem. I am somewhat experienced in normal software/settings and stuff, but when it comes to bios and firmware and all that other stuff I am completely lost in tryign to trouble shoot it myself.

#188 DJ_Moral

DJ_Moral

    stranger

  • Members
  • 4 posts

Posted 16 May 2009 - 05:20 AM

Alright guy's heres my update.. I havent even tried using any new things, nor have I even tried using usb... Well I JUST tried my flashdrive and it works again so I guess the problem fixed itself.

cool

#189 DJ_Moral

DJ_Moral

    stranger

  • Members
  • 4 posts

Posted 20 May 2009 - 04:20 AM

nevermind, everythign works but the ipod... but when i had my flashstick in, I took it out and put in my shuffel really quick and all it told me was taht if it was in a 2.0 usb port it would go faster, so I guess I can trick it to make everything work.

#190 GokuGT

GokuGT

    stranger

  • Members
  • 2 posts

Posted 27 May 2009 - 02:09 AM

Hello everyone, i've got the same issue, but its been like 6 months since this issue came up, i remember it started after i updated the bios, i did it directly from the hp web page, i've tried everything. removing the unknown usb from device manager, the hiden and non present ones, system restore, i even bought an expresscard with usb as output but happened the same sh...t when i tried to plug in the usb it said device not recognized!!!! last thing i tried was to remove all unknown usb from device manager and then remove all of the usb vid registry keys all of this under safe mode and then i turn off the laptop, unplugged from energy, removed the battery and left it the whole night like that but when i woke up and turn it back on !!!still the same sh..t!!!! i really dont know what else to do. Please someone help me.

Also the pc came with this webcam and it stop working at the same time this started, and it is the first device unknown my computer displays so maybe this has something related to as it is usb, the hub says 8 ports and i just have 4 visible.

HP Pavilion dv9428nr
AMD Turion x2
Windows Vista Home Premium

PLEASE HELP..!!!!!!

#191 and_how

and_how

    stranger

  • Members
  • 1 posts

Posted 27 May 2009 - 04:19 AM

the power in my house was recently turned off, when it was turned back on my computer wouldn't turn on. i took it to a pc shop and they opened it up to take a look. they did a test on the power supply and it failed, so i bought a new one. when i brought my pc back to get the new power supply installed, the old one pasted the test. the guy removed all the wires running from the power supply, and then reconnected them. when he hooked everything up the computer would turn on. now whenever i put something in the usb the error "USB device not recognized, one of the usb devices attached to this computer has malfuctioned and windows does not recognize it." comes up. not only that but it will come up even if nothing is plugged in. under device manager two unknown devices are always present. it happens to every usb device i have and on all the usb ports. also when the computer is off it does not turn on right away when you push the power button, i have to push it, let go, hold it in, let go, hold it in, push again, and it will come on (not the exact sequence, but about). i have tried all the things i could find on the web and nothing works. i have vista 32 bit, mci mother board, intel d core 3.0ghz. i dont much about computers and cant speak greek.

#192 GokuGT

GokuGT

    stranger

  • Members
  • 2 posts

Posted 28 May 2009 - 07:13 PM

Anything???

frown

#193 malloy

malloy

    stranger

  • Members
  • 1 posts

Posted 09 June 2009 - 10:39 AM

Hullo! Hope people still read this thread.

I am a new member of this not so exclusive club where the price of admission, sadly, is a non working USB device.

Was running a four year old generic Xp Pro machine 2.4Pentium with 768MB RAM on an Asus board. Have a year old HP laserJet 3050 running smoothly until last week when I got the "USB device not recognized" message. Tried to reinstall the software, installation would not continue. Tried installing on a Toshiba Satellite running Vista Basic laptop same thing.

- Got the updated drivers for vista, no go.
- unlplugged the machines a few hours, no good
- copied and recopied the USB inf files on system 32
- made a new entry inregistry with the key on both machines
- tried fixing the XP with the fix me patch on microsoft, no good
- deleted the USB control panel entries manually in safe mode

I've done just about everything short of getting on my knees and praying for it to work. If I had bottomless pockets, I'd take a hammer and a blowtorch to the machines and
FeEex the remains back to Microsoft.

Also checked out the windows MSDN dev't site, none of their fixes worked!

I have used the same HP printer on an old Compaq 5423 US series with USB 1.1 ports running Windows XP for over a year without any problems. had to migrate to another system since the old Compaq crashed and WINDOWS REFUSED TO BE REINSTALLED, but that is another story.

had a replacement USB cable on hand just in case. Printer works fine and detected sans any drama on another PC with Linux Puppy 4.2 and Kubuntu 9.04.

The funny thing is, I tried the HP printer on a Windows 98 Compaq circa 1999 machine and it worked! All other USb devices such as USB modem, camera, flash disks, so far ( but I'm keeping my fingers crossed) still work.

This is obviosly a windows XP, Vista and USB 2.0 problem. Those top level employees and developers at Microsoft probably just buy new hardware when they encounter this and sweep it under the carpet. Everyone knows MS software is full of bugs but this is unbelievable!

#194 Ute Pass

Ute Pass

    stranger

  • Members
  • 1 posts

Posted 07 July 2009 - 07:22 PM

Of all the forums I have screened in researching this problem, this forum is the most up to date. After spending 5+ hours searching the internet, it seems that this problem has been around for about 4 1/2 years and Microsoft still hasn't addressed it.

The problem appeared on my computer last month (June 2009) after i tried to install a new TrekStor MP3 player. This was the 4th MP3 player i have installed over a 3 year period. Now none of my MP3 players will work on my main computer running XP SP3. However, they do work on a laptop running Windows 2000. This tells me it has to be an OS related problem.

Now today, the XP computer stopped recognizing flash drives and my digital camera.

#195 JayDeeCW

JayDeeCW

    stranger

  • Members
  • 1 posts

Posted 16 July 2009 - 07:52 PM

I had this problem, but only with one device, my USB mouse. It happened no matter which port I plugged it into, and other USB devices - such as my keyboard or external hard drive - worked fine in all USB ports.

I tried a lot of different things, including most of the things suggested in this thread, but none of them worked. I was inspecting the USB connector on the cord to see if it was dirty, and compared it to the USB connector for my keyboard to see if one was dirty and the other wasn't. I saw that the metal part of the connector for the mouse was slightly bent outwards on one corner, and figured this may be causing it. I got a pair of pliers and squeezed that bent section back in. The connecter fit more snugly into the port and now the DNR problem was gone.

I think for most people this is not the problem, since most are saying that the problem is for all devices and in all ports. Some people have posted saying it's only for one device though, and in those cases you may want to compare the USB connector to a USB connector for another device, and see if the one that isn't working is bent or broken in any way. If it is, you may be able to use pliers to squeeze the dent in or pull it out.

#196 darksymphony

darksymphony

    stranger

  • Members
  • 1 posts

Posted 19 July 2009 - 10:41 PM

Hi,

Just wanted to add my voice to the chorus of dismay in this thread... I've had exactly the same problem. Can't believe it's been going on for so many years with no fix.

I don't know if it was a surge of electricity, but for me it could well be that something got "fried". Last night I plugged in a new mp3 player and my laptop froze up. Usually when my laptop freezes it comes back to life again after a while, so I decided to just leave it be and went to bed. After a while, though, the speakers began making a weird crackling noise I'd never heard before, so I got up to look at it, and the laptop was really hot to touch - I mean really hot, I had to snatch my hand away when I touched the mousepad because it almost burned me. Never seen that happen before either. I immediately shut the machine off and left it overnight. I thought it was working fine the next morning... until I realised none of my USB devices were recognised.

It's hard to tell if it was the mp3 player as many people here have reported or the overheating. I've read the whole thread and nothing has helped as yet (though I'm going to try leaving my laptop off overnight - I've tried removing all the power sources for a half hour, though, and that didn't work). It's a Packard Bell machine running on Vista, and I can get the other specs if they would be useful, though I doubt from reading this thread that they would be. frown

All the same, if anyone happens to have any advice I'd be grateful.

#197 skiddie

skiddie

    stranger

  • Members
  • 1 posts

Posted 03 August 2009 - 12:09 PM

I have this problem and have experienced some interesting things with it recently.. here's my story:

It all started with a USB mouse, the Steelseries Ikari laser mouse. When i got it, i had a weak computer that just didn't seem to be able to supply the power this tank of a mouse required. I eventually got a new computer, and things were great... for a little while.

It has a function where you can press and hold down a button on the mouse, and change the CPI setting by increments of 1CPI. no need for drivers for this function, but you do need drivers for a few other options, such as setting special binds to M4 and M5. NOW, when i got it, i felt the need to use this function a LOT to find my correct sensitivity. I also used the software to do these changes occasionally. After a while, i began having these problems... at first, if i moved the mouse too fast it'd sometimes skip, other times it'd turn off and then back on and resume working. it seemed that messing with the cord would fix it, but who knows, could have just been a placebo.

Now after a while i began getting the "device not recognized" problem. id unplug it then plug it back in and it'd work fine for a little while. Little bit down the road, it wont work at all, ever.

Jump ahead a few months. I install windows 7, reinstall counter-strike, and dont even bother with my mouse. until i decide what the hell, why not... i wasn't doing well with my ball wheel mouse, was worth a shot. i plug it in, and holy crap, it works! i go and unplug my PS/2 ball mouse, then unplug my USB mouse, plug it in the back, and it stops working again. a little bit more give and take and it begins not working at all again. then i figure maybe if i install the drivers it'll work... i install the drivers and just for kicks i try to apply some changes to the mouse without it plugged in, it says plug the mouse in and try again... i plug the mouse in, click "apply" and... it works!! for like a minute then it freezes up. now i press apply, and it tells me to plug it in whether or not it is.

I am so confused. it doesnt seem to be a problem with the mouse, since it CAN work occasionally... I have read this entire thread and have tried everything i understand how to do (i'm afraid to mess with registry after last time.. lol).

what i want to know is, what direction should i be looking in to start climbing the steep slope of fixing this problem? mouse manufacturer? gateway? microsoft? is it a driver problem? power? registry?

it hurts my brain thinking about it. computer problems are the most frustrating crap ever!

#198 M0rs

M0rs

    stranger

  • Members
  • 1 posts

Posted 07 August 2009 - 08:21 PM

Maniak79's suggestion to disable the USB2 driver worked for me.

I recently got a new printer for my laptop. The printer is an HP Deskjet D4360 and the laptop is a Toshiba Satellite A series running Vista home.

When I first installed the printer it worked fine, but the next day I started getting this USB device not recognized error. I searched the internet for a solution and ended up trying most of the suggestions in this thread as well many suggestions from other sites.

Disabling this driver is the one that worked for me. Thanks for the solution, this problem was driving me crazy.

#199 nyvid01

nyvid01

    stranger

  • Members
  • 1 posts

Posted 21 August 2009 - 06:26 PM

guys, i m nu to the thread. so, m sorry if i cause any trouble. i'd like to suggest that may b upgrading to a newer os like windows 7 can solve this problem. cuz it would be having a set of new drivers. pls comment.

#200 maheanuu

maheanuu

    stranger

  • Members
  • 1 posts

Posted 24 August 2009 - 08:24 AM

I am working on the same problem on a Toshiba A300 laptop and I was given this as a fix... I am going to put it in as soon as I make the changes in Vista from French to English, so I have more things to do before I get to the point of deleting a file...

http://smokeys.wordp...ems-how-to-fix/ I hope this helps




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq