Jump to content


Photo

Installing mandrake linux 07


  • Please log in to reply
11 replies to this topic

#1 aatwo

aatwo

    stranger

  • Members
  • 6 posts

Posted 16 October 2006 - 03:57 AM

can someone please help me instal mandrake linux 07 64bit Free edition?

I purchased a DVD containing the distribution from ebay and was instructed to boot using the DVD and follow the instructions. I set my prime boot device to DVD rom and restarted and the linux instal menu appeared however there is one problem. It does not show my DVD rom drive in the list of boot devices that I am prompted to select from. So how can I instal it if it doesnt give me the option to instal it from my DVD drive...


What should I do?

#2 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 17 October 2006 - 10:51 PM

Are you trying to install Mandriva Linux 2007?

Where are you being prompted for a boot device? Mandriva should install from the DVD without any such input from you. What it will ask is where you want to install it to (what hard drive or hard drive partition).

Did you tell it to use your CD drive to install from? If you are getting the screen that I think you are referring to, you choose CD as the source of the installation.
"I love it when a plan comes together." - Hannibal Smith

#3 aatwo

aatwo

    stranger

  • Members
  • 6 posts

Posted 17 October 2006 - 11:51 PM

Wellafter I booted it with the DVD in, it took me to the installation menu. I selected the installation button however this is as far as I got. For some reason I get an Error message saying "No CDROM device found"... after selecting "ok" I am then given a list of devices to try however my DVD drive is not in that list... The list only has the following options...

-NFS server
-FTP server
-HTTP server
-KA server
-CDROM drive
-Hard disk
-Load third party modules

#4 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 18 October 2006 - 02:13 PM

You should be able to choose the cdrom drive as the installation media and proceed normally.
"I love it when a plan comes together." - Hannibal Smith

#5 aatwo

aatwo

    stranger

  • Members
  • 6 posts

Posted 18 October 2006 - 07:07 PM

That doesn't work. Every time I select the CDROM drive it returns the same error message as before. "Error - No CDROM device found".

#6 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 18 October 2006 - 08:36 PM

OK, this error can arise due to a number of issues.

1. The DVD that you bought was burned incorrectly or is not compatible with your DVD drive. Is this a full commercial version of Mandriva, or a DVD burned by someone who is selling them online? If the DVD was burned on a DVD disk that is not compatible with your particular drive, this can explain the problem also. I would never buy a home burned DVD or CD disk from someone, as you never know what you are getting.

2. A hardware problem between Mandriva and your system. Can you post what make and model system this is, or what motherboard that you are using, if this is a self-built system? This is a 64 bit version of Mandriva that you are using, so I assume that your system is an Athlon 64 bit motherboard and processor?

In some systems, say with sata drives (as many Athlon 64 bit motherboards are), you may have to change a setting in the bios to get Mandriva to see the CDROM drive correctly.

3. Is the DVD drive an internal drive or a USB DVD drive? I have an external DVD drive that is a real pain to boot from on my motherboard. If the DVD drive is an internal drive, is it attached correctly to an IDE (not RAID) port on the motherboard? This would apply to a self built system, or is you installed the DVD drive yourself (it was not installed by the manufacturer).

"I love it when a plan comes together." - Hannibal Smith

#7 aatwo

aatwo

    stranger

  • Members
  • 6 posts

Posted 19 October 2006 - 02:51 AM

DVD drive is internal connected properly via the IDE port. Also as you can see (below) I am using a sata hard drive but could not figure out what you were refering to in the bios.

Here are my pc specs (yes it supports 64 bit).

Processor-
E6300 Core 2 Duo *OEM* 1.86GHz 1066FSB 2MB Cache

-----------------------------------

Motherboard-
ASUS P5B Pentium 4/Celeron/Pentium D/PentiumEE/65nm dual-core/Core2Duo/Core2EE

-----------------------------------

Graphics Card-
Connect3d X1600 XT 256mb DDR VGA DVI-I TV PCI-E

-----------------------------------

Hard Drive-
Western Digital WD2500KS Caviar SE 250GB 7200RPM SATA2/300 16MB Cache - OEM

-----------------------------------

Ram-
Corsair 1GB (2 x 512MB) DDR2 667MHz 2x64Mx64 non-ECC 2x240 DIMM Unbuffered CL5

----------------------------------

Optical Drives-
Sony CRX230E 52x32x52 CD-RW Internal IDE (Black) - OEM
and
Sony DDU161510 16x48x DVD-ROM Internal IDE

-----------------------------------

Power Supply-
Antec TruePower II 480W PSU



#8 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 19 October 2006 - 11:28 AM

I thought that i remembered something about this and your specs. jogged my memory.

When you boot to the splash screen off the DVD disk, type in the console;

linux all-generic-ide

then hit the enter key and see if the DVD drive is detected.

See this Fedora forum article on the subject. There are a couple more hints on the thread as well.
"I love it when a plan comes together." - Hannibal Smith

#9 aatwo

aatwo

    stranger

  • Members
  • 6 posts

Posted 19 October 2006 - 12:59 PM

I tried putting that command into the console. It starting doing something and then I got the same error message once again frown

I also had a look through that post on the Fedora forum but found nothing helpful to me there :S



#10 aatwo

aatwo

    stranger

  • Members
  • 6 posts

Posted 19 October 2006 - 07:43 PM

If I went back to my distributor and got the CDROM do you think I would have better luck that way?

#11 Wilhelmus

Wilhelmus

    old hand

  • Members
  • 1032 posts
  • LocationFinland

Posted 19 October 2006 - 07:48 PM

Quoting from linuxforums :
Quote:

Hi,
Did you have Serial ATA controler ? I had problem with a new MB with SATA HDD and PATA (IDE) DVD. The CD/DVD is seen by BIOS (you can boot on it) but when the kernel is loaded, it doesn't see the IDE devices.
You have to check in the BIOS to disable Legacy support (Put the serial ata controler in 'Enhanced mode'.
This is a problem linked to kernel 2.6.8. 10.0 with 2.6.3 does not have this problem.


And next post of it:
Quote:

Hi, create a boot floppy and select "/images/alternatives/cdrom.img-2.4.25-2mdkBOOT" from your CD1 mandrake distro, restart, boot from floppy and install mandrake

If you have a floppy drive... smile

Again quoting from linuxforums :
Quote:

Don't know if it will work for you but some users have reported success in booting after turning off acpi either in their BIOS, or at CD boot with "linux acpi=off".


#12 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 19 October 2006 - 10:39 PM

I looked around. It looks like support for the jmicron chipset is lacking in fedora Core 5. But, one user suggested trying this at the command line at the Fedora splash screen;

linux all-generic-ide irqpoll

See if you have any luck with that command. Note that it adds irqpoll to the command sequence.

the reference for this is here.

You are likely to have a problem with the Realtek LAN, but see how it goes.
"I love it when a plan comes together." - Hannibal Smith




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq