Jump to content


Photo

d-link dwl-650 on fedora 5, need help.


  • Please log in to reply
4 replies to this topic

#1 maylin

maylin

    stranger

  • Members
  • 3 posts

Posted 12 October 2006 - 05:30 AM

Hi, all

I am trying to setup wireless network for my old laptop. I just installed Fedora 5 on it. I am a newbie in linux world. I have done reading for a week but each time I tried I failed to follow the instructions one way or the other.

Please help me with step by step instructions if you can.
The wireless card I have is d-link DWL-650 (revision P)
I read from somewhere that it is a prism 3 SSF card. I like to learn how can I install the driver for this particular card so I can setup a network connection?

Note that I don't have ethernet port on this laptop so as far (not too far tho~) as I know, I can not use YUM. So please provide a work around.

Thank you in advance!

Maylin

Additional information on my system --

uname -r
2.6.15.2054_FC5

pccardctl ident
Socket 0:
product info: "D-Link", "DWL-650 Wireless PC Card RevP", "ISL37101P-10", "A3"
manfid: 0x000b, 0x7110
function: 6 (network)

#2 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 12 October 2006 - 10:22 AM

Your information confirms that this is a prism chipset, thanks for that. It saves a lot of leg work.

I believe that there should be native support for the card, based on what you already posted.

Can you tell us what you have tried to get the card to work? this would tell us a lot. For example;

Did you get into Fedora's network manager and try to configure the card?

Do you have the essid and passphrase for the router to get the card to capture a signal?

Realize, that in Windows, the D-Link driver package guides you through this process. With Fedora, you need to use the network manager to do this. D-Link does not have a driver package for Linux.

...and you are using gnome as your GUI (graphical interface) in Fedora?


"I love it when a plan comes together." - Hannibal Smith

#3 maylin

maylin

    stranger

  • Members
  • 3 posts

Posted 12 October 2006 - 04:37 PM

Hi danleff,

Thank you so much to response back!
What I was trying to do is just to be able to surf the internet, that's it.
I think I am using a gnome because I do see a desktop kind of user interface like this.
I opened up firefox but I don't feel there is a network connection established yet.
When I try to configure the network by selecting System ->admin(? sorry I am at work without the laptop)->network.
At the hardware tab, add new, select "wireless", then there is a dropdown list for "adapter". Where I do not see this particular card and I am not sure which alternative (if) I should select. That's where I got stuck. [I tried to ramdomly select some pcmcia cards and the system will tell me "no such device..." when I try to 'activate':p]

Please let me know what should I do next in order to proceed.

I do have the essid and passphrase for my router, but the problem seems to occure ahead of this step.


Sincerely,
Maylin

#4 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 13 October 2006 - 11:05 AM

Fedora has a quirk that it does not recognize some wireless designations in the Network Manager. You will see what we mean soon.

Yes, you are using Gnome, good, this helps.

I wonder if Fedora has the prism 3 drivers native. I know the prism 2 ones are. Try this. Get into a console, as root user and type in the following;

/sbin/iwconfig (hit the enter key)

See if there are any wireless connections recognized, then report back. If not, the drivers are not loaded.

We do know, from you first post, that the PCMCIA interface sees and identifies the card. The question is if there is native driver support.

I wish that I could walk you through this better, but I do not have one of these cards to do so.

There do not seem to be any web articles on Fedora and this card available.

What make and model laptop are you using?


"I love it when a plan comes together." - Hannibal Smith

#5 maylin

maylin

    stranger

  • Members
  • 3 posts

Posted 13 October 2006 - 02:45 PM

Here is what I got after typing /sbin/iwconfig -
lo no wireless extensions.
sit0 no wireless extensions.

By that it probably means the drivers are not loaded...

Now it kinda like I recognize there is an 'airplane' on my driveway but I don't know how to fly it grin

My laptop is quite old, it is a Compaq Presario 1600. It was almost retired until give linux a try.

Maybe I should try orinoco (didn't quite follow the readme file though)? Or I do have the CD for windows drivers, how can I utilize it?


Sincerely,
maylin
Maylin





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq