Jump to content


Photo

Edited /etc/fstab and Fedora wouldn't boot


  • Please log in to reply
6 replies to this topic

#1 SideshowMel

SideshowMel

    stranger

  • Members
  • 19 posts

Posted 08 August 2006 - 02:45 AM

I posted a few minutes ago with a question about reformatting my HD, but this post is to ask about the original problem that started it all, and how I can avoid making the same mistakes again.

I followed posted instructions on several websites regarding mounting an NTFS partition under Fedora 5. I had trouble with sevral techniques, but I was finally able to get one working. My only problem was that it didn't mount the ntfs partition on bootup. I added a new line in the /etc/fstab file which I had THOUGHT would mount the ntfs drive on bootup. Well it actually prevented me from booting up. I had done the smart thing by making a backup copy prior to the issue, so I thought I could use the rescue linux utility to:
#rm /etc/fstab
#cp /etc/fstab-backup /etc/fstab

This didn't work because the return I got was that I was in "read-only" mode. I tried from the command line I got when trying to boot, and also on the command-line I got from the rescue utility. Unfortunately, I don't have any way to post the line I added to the fstab file because I ended up reformatting. I know this is kindof a broad question, but how can I avoid this in the future? Is there a way to "test" the fstab file prior to implementing it, just to make sure it is valid? Is there something else I could have tried to copy the correct file overtop of the bad one? Is there an application for Windows that would hyave allowed me to copy n paste over the bad file (I searched but couldn't find what I was looking for)?

I also tried to use Puppy Linux to access my Fedora partition, but I had driver problems getting Puppy to load, and I was too frustrated at the time to mess around with Puppy. If I had continued to troubleshoot Puppy, would it have allowed me access to my Fedora partition so I could paste over the bad fstab file?

One more question, what is the /etc/mtab file and what problems might I run into after editing that file? The reason I ask is that some tutorials for mounting other drives say I should edit the mtab file and some don't.

#2 SideshowMel

SideshowMel

    stranger

  • Members
  • 19 posts

Posted 08 August 2006 - 04:50 AM

...and before you ask, at every command-line I got, I typed "su" and entered root pw prior to attempting maintenance. Thanks.

#3 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 08 August 2006 - 08:17 AM

Quote:
I followed posted instructions on several websites regarding mounting an NTFS partition under Fedora 5.


Take a look here for information and module packages. See the RedHat/FC section on the right hand links. For Fedora Core 5 here. Of course, read the instructions, which gives you the information that you are looking for, including modifying the fstab file and mounting the volumes correctly.

This is a problem in of itself. Several techniques is not a good idea. There are great packages to allow mounting of NTFS volumes for Fedora. The plan is to use only one package (module) and one technique, specific for that module.

Good question about the fstab file. The backup always is read-only. I have used Puppy a lot to correct fstab and grub problems. It has always worked great for me. Can you tell I am a fan of this distro?

The driver issue that you note, do you know what the issue was? I'm sure there is a way to do this correctly (command line arguments), but I have never needed to do so. The fstab file is funky about exact syntax.

You should be able to boot into Fedora, in rescue mode and fix the original fstab file. Again, I seem to recall that there is a command to change the read-only status of this file when recovering a backup, but again, I have never needed to do this.

I never have messed with mtab. This file should never need to be modified, unless you change something significantly with your hard drives. Fedora should auto-correct the drive designations, but we know that that does not always occur as it should, don't we?

Some food for thought for some new how-to articles!!

#4 SideshowMel

SideshowMel

    stranger

  • Members
  • 19 posts

Posted 09 August 2006 - 05:06 AM

The link you just posted about NTFS is the one which finally worked, but like I said, I couldn't get it to mount on bootup, so I added the new line to fstab. I had used the syntax as closely as I could to the FAT32 lines I had previously added, except I changed the crucial parts (path or drive, path of mount file, and data type). Obviously that created a huge issue.

With regards to Puppy, I couldn't even get the initial load to start because it wouldn't accept any keyboard commands. It accepted the very first one (where is gives you a command prompt) but then when it got to the point where you choose your default keyboard layout, Puppy wouldn't accept any input. I tried reseating the keyboard plug several times and rebooted several times. I think the issue was that I use a wireless USB keyboard/mouse combo and my old PS/2 keyboard is buried somewhere in the garage. Soon I intend to get Puppy working, but first I should dig out that old keyboard...

I have new, although closely related, questions:

I just found out last night (I recall running into this problem years ago, but I completely forgot about it until now) that FAT32 has a maximum single-file size of 4GB. As you can imagine, this is a huge problem when trying to create an ISO image of a DVD. In Linux, there is no indication of said limitation, it simply stops creating the file at 4GB. I was pulling my hair out trying to figure out why, so I just gave it a shot in Windows, which is when I received the error message and subsequently smacked myself in the head for forgetting about this limitation! My new questions are these:

What file system should I use which both Linux and Windows read/write is fully supported and does not have a 4GB file-size limitation? What limitations should I be aware of when migrating to the new filesystem?

#5 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 09 August 2006 - 06:23 PM

This explains a few things. I wonder if Puppy has added wiresless keyboard and mouse support in their new version. I can't test this, as I have a KVM switch on my systems, which doesn't support wireless keyboards and mice.

Simply put, windows does not read and write any Linux partitions. There are a few Windows based programs that allow you to see Linux partitions, but that is it.

Fore normal sharing of data files (excluding DVD burns), I use fat32. NTFS write support is still in progreass in Linux. Puppy claims to have full write support for NTFS in their new version. I have not tried this out yet.

In terms of file sizes, Linux supports up to 2 TiB of file sizes. What you are probably runnng into, is the limit of the download method that you are using. I seem to remember Fedora's wget utility has a 2 gig limit on download file sizes.

For downloading DVD files, you can use a download manager, like gftp. I have downloaded DVD files without a problem with this utility. It is included as an add on in Fedora, either off the DVD (Applications-->add/remove software) or though Yum.

#6 SideshowMel

SideshowMel

    stranger

  • Members
  • 19 posts

Posted 10 August 2006 - 12:36 AM

Well downloading or ripping is fine, because most downloads are RAR files, and ripping you can choose to use the VIDEO_TS method, which gives you several files, all smaller than 4 GB. I am going to repartition my storage drive to half FAT32, the other half 8E. That way I can still share btwn Win and Linux, but have a significant amt of Linux free space.

Also, with Puppy, I am going to need to post on their website, because I think perhaps some HW on my mobo is unsupported... lots of keyboard and mouse errors (can't type more than a few characters and it throws an error code, so I need to go WAY back to the old school HID devices. the mouse is very buggy, but it works sometimes) and the NIC adapter (built-in on mobo) doesn't have drivers in Puppy, so I can't get on the internet to DL more drivers for the other HW. Also, Puppy doesn't see my SATA HD at all, which would have been a real problem if I had tried to use it to troubleshoot my fstab issue from the other day...

Wanna know what else is funny about that? There are no drivers for that nic card in Windows, either, so I have to install from disc whenever I reformat, but in Fedora 5, the NIC worked right off the bat!

#7 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 10 August 2006 - 05:25 AM

If you want to, post your motherboard make and model here (or if the NIC care is a PCI card, not onboard, the same for the card) and what make and model sata drive that you have. The new version of Puppy 2.02 sees all my drives (two sata drives included). You have to set up your NIC card in start-->setup-->wizard wizard. Pick the option to set up onboard (wired) NIC and see if the interface is detected.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq