Jump to content


Photo

dual boot problem winXP on SATA1 Fedore core 5 on SATA2


  • Please log in to reply
8 replies to this topic

#1 kc0sm

kc0sm

    stranger

  • Members
  • 6 posts

Posted 07 August 2006 - 02:06 AM

I installed new SATA drive in system. winXP installed on original SATA drive. Installed Fedore core 5 on second (new) SATA drive. During the install I selected to have grub installed on sda. When the system rebooted it booted winXP without ever going to grub. The system is the following config:

Motherboard: Asus P4C800-E Deluxe
Memory 1GB
1st SATA Seagate 120GB
2nd SATA Samsung 250GB

Any ideas?

#2 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 07 August 2006 - 07:44 AM

This confirms something to add to the article that I just wrote.

You did not install the bootloader to the MBR of the boot sda drive. If you were able to look at the drives in Fedora, you would see that you installed grub to the /boot directory on the second sata drive, but not the actual bootloader to the MBR of sda.

This occurs when you accept the default values during the installation. You must go into the advanced section of the Grub screen, during the installation, and change the order of the drives there. See the page on my article, located here.

So, the Windows bootloader is still on the boot sata drive, grub is on the second sata drive, including the bootloader itself.

I will add this information to my article.

#3 kc0sm

kc0sm

    stranger

  • Members
  • 6 posts

Posted 07 August 2006 - 01:20 PM

danleff,

I tried as you suggested. I tried all 4 possible ways of doing the install, both ways without swapping the order of the drives and both ways with the drives swapped and still it boots to XP without bringing up grub. What am I doing wrong?

Mike

#4 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 07 August 2006 - 06:00 PM

What "4" ways are you speaking about? Please be specific.

Let's look at the problem. This will also help me to improve the article for others, as well.

Look at this part of the article.

If you allow the default layout, then Fedora assumes that the installation is on a single drive in the system.

If you feel like troubleshooting, pop in the install disk and get to the partitioning scheme point. Tick the box during this phase and allow Fedora to look at your drive layout. See which drive has XP on it (it will show NTFS as the filesystem on the Windows drive). Stop the installation and report back.

I am downloading your users manual as we speak to look at this.

If you really choose to install grub on the sda drive (as noted on the summary window) then sda is not your boot drive, or there is a bug in the Grub installer.

Installing over and over keeps changing your installation and grub defaults, so I suggest you stop now until we see what is going on. We probably can correct the problem.

Can you post which drive is on which sata connector on the motherboard?

Also, look in the bios and see which drive is the boot drive. Please be specific.

P.S. OK, you have 2 sata connectors and possibly (optional) two sata raid connectors.

Which drive is on sata 1 and which on sata 2 (not raid if you have thiese connectors)?

In the bios, under the boot menu. Which drive is set as the boot drive?

If you already know this, excuse my detail. I just want to see what you have exactly.


#5 kc0sm

kc0sm

    stranger

  • Members
  • 6 posts

Posted 08 August 2006 - 02:14 AM

danleff,

First, let me start by thanking you for taking the time to help. I really appriciate it.

What "4" ways are you speaking about?

I was refering to the advance screen that has the box to change drive order. Prior to changing the drive order the two options are:

/dev/sda MBR
/dev/sdb1 first sector of boot partition

After changing drive order the options are

/dev/sdb MBR
/dev/sdb1 first sector of boot partition


If you feel like troubleshooting, pop in the install disk and get to the partitioning scheme point. Tick the box during this phase and allow Fedora to look at your drive layout. See which drive has XP on it (it will show NTFS as the filesystem on the Windows drive). Stop the installation and report back.



On the top of the drive layout screen it shows:

sda1 10GB sda2 50GB sda3 55GB

scb2 240GB

at the bottom of this screen it shows:

/dev/sda
/dev/sda1 NTFS 10GB

/dev/sda2 EXTENDED
/dev/sda5 NTFS 50GB
/dev/sda6 NTFS 55GB

/dev/sdb
/dev/sdb1 /boot /ext3 102MB
/dev/sdb2 VolGroup00 240GB

Can you post which drive is on which sata connector on the motherboard?

In the bios:

IDE1 MASTER cdrom drive
IDE1 SLAVE dvd r/w drive
IDE2 MASTER cdrom r/w drive
IDE2 MASTER NOTHING
IDE3 MASTER 120GB sata drive (with winXP installed)
IDE3 SLAVE NOTHING
IDE4 MASTER 250GB sata drive (new for Fedora)
IDE4 SLAVE NOTHING

Under the "boot tab/hard disks" in the bios
1st drive 120GB sata drive
2nd drive 250GB sata drive

Under the "boot tab/boot priority" in the bios
DVD
SATA 120GB DRIVE (because it is listed first in the above
list of hard drives)
floppy

Which drive is on sata 1 and which on sata 2 (not raid if you have thiese connectors)?

I think that the above information answers this but:

SATA1 is the original drive (120GB) that shows up in the fedore install as sda.
SATA2 is the new 250GB drive that shows up in the Fedora install as sdb

The raid is not being used.

In the bios, under the boot menu. Which drive is set as the boot drive?

The original drive (SATA1 120GB with winXP installed) is the boot drive in the bios and is the one that shows up as sda int the Fedora install.

If you already know this, excuse my detail. I just want to see what you have exactly.

NO problem. I should have been more specific to begin with. I hope this information is what you need to figure out the problem. I'm sure that if we get this to work that other who read your article will appriciat you hard work. Thanks again for you time.

Mike


#6 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 08 August 2006 - 05:59 AM

WOW, this is interesting!

I see a couple of possible problems. Let me look at my bios settings and see what I have.

Quote:
In the bios:

IDE1 MASTER cdrom drive
IDE1 SLAVE dvd r/w drive
IDE2 MASTER cdrom r/w drive
IDE2 MASTER NOTHING
IDE3 MASTER 120GB sata drive (with winXP installed)
IDE3 SLAVE NOTHING
IDE4 MASTER 250GB sata drive (new for Fedora)
IDE4 SLAVE NOTHING


Do you really have three CDROM/CDRW devices on the system on the IDE channels?

In the bios, under the advanced tab, what is the onboard Promise raid controller set to, disabled, or enabled?

If enabled, is the Operating Mode set to raid, or IDE? If it is set to disabled, then you will not see these two options under the Operating Mode.

#7 kc0sm

kc0sm

    stranger

  • Members
  • 6 posts

Posted 08 August 2006 - 06:16 AM

Do you really have three CDROM/CDRW devices on the system on the IDE channels?

Yes I do. I started with cdrom, then added cdrom r/w
and when the price dropped I added dvd r/w.


In the bios, under the advanced tab, what is the onboard Promise raid controller set to, disabled, or enabled?

The Promise controller is set to enabled. Should it be
disabled????

If enabled, is the Operating Mode set to raid, or IDE? If it is set to disabled, then you will not see these two options under the Operating Mode.

The operating mode is set to raid.

#8 kc0sm

kc0sm

    stranger

  • Members
  • 6 posts

Posted 11 August 2006 - 01:27 AM

Just another thought now that I have time to think about this again. Fedora seems to be installed on the second SATA drive(250GB), at least I was able to boot off the install DVD in rescue mode and mount the file system. Is is possible to create a boot floppy and use that while I try to get GRUB working from the hard drive?

Mike

#9 kc0sm

kc0sm

    stranger

  • Members
  • 6 posts

Posted 11 August 2006 - 04:43 AM

danleff,

Well I can read after all. I went back and looked at your post of 8-7-2006 11:00 and followed the link "this part of the artical". I read the article and then followed the link "Recovering Grub when you....". I booted from the install DVD in rescue mode as instructed. I did the chroot /mnt/sysimage. Next I did the "grub-install /dev/sda" (sda for the boot SATA drive with WINxp on it, the original disk}. I got an error message but didn't write it down ( something about sdb1 not having a corresponding device) I next ran "grub-install --recheck /dev/sda" I was shown a list of the drives and told to correct the list if it was not right. The list was fine so I re-ran the "grub-install /dev/sda"

When the command was complete I rebooted the computer and there was the grup menu!!!!

I have since booted on both WINxp and Fedora several time and all is good!!!

Many thanks for all you help.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq