Jump to content
Compatible Support Forums
Sign in to follow this  

how to install sis 760 drivers!

Recommended Posts


i wanted to change to Sis drivers for red hat linux 9. its showing VESA type and memory 16 mb only.the screen resolution wont change from 800x600.

igoogled and found that sis doesnt make drivers for linux.but a guy makes them for free and is available on his site.

since i am quite new to linux , i hav problems understanding as how to install the drivers!


plz visit this site:juts read about installation procedure!


i have found correct driver but am unable to install it

Q1. i replaced the sis_dri.o file( this means i am using Xfree86????)

"/usr/X11R6/lib/modules/drivers/."this is the path in which i found this .o file. it says u must stop xorg6.9 do ihav to stop xfree too ,how?

Q2.how to restart the xorg/xfree?

Q3.i restarted computer with that driver copied to that path .but nothing changed?




Share this post

Link to post
Share on other sites

Remember, I did mention to you in your other post, that RedHat 9 was not a good version to install on your system. It is too old for the hardware in your system. you are bound to have problems with it.


Did you install the correct version of the driver package? You should have tried the Xfree 4.3 version for gcc 3.x, which is what RedHat was built on. On first thought, it should be the XFree86 4.3.0 (gcc 3.x) file. But realize, I have no idea if this supports your PCI-E video interface.


So, you have Xfree86 version 4.3, not Xorg, which would be in Fedora Core 5.


Additionally, the author of the package makes note of problems with the sis 760 chipset,which is what you have on your system.


It sounds like you did the right things, but the question is, did you pick the correct package for your system?


How are you trying to change the resolution and video settings? Are you using redhat-config-display via a command line, or otherwise?


Also, from my perspective, if you set up the system without sis support initially, then the Xfree86 config file is probably set to vesa and your monitor not set up correctly, as it is most likely newer than what was supported by RedHat in it's time. I would assume that you would need to change the config settings in the /etc/X11/XFree86.conf file to use the sis driver, or set up the video card via a utility (say redhat-config-display) to take advantage of the new sis driver.


Did you ask this question on the forum referenced on the author's website? This would make sense, since he developed the driver and that forum could best answer the questions that you pose?


If you do chose to use his forum, make sure that you post what motherboard model you are using, that you are using RedHat 9 and what package you attempted to install. This will help them troubleshoot what the issue may be.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this