Jump to content


Photo

Fedora Core 5 install w/ 2 hard drives


  • Please log in to reply
4 replies to this topic

#1 atagar

atagar

    stranger

  • Members
  • 16 posts

Posted 07 July 2006 - 12:35 AM

Hi. I'm trying to make a dual boot system with Windows 2000 on hda and Fedora Core 5 on hdb. After reading several posts by danleff I've been able to get a system that can boot into either Windows or Linux depending on the bios. However, a problem's popped up with grub, and being new to Linux I'm not sure what to do.

I first installed a fresh copy of Windows 2000 on hda, and formatted a 2GB section in FAT32 for transfers between Linux and Windows. I then installed Fedora Core 5 on hdb, keeping the default installation settings for the boot loader (placing it on hda). After restarting it skipped the grub splash and booted directly into Windows. I swapped the bios settings to boot from the slave drive and as expected, it said "No Operating System Detected". I read that Norton has a "Turn Back" feature that hooks the MBR and prevents changes. However, looking over the settings of my virus protection (AVG), I'm not spotting anything that looks like that sort of feature.

After reading some posts I decided to place grub in the MBR of hdb instead to both preserve the Windows boot loader, and hopefully fix the problem. I re-installed Fedora Core 5, this time telling grub to be placed on hdb and clicking "Change Drive Order", making the slave drive first.

Now if the bios has hda first it boots directly into Windows, and grub if it's hdb. In grub I'm able to start Fedor Core 5, but if I select windows it says:
Booting 'Windows'

rootnoverify (hd1,0)
chainloader +1

Then sits there. If switching the bios confused the boot loader, wouldn't both Linux and Windows stop working? Any idea what I should do next?

System:
HP Pavilion 7845
863MHz PIII processor
256MB ram
Master HDD: 40 GB
38GB Windows 2000 (NTFS)
2GB FAT32
*Windows was installed with a normal Windows 2000 disk
Slave HDD: 10 GB
Fedora Core 5

#2 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 07 July 2006 - 06:08 PM

First, let me clarify. In all my posts, I do not advocate changing the bios order to boot Windows and Linux. In fact I have taken greeat pains to recommend against this, for the same reasons that you give with your dual boot issues.

Let me also clarify, once again, what happens when you change the boot order in the bios.

1. Each OS that you install and it's ability to boot is dependent on where the drive is seen in the bios and how the drive is jumpered (IDE or pata drives) when you first installed the OS.

2. If you install Windows on a primary master drive and it is the first drive tagged by ther bios in the system, then the Windows boot.ini file points to the system startup files on that drive.

3. If you change the boot order in the bios to a second drive, that drive is seen as the first drive in the system.

4. You now have the second drive set first in the bios. Grub uses it's script to start the boot process (tag the boot.ini file to run Windows) on the correct drive, hd1,0, which means the master slave drive. This is correct now for Grub, but then the boot.ini file is invoked and says, "I am looking for the system files on the first drive in the system", or hd0,0. However, now this drive is really the Fedora drive, not the Windows drive, so Grub seems to hang.

In this case, there are two solutions, either install Grub to the MBR of hda and keep the boot order as you always had it, or "fake" grub to change the boot order of the drives when you choose the Windows boot option, so Windows boots normally (reverse mapping).

I am working on an article about this, for users that know how to modify the grub.conf or menu.lst file. But, this assumes that you feel comfortable with how to do this.

I don't use Nortons, but found this article on Norton AV.

If in fact, auto protection does not allow writing to the MBR, as a virus protection tool, then you need to turn off this feature, as per the instructions given, before installing any software or OS that may change any of the protected areas.

#3 atagar

atagar

    stranger

  • Members
  • 16 posts

Posted 08 July 2006 - 07:27 AM

Thanks for the reply. I've re-installed Fedora, again installing grub to hda (and again it booted directly into Windows). I followed the instructions here, using the Fedora rescue disk and entering:
chroot /mnt/sysimage
grub-install /dev/hda

Like that thread, I got the error saying "/dev/hdb1 does not have any corresponding BIOS drive." Unfortunately, it doesn't look like a solution was found. This system is expendable, so if you have any ideas, there's not much to loose.

#4 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 08 July 2006 - 04:19 PM

There seems to be a bug in Grub. I believe it has something to do with a users system and how it handles a default installation of Fedora. The grub booloader does not get installed correctly wheninstalling on a second hard drive.

Since this is not a mission critical system, let's try the following;

If you changed the bios boot order back to booting Windows 2000 first.

If you did a default installation of Fedora and did not specify how the second hard drive should be partitioned. This would have given you a /boot partition on the target drive and set up a LVM (Logical Volume management) partiton.

You know this is the caee, if you, as root user, type in;

/sbin/fdisk -l (the small letter L}

You see a small boot partition (hdb1) and hdb2 as LVM Type.

Get to a command line (terminal) as root user.

Get into grub manually and type in;

grub (hit the emter key & after each command below)
grub> root (hd1,0) (since fedora /boot is on /hdb)
grub> setup (hd0) (the mbr of the first hd)
grub> quit

Again, this assumes the bios is back to booting from the Windows drive again, before you started the Fedora installation.

Then reboot and see if you get both Fedora and Windows to boot.

#5 atagar

atagar

    stranger

  • Members
  • 16 posts

Posted 09 July 2006 - 04:42 AM

Sweet, works perfectly. Thanks!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq