Jump to content
Compatible Support Forums
Sign in to follow this  
DJ Wings

Dapper problems: F5D6020v2

Recommended Posts

I recently upgraded from Ubuntu 5.10 to 6.06 via "sudo dist-upgrade". This has apparently cost me support for my Belkin F5D6020 WNIC, which I have used for a year.

What I've done:

1. Ran the drver with Wine, unshielded the cabinet files, and looked for driver files. Found none.

2. Downloaded RealTek's Net8180.inf driver and installed with NDISWrapper -i and used -d with lspci.

3. Googled for more info. In almost every case, there was a file called "Bel6020.inf", which was nowhere on the Web to be found, OR on the driver or ANY of the cabinets, or ANYWHERE on the accompanying driver CD. Sending me that file via email would be appreciated.

4. Ran it in Knoppix, and it said my PIRQs didn't match. I'm running it with "pci=usepirqmask" right now.

Any advice?

Share this post


Link to post
Share on other sites

Can you supply a link or two on the driver you are speaking of regarding what you found on google?

 

This ia a PCMCIA/carbus card, correct?

 

...and you had it working before with ndiswrapper?

 

Which version card is this? It can make a difference.

Share this post


Link to post
Share on other sites

The link that you provided is the version 3 driver, not the version 2, which is located here on the Belkin site. I wonder if this is the problem. They could have different chipsets. Do you know if this is the case?

 

If it worked in the previous version of Ubuntu (without ndiswrapper), I am wondering what chipset that it actually has. It would be strange if it worked previously and not now, unless this is a bug in the upgrade process.

 

What I was wondering, is where did you see references to the Bel6020.inf on the web?

 

I can't get the cab files to extract after unzipping the exe package, so I can't see if it is there. How did you get the cab files to decompress? Maybe it just a fluke with Fedora Core 5.

 

Reference

Share this post


Link to post
Share on other sites

I just looked around the Ubuntu wiki and a few other places. You don't need ndiswrapper. However, thee seems to be an issue with these cards in the new version. See the thread located here.

 

Are you trying to hotplug the card, or have you also had the card in before booting?

Share this post


Link to post
Share on other sites

I never hotplug networking peripherals. The Ubuntu wiki... is seriously outdated in spots. It only applies for Breezy for that card- nothing about Dapper. But anyways, thanks a ton for the file- even if it doesn't have the Bel6020 file, which I heard about on the NDISWraper wiki.

Do you think I should recompile my kernel with Atmel support (if I download the drivers from sf.net)? I need a fix quick, because I'm going away for a month later today (so if this thread gets bumped after a month, you'll know why).

Share this post


Link to post
Share on other sites

First, the ndiswrapper wiki card list that you referenced (#10 under Belkin) is for a different chipset, namely the version 3 Realtek card. If you have the version 2 (Atmel), support is already built in.

 

However, as per my link in the first line of my post # 173849 above, there seems to be a bug with the upgrade to Dapper. See the last post on that bug report, which describes your situation exactly. Not you exact card, but the same chipset.

 

I would post a thread on the Ubuntu forums, where folks are most likely encountered this problem and have found a solution.

Share this post


Link to post
Share on other sites

...and if you read the last post by Vincent, he was unable to get the card to connect unless he followed the procedure that he outlined for hotplugging the card.

 

The bug report is somewhat confusing, as the original bug file speaks to the F5D6020 orinoco-based wireless card, the last comment, to your card chipset.

 

My point was to explain that there seems to be a problem with the card and PCMCIA.

 

The Amtel driver is already in Dapper, but apparently has a problem.

 

Given the issue at hand, this is why I suggested posting on the Ubuntu forum. Your more likely to get a good response, given others have had the same problem with these cards and someone is likely to have found a solution, which might include dumping the installed version and upgrading to a newer one. But, better let them tell you what exactly to do, then trying solutions that may or may not work.

 

I would rather have you go there, then get frustrated with not getting a direct answer from this forum.

 

 

Share this post


Link to post
Share on other sites

The problem isn't hotplugging, I FOUND IT! w00t!

I upgraded my entire system EXCEPT the kernel, and it worked fine. This included removing the hotplug package (it got integrated into another one). Therefore, the problem lies somewhere between kernels 2.6.12 and 2.6.15. I have a transcript of all the modifications to the atmel_cs driver between the versions:

Quote:

Excerpt from Linux Kernel 2.6.13 changelog:

 

commit 4a17a119381a5467144b18eaa954ba324e8a140b

Author: Dominik Brodowski <linux@dominikbrodowski.net>

Date: Mon Jun 27 16:28:34 2005 -0700

 

[PATCH] pcmcia: id_table for atmel_cs.c

 

Add pcmcia_device_id table.

 

atmel_cs.c? Hmm...... Looks promising. But there's more.

And this, from the 2.6.14 log:

 

[PATCH] tpm: fix tpm_atmel.c on ICH6

 

While installing Debian on our new IBM X41 Tablet, I tried briefly to use

the built-in Atmel TPM. The Athmel TPM is also located on the LPC-bus of

the ICH6. To make it work I had to apply the following patch:

 

And this:

commit 72f98d38a890822cf547f94c8fbdef591b082ec2

Author: Jean Tourrilhes <jt@hpl.hp.com>

Date: Fri Sep 2 11:36:00 2005 -0700

 

[PATCH] atmel_cs : WE-17 support

 

This adds support for WE-17 to the atmel_cs driver. Not

tested, I don't have the HW.

 

Untested? Not good. I looked for a patch, and found this:

 

[PATCH] TPM compile fix

 

CC drivers/char/tpm/tpm_nsc.o

drivers/char/tpm/tpm_nsc.c:277: error: `platform_bus_type' undeclared here (not in a function)

...

CC drivers/char/tpm/tpm_atmel.o

drivers/char/tpm/tpm_atmel.c:175: error: `platform_bus_type' undeclared here (not in a function)

 

Make sure to include proper headers.

 

Bad headers... Oog...

 

Should I email this to someone at the dev team? The problem is definitely in the kernel.

And anyone else reading this, I warned you about the bump.

EDIT:

Quote:
-Plug the PCMICA wireless card and the USB wireless adaptator

What if I don't have a USB adaptor?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×