Jump to content
Compatible Support Forums
Sign in to follow this  
Robert Alamond

Help SuSe 10.0 wireless Belkin 54g can't configue very new to linux

Recommended Posts

I have an


Compaq armada E500

P3 500mhz

128mb ram

6gb hd


I am running SuSe 10.0


two pcmcia slots, one of which I would like to use the


Belkin 54g wireless card that I used in Windows


It is F5D7011


I have any number that you may need to help, just let me no


any help please.



Share this post

Link to post
Share on other sites

My first question was, does this unit have a 32-bit CardBus slot?

I see from the product description, that it does.


The card has a Broadcom chipset.


So, my second question is, what have you done to try and get it working so far?


Did you install SuSE with the card in the slot and try to configure the network during the installation?


Have you had the card in the slot before you booted the system?


Have you tried to configure it in Yast using ndiswrapper?


Sorry for all the questions, but we need to know exactly where you are at this point.


Your post did answer a bunch of questions.


Basically, you need to install drivers to get the card to work. This can be a bit complicated in some cases, but knowing what you tried so far will help.


If you don't understand anything I posted, just ask.

Share this post

Link to post
Share on other sites

You're welcome, Danleff. Andrew has recently updated his How-To and continues to refine and improve it. It's quite helpful and now he has even added some pictorial assistance in walking one through the steps.




Share this post

Link to post
Share on other sites



i also have problems with my belkin 54g usb adapter on suse 10.1... i couldn't connect to wlan at all using knetworkmanager (well, i connected ONCE in like 30 times i tried, but i wasn't able to reproduce the settings after restart...)


i googled for a bit of time (rather big bit that was, and yhe outcome was a suggestion, that traditional method (with ifup) should be used in such situation. this seemed ok, as i also need both my network interfaces (eth0 & wlan0) active at the same time-smthng what knetworkmanager is incapable of (if i'm wrong tell me pls, i rather like the util).


well i RTFM for ifconfig, ifup, ifdown, ethtool, iwconfig etc... and tried my luck... guess what-i wasn't able to connect wlan0. only eth0.


after another rather big bit of googling i thought i had a solution. i found a thread somewhere (if i'd only remember where ;() where this guy described exactly same problems as mine are. after a few posts he claimed to have them solved by following sequence:


ifdown eth0

ifdown wlan0

ifup wlan0

ifup eth0


that the problem was in the starting order of devices, that eth0 has to be started AFTER wlan0. oh, how happy i was...until i found out that this isn't the solution for me...


so, here i am - asking humbly for help... you see, this is one of like 5 things i am not able to solve on my linux box to be able to do what i want without having windoze installed (others include: i can't upload to proftpd ftp server even when the permissions on the upload folder are ok, make smb4k able to actually scan the network, not only find the hosts which i enter, correctly displying national characters in mplayer (i'm from slovak republic)-this one seems more impossible than a week of uptime on winxp used dy ordinary gaming user) and a few others...)


well, back to my most accute network problem... here is my config info:


suse linux 10.1


toshiba equium a60 laptop



realtek (the most common one, can't remember the number (5139? or smthng like that))


configured with static adress/net mask using routing



belkin wireless g usb network adapter

configured with dhcp

using ndiswrapper 1.10-19, winxp driver recognized as rt73 driver installed/hardware present


well, that's about it, if you'd be willing to help, i could provide virtually any info you could possibly need...


thanks in advance



p.s. really sorry for such long post, but this has caused me so much frustration over last few days, that i just had to get it out...



Share this post

Link to post
Share on other sites

Could you post the model number of the adapter? There are several.


Did you read the ndiswrapper instructions for SuSE, located here?


Are you using the ndiswrapper package that came with SuSE, or did you use a newer version from the ndiswrapper website? Depending on the model number of your adapter, you may need a newer version of nsidwrapper.


The article mentions that you may have an issue with having the wired connection set to be detected on boot. Where did you find directions that both needed to be loaded?


You also mention that you have the wired card set as static and the USB as DHCP? Which is your connection to your ISP, dynamic or static?


Finally, did you follow the basic instructions for actually loading the module and setting your essid and passphrase (WEP or WPA), if you have one?

Share this post

Link to post
Share on other sites



thank you so much for your support.

the adapter model is Belkin F5D7050


i read those instructions and followed them to no avail.


i am using ndiswrapper which was shipped with suse, as i was unaware there are newer versions as it never appeared in YOU.


concernig loading both interfaces: i do not need them to be loaded on boot (well it would be nice, but i can live without that) what i meant was, i need them both to be active. with knetworkmanager i was able to be on wirelles OR on lan, i'd like to be on both.


my isp connection: i am connecting thru lan to my mate's windows box, where he is receiving wirelles connection, which he shares. so my isp connection now is that static one. but i'd like it to be wlan, so we wouldn't have to share available bandwidth.


yes i did succesfuly installed windows driver (identified as rt73 by ndiswrapper) and i have also loaded ndiswrapper kernel module (if that's what ndiswrapper -m does) - lsmod | grep ndiswrapper shows the module. the network isn't using WPA.


well that's about it, thanks again for your time, hi hope my english isn't very bad;)

Share this post

Link to post
Share on other sites

OK, I going to make some assumptions. There are three models of this USB adapter. Straight F5D7050, as well as a version 2 and 3. I think the original version has a prism chipset, fromwhat I am reading. Versions 2 and 3 should be Ralink. Letś assume that it is version 2 or 3.


What is the exact name of the inf and sys files that you used from the drivers disk?


Did you use the Windows XP versions of the driver sys and inf files? many driver disks have the drivers for multiple versions of the USB device, so make sure that you used the correct ones for your version.


You apparently did the ndiswrapper -m command, which does not load the driver, but places it in the modules.conf file so it loads at boot.


lsmod | grep ndiswrapper shows that it it running.


What is the output of the command, as root user;




Does it show rausb0 or something like that with the output of some parameters?




rausb IEEE 802.11b ESSID:""

Mode: Managed Channel: 0 Access Point: Not-Associated

Bit Rate: 0 kb/s Tx-Power: 0 dBm Sensitivity=0/3

Retry: off RTS thr: off Fragment thr: off

Encryption key: off

Power Management: off

Link Quality=0/94 Signal level=-95 dBm Noise level=-95 dBm

Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0

Tx excessive retries:0 Invalid misc:0 Missed beacon:0


sit0 no wireless extensions.


ppp0 no wireless extensions.


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this