Jump to content


Photo

Issues with dual-booting FC5 x86_64 and XP 64x


  • Please log in to reply
1 reply to this topic

#1 claudem

claudem

    stranger

  • Members
  • 1 posts

Posted 19 June 2006 - 10:24 AM

I have currently beenm trying to install FC5 (64bit) along side my current XP 64x installation.

Both are on the same HD and each have their own partition along with 2GB for swap.

I initially installed FC5 over the MBR which of course killed the XP boot loader. This did not bring up the GRUB boot loader screen which usually gives you a choice of OS.

So I rebuild the Windows MBR and did an reinstall of FC5 with Grub on the same partition as the install, as read in a forum I can apparently add a script to the boot.ini file in windows that initiates the FC5 install, but when I looked for the /boot directory in /ETC its wasn't there???
I did a DF to check the ouputs but still no /boot directory??

I desperatly need some help with this as I am a Newbie with linux.
Many different ppl have completely different advice on how to change the boot situation - if possible I would like to boot windows from grub, but as windows doesn't like a missing boot file I can deal with running it vice versa.


CAN ANYONE HELP???




#2 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 19 June 2006 - 06:09 PM

Quote:
I initially installed FC5 over the MBR which of course killed the XP boot loader. This did not bring up the GRUB boot loader screen which usually gives you a choice of OS.


What happens? does it seem that Fedora boots right off, and did it boot OK? Usually what happens is that an option to boot Fedora comes up. Then when you hit the enter key, a menu comes up with a choice for Fedora and "other." Other, of course is Windows. The problem is that the default boot choice time is very fast and it is easy to miss.

Quote:
I looked for the /boot directory in /ETC its wasn't there???


There is no boot diretory in /etc. Where it is depends on what type of installation you did.

If you did the installation with the default settings, then a /boot partition is created. It would be it's own unique partition.

If you preformatted the drive and used "expert partitioning" then the boot partition is on the root filesystem on the drive. So, not in /etc, but in /boot.

If you choose on the beginning of the linux partition, then the /boot directory (folder) would be in the same place.

Quote:
I did a DF to check the ouputs but still no /boot directory??


It looks like the /boot directory is on the root filesystem, which is why it does not show under df. It should be under /boot, with the grub files on the subdirectory/grub.

/boot/grub.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq