Jump to content
Compatible Support Forums
Sign in to follow this  
GhostSong

SuSE 8.1 Pro ACPI

Recommended Posts

Hi there

 

I need someone expert about compiling the kernel

 

When in X the battery is with X and says that i need at least to enable control method battery and AC adaptor

 

I compiled the kernel all ACPI apm are enabled but still no dice

 

rcapmd status

Checking for apmd:unused

 

apmd

No APM support in kernel

 

uname -a

Linux SoftParade 2.4.19-4GB #1 Wed Sep 25 18:58:10 UTC 2002 i686 unknown

 

Acpid is the only one that seems to run.

 

( ) Within the bios there's nothing about ACPI APM

 

Cause it's a new laptop

 

I have to add that before i log into X if i press the button to

 

suspend the monitor goes off but when i log in X there's no action at all.

 

Anyone ? Any help will be grateful

 

Thank You

 

Farewell

Share this post


Link to post
Share on other sites

Okay but what with the make menuconfig ....

 

 

Last time i tried i had a kernel panic about VFS cant mount root fs on 03:02 i think ...

 

I use Grub

 

My steps were :

 

make menuconfig|changes|make dep|make clean|make bzImage|make

 

modules|cp /boot/vmlinuz /boot/vmlinuz.old|cp arch/i386/boot/bzImage

 

/boot/vmlinuz|Grub ( where's the make modules_install ) and within

 

grub> root (hd0,1) | setup (hd0,1) | kernel /boot/vmlinuz | boot

 

(distro:Suse 8.1 Pro) on Laptop Compaq Presario 2800series

Share this post


Link to post
Share on other sites

I'd wait on the 2.5 kernels. I'm running a patched 2.4.21-pre3 and it's working nicely. Once you apply the appropriate patch, 'make menuconfig' should give you a couple extra menu items for power management.

 

Also, 'make clean' should preceed 'make dep'

Share this post


Link to post
Share on other sites

I was sure i could deal with the panic kernel

 

I Did chainloader(hd0,1)+21 and went all good

 

But ...

 

Still no apm support by kernel acpi not at all ( should i try apm acpi =on as well ? ) Even the dmesg rcapmd status unused etc

 

Or i should try the patch ( which one should i get for my distro ) or update my kernel ( which one again )

 

Farewell

Share this post


Link to post
Share on other sites

Download the 2.4.20 kernel: http://www.kernel.org/pub/linux/kernel/v2.4/linux-2.4.20.tar.bz2

 

Patch it to 2.4.20-pre4: http://www.kernel.org/pub/linux/kernel/v2.4/testing/patch-2.4.21-pre4.bz2

 

Patch it with the ACPI patch: http://prdownloads.sourceforge.net/acpi/acpi-20030218-2.4.21-pre4.diff.gz?download

 

Patch it with the kernel-level suspend patch: http://fchabaud.free.fr/English/Tricks/Laptop/Swsusp/patch-acpi-acpi20030125-swsusp18.gz

 

'make menuconfig' The additional options for APCI will be present.

 

Enable them.

 

Recompile.

 

In the mean time, read the documentation on the pages above. Read it all.

Share this post


Link to post
Share on other sites

Alo'

 

 

Well i always get a kernel panic VFS about mount root VFS n' stuff after every make dep of my kernel.

 

And i go through lots to deal with the panic kernel which i can deal with it

 

But i cant keep the compiled kernel for the reason i've told you before

 

I load manualy de default kernel , then i reconfigure man too the grub

 

and so on and i can work again w/o install again smile But still no dice with the compile

 

() I'm on SuSE 8.1 pro ( no other os's , just linux in the whole hdd )

 

Farewell

Share this post


Link to post
Share on other sites

Greetings ,

 

Allright with the kernel.Acpi/bluetooth/irda

 

Every thing works great , like Rock

 

The steps to deal with the kernel panic were ( if you configured with reiserFS / scsi emulation within the kernel's options otherwise these were the causes ) are

 

a) root (hd0,1)

B) setup (hd0,1)

c) kernel=/boot/vmlinuz

d) initrd=/boot/initrd

e) chainloader (hd0,1)+1 ( or +21 )

f) boot

 

Farewell

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×