Jump to content
Compatible Support Forums
Sign in to follow this  
raymondobasildon

Suse 10.0, Motorola SB4200, can't set up

Recommended Posts

I have an external USB cable modem - Motorola SB4200. I have successfully used this for years with Mandrake9.2 (and WindowsXP).

But I find the internet modules in YaST too numerous and too confusing.

I have just installed SUSE Linux 10.0 (my Mandrake was broke and I wasn't having any joy with support). I was delighted at how much the installation detected automatically. But after a couple of hours of trying I just cannot get the internet connection up and running.

The Cable modem is properly recognised.

I think I could manage it if I knew which modules to configure - there are so many and I'm sure most of them are not for me - a simple home user.

I have also tried setting up an Ethernet card as that is what is in the modem but this didn't help.

Please could someone help as I don't want to have to spend the whole weekend waiting to connect

Share this post


Link to post
Share on other sites

OK I have temporarily solved the problem. Acknowledgements to those who put this solution on the net.

 

In a terminal, login as superuser:

 

# su

 

Then enter the command:

 

# modprobe usbnet

 

This fixes it.

 

But only for that session. I used to do this sort of thing at the end of the nineties for the soundcard. And I can't remember the commands for making module changes permanent.

 

If I could persuade SUSE to load the module in the setup the problem wouldn't arise.

 

Incidentally, this is the answer for kernel 2.6.x

 

If you have 2.4.x kernel, the command would be:

 

# modprobe CDCEther

 

 

But can someone tell me how to make these changes permanent please.

Share this post


Link to post
Share on other sites

Once you modprobe the usbnet module, go to Yast and set up the connection. Choose DHCP and to enable the connection on boot. Follow though with the menu windows until the process is finished. Your new connection should be up after the next boot.

Share this post


Link to post
Share on other sites

Thanks for the input but I guess I'm unclear about precisely what you mean.

 

I have tried both configuring the Motorola (under Network Devices) before a reload and after. Each time after connecting up to the web with the modprobe usbnet command. Even when I had connectivity to the internet, I get the message that there is no driver loaded for this device it may be in the kernel ( or something [sorry should have written it down]).

 

Incidentally, during the reload, I tried looking for anyway I could persuade SUSE to load the usbnet module. There would appear to be none.

 

Anyway, whatever I do, everytime I reboot the computer, I'm not connected again and have to run the command.

 

I feel certain I'm overlooking something obvious and should be setting up one of the other modules in YaST. But there are so many and so little indication of what they are needed for.

Share this post


Link to post
Share on other sites

Let's see if this will be simple. It's at these times that I wish I had one of these modems to test. Since just loading the module seems to work, try the following;

 

Go to Yast-->System-->Kernel-->MODULES_LOADED_ON_BOOT and add "usbnet" (without the quotations).

 

Bear with me. I am on a new system and don't have my SuSE installation available to me yet.

 

I assume this connection is broadband and not DSL?

Share this post


Link to post
Share on other sites

Brilliant!

 

That was the solution. Thanks!

 

So to recap:

 

To install a Motorola SB4200 USB Cable Modem using the USB connection, with SUSE Linux 10.0

 

YaST > System > /etc/sysconfig Editor

 

System + Kernel + MODULES_LOADED_ON_BOOT

 

enter:

 

[font:arial]usbnet[/font]

 

in the box and click Finish

 

Reboot

 

I understand if you are using an older version with a 2.4.x kernel then the command would be CDCEther, but I can't check this.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×