Jump to content


Photo

Suse 10.0, Motorola SB4200, can't set up


  • Please log in to reply
5 replies to this topic

#1 raymondobasildon

raymondobasildon

    stranger

  • Members
  • 6 posts

Posted 01 April 2006 - 03:30 AM

I have an external USB cable modem - Motorola SB4200. I have successfully used this for years with Mandrake9.2 (and WindowsXP).
But I find the internet modules in YaST too numerous and too confusing.
I have just installed SUSE Linux 10.0 (my Mandrake was broke and I wasn't having any joy with support). I was delighted at how much the installation detected automatically. But after a couple of hours of trying I just cannot get the internet connection up and running.
The Cable modem is properly recognised.
I think I could manage it if I knew which modules to configure - there are so many and I'm sure most of them are not for me - a simple home user.
I have also tried setting up an Ethernet card as that is what is in the modem but this didn't help.
Please could someone help as I don't want to have to spend the whole weekend waiting to connect

#2 raymondobasildon

raymondobasildon

    stranger

  • Members
  • 6 posts

Posted 01 April 2006 - 07:33 PM

OK I have temporarily solved the problem. Acknowledgements to those who put this solution on the net.

In a terminal, login as superuser:

# su

Then enter the command:

# modprobe usbnet

This fixes it.

But only for that session. I used to do this sort of thing at the end of the nineties for the soundcard. And I can't remember the commands for making module changes permanent.

If I could persuade SUSE to load the module in the setup the problem wouldn't arise.

Incidentally, this is the answer for kernel 2.6.x

If you have 2.4.x kernel, the command would be:

# modprobe CDCEther


But can someone tell me how to make these changes permanent please.

#3 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 01 April 2006 - 07:58 PM

Once you modprobe the usbnet module, go to Yast and set up the connection. Choose DHCP and to enable the connection on boot. Follow though with the menu windows until the process is finished. Your new connection should be up after the next boot.

#4 raymondobasildon

raymondobasildon

    stranger

  • Members
  • 6 posts

Posted 02 April 2006 - 12:04 AM

Thanks for the input but I guess I'm unclear about precisely what you mean.

I have tried both configuring the Motorola (under Network Devices) before a reload and after. Each time after connecting up to the web with the modprobe usbnet command. Even when I had connectivity to the internet, I get the message that there is no driver loaded for this device it may be in the kernel ( or something [sorry should have written it down]).

Incidentally, during the reload, I tried looking for anyway I could persuade SUSE to load the usbnet module. There would appear to be none.

Anyway, whatever I do, everytime I reboot the computer, I'm not connected again and have to run the command.

I feel certain I'm overlooking something obvious and should be setting up one of the other modules in YaST. But there are so many and so little indication of what they are needed for.

#5 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 02 April 2006 - 12:34 AM

Let's see if this will be simple. It's at these times that I wish I had one of these modems to test. Since just loading the module seems to work, try the following;

Go to Yast-->System-->Kernel-->MODULES_LOADED_ON_BOOT and add "usbnet" (without the quotations).

Bear with me. I am on a new system and don't have my SuSE installation available to me yet.

I assume this connection is broadband and not DSL?

#6 raymondobasildon

raymondobasildon

    stranger

  • Members
  • 6 posts

Posted 02 April 2006 - 02:04 AM

Brilliant!

That was the solution. Thanks!

So to recap:

To install a Motorola SB4200 USB Cable Modem using the USB connection, with SUSE Linux 10.0

YaST > System > /etc/sysconfig Editor

System + Kernel + MODULES_LOADED_ON_BOOT

enter:

[font:arial]usbnet[/font]

in the box and click Finish

Reboot

I understand if you are using an older version with a 2.4.x kernel then the command would be CDCEther, but I can't check this.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq