Jump to content


Photo

Please Help in Configuring Wireless in Suse 10


  • Please log in to reply
19 replies to this topic

#1 verrami

verrami

    stranger

  • Members
  • 12 posts

Posted 18 March 2006 - 02:59 AM

Hi,

I installed the suse 10.0 and followed the steps to try and configure wireless:

1. installed ndiswrapper from cd
2. downloaded driver from net for my wireless card
3. did ndiswrapper -i <path to .inf> file
4. did ndiswrapper -l and got :"driver present, hardware present".
5. did ndiswrapper -m..first time got message like:"alias wlan0 something" but on reinstalling driver and doing this i get "alias directive already exists".
6. modprobe ndiswarapper
7. opened Yast...Hardware>network>network cards
8. clicked on add and deveice to wireless, configuration name module ndiswrapper ..used DHCP..managed, essid: any and no encryption

The wireless is not working despite these steps..when I do iwconfig wlan0..it says interface wlan0 not present..i would really appreciate it if any of you could help me out..i am new to linux and am willing to learn.please HELP!



#2 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 18 March 2006 - 06:49 AM

Ahh...loads of questions.

What name and brand (with the exact revision of the card) are you using.

It sounds like the driver got loaded OK. What driver did you use, the XP driver, or otherwise?

Where did you get the driver?

I assume you have no WEP or WPA key that is attached to the router?

There are specific instructions for SuSE, as I remember. See the ndiswrapper wiki. The directions may be a little outdated, but generally still apply.

Quote:
5. did ndiswrapper -m..first time got message like:"alias wlan0 something" but on reinstalling driver and doing this i get "alias directive already exists".
6. modprobe ndiswarapper


Do you mean that you re-installed the driver using ndiswrapper -i? You only need to do this once. If you got the hardware and driver loaded message, you are 1/2 done.

Ditto for the ndiswrapper -m command. once it is done, the system is set with the driver to load at boot time.

If you have a specific essid set up on the router, you probably need to use it, not "any." This does not always work.

Is the system totally open, or do you need a WEP or WPA key?

What is the output of iwconfig once the module is loaded? You may want not to post your essid, just be sure that the output shows your specific essid, not an arbitrary one.

If there is no WEP or WPA key, and the system is open, is there an option in Yast for open? Managed refers to a specific setup.


#3 zenarcher

zenarcher

    enthusiast

  • Members
  • 238 posts

Posted 18 March 2006 - 12:00 PM

Here is the step by step instructions I used for setting up wireless with SUSE 10.0 on my notebook computer. It is really an excellent step by step tutorial and even with my limited knowledge....got be going quickly...

http://nextgen.no-ip...apperinfo10.php

Regards,
zenarcher

#4 verrami

verrami

    stranger

  • Members
  • 12 posts

Posted 18 March 2006 - 12:10 PM

@zenarcher: Thanks! but I already used that guide to no avail:(

@danleff: Thanks for replying. To answer your queries:
Dell Wireless 1370 WLAN Mini-PCI Card, BCM4318 chipset. I downloaded the driver from the ndiswrapper driver website..the one with the list of drivers.(bcmwl5.inf)

I do not have encryption on the router. The thing is that i uninstalled my driver using ndiswrapper -e and reinstalled it using ndiswrapper -i. It shows up as "driver present. hardware present". I do modprobe ndiswrapper and i did not get any message. When i did ndiswrapper -m the second time, i got the message saying "alias directive present". The first time I got the message saying alias wlan0 something something. Is the essid the same as ssid in windows?

when i do iwconfig, i get an output saying interface wlan0 does not exist (something to that effect).

I'm not too sure if yast has an open option.

Please help me out..Thanks a lot!

#5 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 18 March 2006 - 06:32 PM

zenarcher, nice article!


verrami ;

You should have receied a more detailed message when checking ndiswrapper -l

Did the message say something like;

Installed ndis drivers:
bcmwl5 driver present, hardware present


One thing that most instructions don't always clearly say, is that you need both the .inf file and .sys file to install the drivers properly.

Did you have both these files available in a common directory when you did the ndiswrapper -i command?

Look in Yast and make sure that the Wireless-tools package is installed.


#6 zenarcher

zenarcher

    enthusiast

  • Members
  • 238 posts

Posted 18 March 2006 - 08:34 PM

Danleff, you are correct about most articles not being clear as to needing the .inf and .sys files. I learned that one the hard way, early on. What I finally did was to merely copy the entire Windows wireless driver folder over to my Home area, just to be sure I had everything I'd need.

zenarcher

#7 verrami

verrami

    stranger

  • Members
  • 12 posts

Posted 19 March 2006 - 03:33 AM

Originally posted by danleff:
Quote:
zenarcher, nice article!


verrami ;

You should have receied a more detailed message when checking ndiswrapper -l

Did the message say something like;

Installed ndis drivers:
bcmwl5 driver present, hardware present


One thing that most instructions don't always clearly say, is that you need both the .inf file and .sys file to install the drivers properly.

Did you have both these files available in a common directory when you did the ndiswrapper -i command?

Look in Yast and make sure that the Wireless-tools package is installed.


I did receive a detailed message when I did ndiswrapper -l. I got this message:
bcmwl5 driver present, hardware present

Am I supposed to get a message after doing modprobe ndiswrapper?

I had both the .sys and .inf file in the same directory. I did vi modprobe.conf (after doing modprobe ndiswrapper) and could not find ndiswrapper any where in the file.

Please help!

#8 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 19 March 2006 - 08:37 AM

Quote:
Am I supposed to get a message after doing modprobe ndiswrapper?


No, only errors would show up if there was a problem. A clean return to the command line indicates that the module loaded OK.

I remember reading that SuSE's configuration is a little different with the ndiswrapper -m command. I believe that either it does not work as it should, or the file actually ends up in /etc/modprobe.d/ndiswrapper.

You can check to see if the module is actually loaded, by running the lsmod command, as root user. Ndiswrapper should be listed near the top, if it is loading at boot.



#9 verrami

verrami

    stranger

  • Members
  • 12 posts

Posted 19 March 2006 - 09:37 AM

I reinstalled linux and went through the steps..it says that alias wlan0 added to modprobe.d but the problem is that when i do iwconfig, wlan0 does not show up..eth0, l0 show up...i dont know what im doing wrong..

#10 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 19 March 2006 - 07:53 PM

What steps did you follow? From where? zenarcher's referenced article, or the ndiswrapper wiki?

Let me clarify the problem as I see it.

Each distro of Linux has some basic differences in how they are set up when installed. This is why the ndiswrapper wiki has distibution specific instructions for setting up ndiswrapper in each major distro (flavor of linux). The general instructions may or may not work.

To use an example, zenarcher's referenced article recommends specific instructions for installing ndiswrapper. That article recommends getting rid of the natively installed ndiswrapper and installing the4 source package. This is because users have noted some problems with the package that comes installed with SuSE.


So, are you using the package that is already installed by SuSE, or did you install the source package? From your earlier post, you said;

Quote:
@zenarcher: Thanks! but I already used that guide to no avail


If you did not follow all the directions, including using the source package, then these directions may or may not work.

In SuSE, you do not use the ndiswrapper -m step, as this has been shown not to work. Instead, you try to configure the card via Yast. All the directions that I have seen relative to SuSE recommend this method.

Re-installing SuSE will not change a thing, unless you use the specific directions for SuSE. I know that it can be frustrating, but a lot of people think that a re-installation will solve problems. Best to work on the issue, rather then do a re-installation right off. Most of these problems are related to issues with the settings, not the basic installation.

When you configure the wireless card in yast, you need to know the essid of the router, WEP or WPA password, or if there is none, set it up as an open system. All these variables are in the network configuration dialog boxes in Yast.

A lot of folks get confused about these settings, as they are usually set up by the routers Windows based software and most users do not think of writing these settings down.

Back to the issues. Did you do the following;

1. Use the ndiswrapper package that came with SuSE pre-installed, or the source package?

2. Did you look and see if ndiswrapper was really loaded, via the lsmod command that I told you about?

3. Do you know the essid name set in the router?

4. Is you internet connection DSL, or Broadband? If the latter, does you ISP assign it's IP address dynamically, or statically?

The real problem here, is that most ISP's don't support Linux, so you need to gleen the information from them about how they assign ISP addresses. I ran into this with my DSL provider, who refused to give me the informatiuon, as they don't support Linux. Well, I had to figure this out myself when I started my subscription.

#11 verrami

verrami

    stranger

  • Members
  • 12 posts

Posted 20 March 2006 - 06:24 AM

1. Use the ndiswrapper package that came with SuSE pre-installed, or the source package?

I am using the ndiswrapper package that came with SuSE (in CD1)

2.Did you look and see if ndiswrapper was really loaded, via the lsmod command that I told you about?

ndiswrapper is really loaded. I checked using lsmod and it was top of the list.

3.Do you know the essid name set in the router?

I am using the SSID information I get in my windows system. Is it the same as the essid?

4.Is you internet connection DSL, or Broadband? If the latter, does you ISP assign it's IP address dynamically, or statically?

Its DSL and uses DHCP to assign dynamic IP's.

I did dmesg|grep ndiswrapper and got messages like:

ndiswrapper 1.2.2 loaded

ndiswrapper unable to load driver 'bcmwl5'.

Thanks for replying! I'm learning a lot but I just wish I could get the wireless to work.


#12 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 20 March 2006 - 10:57 AM

I wonder if there is a conflict with another module in SuSE. Take a look at the troubleshooting section of the ndiswrapper wiki and look at the following section;

Quote:
If ndiswrapper module can be loaded successfully, first unload the module from the kernel if it is already there with 'rmmod ndiswrapper' and then load it again with 'modprobe ndiswrapper'. Now check system messages with 'dmesg'. At the end, you should see messages from ndiswrapper. If everything works fine, you should see something like ..


Try unloading the module, reload it and see what the dmesg output shows. It should be at the bottom of the demsg output.

Since you use DSL, do you normally need a login name and password to access the internet? If so, you need to set up the card in yast, as an ASDL device connection. This allows you to input your username and password, as well as connect to the wirelesss device.

#13 verrami

verrami

    stranger

  • Members
  • 12 posts

Posted 20 March 2006 - 11:42 AM

I think im using an older version of ndiswrapper because on reading the troubleshooting guide, it mentioned an error called loadndiswrapper failed is due to an older version and i got that error when i did dmesg.....the cd has:ndiswrapper-1.2.2.i586..i downloaded ndiswrapper-1.10..im assuming thats the recent most one.

#14 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 20 March 2006 - 07:28 PM

If you plan on installing the newest version, you need to remove all references to the older one. See the uninstall instruction.

Of course, in your case, you used the rpm version, so that needs to be removed in yast, after you remove the old module using ndiswrapper -e bcmwl5.

Then make sure that the files in /etc/ndiswrapper are also all gone.

At this point, you can install the new version and follow the directions.

#15 verrami

verrami

    stranger

  • Members
  • 12 posts

Posted 21 March 2006 - 12:54 PM

Made some progress. I reinstalled the new version of ndiswrapper and went through the steps. Now when I do iwconfig wlan0 is atleast showing up in the list along with details. I set the essid and the network is open so no need for encryption. I did iwconfig wlan0 up and dhcpcd wlan0 but I am still not able to connect to the net.

#16 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 21 March 2006 - 06:30 PM

OK, are you trying to configure the connection through Yast, or the iwconfig interface?

Do you need a username and password (assigned by your ISP) to login? For example, I use Verizon and need a usernake and password to access the internet connection.

The other important point is if you are getting an access point. When you do iwconfig, is the output somethng like;

Wlan0 IEEE 802.11 ESSID:"your eesid value"
Mode:Managed Frequency:2.462 GHz Access Point: 00:00:00:00:00:00
Bit Rate:1 Mb/s Tx-Power:18 dBm Sensitivity=0/3


Or an actual value, like;

wlan0 IEEE 802.11g ESSID:"your essid value"
Mode:Managed Frequency:2.437 GHz Access Point: 00:E0:98:F1:4B:86

#17 verrami

verrami

    stranger

  • Members
  • 12 posts

Posted 22 March 2006 - 05:17 AM

well, I tried through both Yast and iwconfig. Which would you recommend? When I used Yast2, It installed the card as "Ethernet Interface Card".

I do not need to use a username, pwd to login.

Initially I got the output on the top when I did iwconfig but after that I did ifconfig then I got the output you pasted below. I think I'm close to getting it configured. Does kwifi help after the system recognises wlan0?

Thanks.

#18 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 22 March 2006 - 05:29 AM

As I mentioned, YaST is the preferred method.

See the referenced article that zenarcher noted above. Note the YaST Configuration section.

#19 verrami

verrami

    stranger

  • Members
  • 12 posts

Posted 22 March 2006 - 11:02 AM

@danleff..I got it to work! posting from linux right now. Thanks a lot for your time and advice.

#20 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 22 March 2006 - 06:33 PM

Nice going! have fun!!!




1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


    Bing (1)
IPB Skin By Virteq