Jump to content


Photo

kernel update + udev killed console display


  • Please log in to reply
1 reply to this topic

#1 ThurstonX

ThurstonX

    stranger

  • Members
  • 1 posts

Posted 06 February 2006 - 12:53 AM

Hi all.
I've just installed FC 4 (for the 3rd time) in order to isolate a problem with the console display. Briefly, running up2date or yum breaks the monitor. The display is fine through the boot, even looks like 1280x1024, but when it hits the xdm (gdm?) the screen is whacked. A green line crawls across the top left to right, slowly spreading. The middle is white and the bottom fifth or so is blue.

During the post-install/initial boot setup my video card (3Dfx Voodoo 4500) and monitor (Acer AL1715) are both recognized. All is fine after the install.

On my first two attempts to build this box I grabbed everything in up2date. Result: same busted monitor symptom. The latest kernel (kernel-2.6.15-1.1830_FC4) was not out during the first two installs, so I was grabbing the one prior. This time I updated yum to use livna and installed yumex and launched the latter, forgoing up2date. The latest kernel and kernel-devel rpms were listed.

This time around I only selected the kernel and kernel-devel rpms. The dependency check required udev-071-0.FC4.2, so what choice did I have. I ran the update, rebooted, whammo! same prob. Since booting to the original kernel doesn't help, I gotta finger udev as the culprit. Erasing the udev rpm screws the system royally (no X) as one might suspect, so I added udev* back using yum. reboot. Jacked-up monitor returns. Familiarity begins to breed contempt.

I can VNC into it fine, so again, all signs point to udev (vs. some xorg thing; went down that road on install #2). Some Linux rag article on udev states that /etc/dev will be repopulated dynamically on every boot. Since I have no /etc/dev, perhaps he meant /etc/udev. Regardless, I'm clueless how to proceed. Another install seems ... stupid. Hoping one of you smart, not-pissed-off folks can lend a hand.

In the meantime, that PC's got some BOiNC # crunching to do. In WinXP. It's a sad day. I hope I awake to a nugget of truth under my virtual pillow.

TIA.

PS - Tried searching bugzilla.redhat.com but that site is about as whacked as my console.

PPS - under Desktop | System Settings | Display the video card and monitor are correctly identified (this gleaned from a VNC session)

#2 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 06 February 2006 - 03:58 AM

I bet the video drivers are depreciated for this old card in the updated kernel.

Boot the original kernel and see what happens.

The option to boot the older kernel should still be in grub.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq