Jump to content


Problems with helpsvc.exe

  • Please log in to reply
5 replies to this topic

#1 dumontal



  • Members
  • 5 posts

Posted 11 December 2005 - 08:26 AM

Hi all.

I wanted to ask your opinion about somehting going on on my computer. Lately (4-5 days, maybe a week), there's this "helpsvc.exe" that's been loading itself out of nowhere and it's using 90% and more of the CPU. It's said to be either the help and support service from windows or, as i've found on the net, a virus, W32/Sdbot-OG.

I've used hijackthis, bazooka anti-spyware, Ad-Aware and my antivirus, and none have found anything related to that particular problem.

Where should the file be, or where should it not be? I've found it in

and in

Thanks for your lights!

#2 Sampson



  • Members
  • 1458 posts

Posted 11 December 2005 - 03:08 PM

Depending on which service pack you are using apparently helpsvc can run amok. (Though I have read that if affects even those SP2 packs that are supposed to be immune. Generally happens during a windows update or install of a program that goes awry. This article from Microsoft explains it. It also gives a possible hotfix: http://support.micro...kb;en-us;839017

But, if you want to shut it down and not have it continue to restart do the following:

Create a DWORD entry called Headlines and give it the value of 0, for the following Registry Key HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ PCHealth \ HelpSvc \

There is a side effect to this solution however: This disables the Headlines feature which simply means that your Help and Support Center headlines are never updated.

#3 Cormac



  • Members
  • 397 posts
  • LocationUSA

Posted 11 December 2005 - 05:18 PM

What about going into the services section and changing how it is run. Instead of automatic, change it to manual.
You can go into control panel, then click on performance and maintenance, then click on admin tools and then click on services.
Scroll down to help and support and then right click on it, then click on properties and then on the general tab you will see startup type.
Change the type to manual and then click apply.
Then it will only pop up when you actually click on help to use it.

#4 dumontal



  • Members
  • 5 posts

Posted 14 December 2005 - 04:50 AM


Thanks, it worked!

I never uses that service thing anyway, so it'll just stop bothering me, yeah!

#5 starsinthesky



  • Members
  • 1 posts

Posted 30 December 2005 - 08:42 PM

Could someone contact microsoft and retrieve the


hot fix and post it here or somewhere on the net please?

does anyone have it?

#6 Sampson



  • Members
  • 1458 posts

Posted 30 December 2005 - 10:14 PM

Well, this is a hotfix; it also happens to be one of those that Microsoft wants to charge you for. So, it will be up to you to "phone home" and get it (or until Microsoft relents on its Ebeneezer Scrooge imitation). Meanwhile, there are a couple of workarounds posted here.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq