Jump to content


Photo

ASUS GeForce N6600 - problems if using DVI interface


  • Please log in to reply
6 replies to this topic

#1 Phalanx-Imawano

Phalanx-Imawano

    member

  • Members
  • 139 posts

Posted 10 December 2005 - 01:55 PM

I'm having a strange problem with my ASUS GeForce N6600 video card - if I use the DVI interface (because I have an LCD monitor with DVI), prolonged gaming results in what looks like the results of an overheating video card - blotches, artifacts, and eventually system crash (no BSOD, the PC just freezes with a blank screen). I don't get those problems if I use the conventional SVGA/RGB connection (but then I wouldn't be taking full advantage of my LCD monitor's features). What's likely to be wrong with my video card? Bad design? And note that this happens even with games having very LIGHT system requirements (last time this happened, I was playing QUAKE 1!).

#2 Sampson

Sampson

    veteran

  • Members
  • 1458 posts

Posted 10 December 2005 - 04:05 PM

It could very well be a defective card or some driver problems. I have noted a peculiarity about nVidia drivers in relation to monitors. Don't want to go into a long discussion about it but sometimes if the monitor is not designated correctly before the drivers are installed for whatever reason it messes things up.

From your desktop right click and choose Properties, click on the Settings tab, then click the Advanced button, then click on the Monitor tab. Is the monitor name and number showing up there? If not then click on the nVidia tab, let its interface come up and click Direct Access and read the Window that comes up. When the DVI is connected is it saying that it is a Cathode Tube Analog or is it giving you the proper manufacturer, LCD, and Digital? I know that the drivers usually work with the Generic plug and play, but sometimes the card and certain monitors have to be specific.

#3 Phalanx-Imawano

Phalanx-Imawano

    member

  • Members
  • 139 posts

Posted 10 December 2005 - 09:58 PM

The monitor driver used is "Plug and Play Monitor", and besides my LCD monitor has no specific drivers (it didn't come with a driver disk, and the manufacturer has no website). Unfortunately I can't find those settings you're talking about (Direct Access?). Anyway I've decided to just stick to using the SVGA/RGB connection since it has no problems, and quality wise, I can't really perceive any difference between that and using DVI (though I did notice that GLQuake can support 1280x1024x32 only if using DVI; with SVGA/RGB, I have to settle with 1280x1024x16).


#4 Sampson

Sampson

    veteran

  • Members
  • 1458 posts

Posted 10 December 2005 - 11:08 PM

Right click Desktop-Properties-Settings tab-Advanced button, Nvidia tab. There should be a pop up screen to the left of the main window. One of the contents on that screen should be Nvidia Direct Access. (This allows you to use the Nvidia interface to center or move your screen) Click on this. This will change the main screen and tell you the video card, the serial number, the display type, etc. It should read Cathode ray tube and Analog when you are using the SVGA connection. But, under Plug and Play generic monitor, I have found that when the DVI input is used, this remains Cathod ray tube - Analog. Or, when it reads it correctly LCD Digital, for whatever reason the Plug and Play is not always in sync with some LCD monitors.

Have you tried to see if you can get Windows to see your specific Monitor? Right click Desktop-Properties-Settings-Advanced button-Monitor tab-Properties button-Drivers tab-Update drivers button-at pop up window tell it no and you want to choose the monitor which will eventually bring up the Manufacturers and the specific models for that manufacturer?

Nvidia can be quirky and can start throwing you into the "Infinite Loop" syndrome saying it failed at nv4_disp.dll if you mess around with it too much. I was just curious to see what your card was reporting. Don't want you to be a guinea pig.

#5 Relic

Relic

    addict

  • Members
  • 516 posts

Posted 10 December 2005 - 11:23 PM

Unless your LCD monitor is a newer one, it's probably way too slow to keep up with games, even some of the newest monitors can't respond fast enough.

This leads to "ghosting" amongst other visual anomalies. Although LCD technology is slowly catching up, it will be a long time before it can surpass CRT's, if ever. Electrons will always respond/move faster than liquids, that's just physics. LCD's may get close to CRT response times, but I doubt they'll ever surpass them.

Also, the "Plain-Jane" (no offence meant) 6600 is not really a gaming card, the 6600GT would be the better choice. You haven't said whether or not that's an AGP card, or a PCI-Express. Give me some details, there may be a BIOS update/hack for your card to get you close to 6600GT speeds.

If not, there's always NVTweak and RivaTuner. smile

#6 Phalanx-Imawano

Phalanx-Imawano

    member

  • Members
  • 139 posts

Posted 10 December 2005 - 11:39 PM

Originally posted by Sampson:
Quote:
Right click Desktop-Properties-Settings tab-Advanced button, Nvidia tab. There should be a pop up screen to the left of the main window. One of the contents on that screen should be Nvidia Direct Access. (This allows you to use the Nvidia interface to center or move your screen) Click on this. This will change the main screen and tell you the video card, the serial number, the display type, etc. It should read Cathode ray tube and Analog when you are using the SVGA connection. But, under Plug and Play generic monitor, I have found that when the DVI input is used, this remains Cathod ray tube - Analog. Or, when it reads it correctly LCD Digital, for whatever reason the Plug and Play is not always in sync with some LCD monitors.


Hmm, it seems my particular driver doesn't have that at all.

Quote:
Have you tried to see if you can get Windows to see your specific Monitor? Right click Desktop-Properties-Settings-Advanced button-Monitor tab-Properties button-Drivers tab-Update drivers button-at pop up window tell it no and you want to choose the monitor which will eventually bring up the Manufacturers and the specific models for that manufacturer?

Nope, there's no entry for my monitor (the brand is Phoenix).

Quote:
Nvidia can be quirky and can start throwing you into the "Infinite Loop" syndrome saying it failed at nv4_disp.dll if you mess around with it too much. I was just curious to see what your card was reporting. Don't want you to be a guinea pig.

Only happened a few times, particularly the first few times I played Half-Life 2.

Originally posted by Relic:
Quote:
Unless your LCD monitor is a newer one, it's probably way too slow to keep up with games, even some of the newest monitors can't respond fast enough.

This leads to "ghosting" amongst other visual anomalies. Although LCD technology is slowly catching up, it will be a long time before it can surpass CRT's, if ever. Electrons will always respond/move faster than liquids, that's just physics. LCD's may get close to CRT response times, but I doubt they'll ever surpass them.

I used to experience that until I increased the Refresh Rate (my LCD monitor supports either 60 or 75 Hz).

Quote:
Also, the "Plain-Jane" (no offence meant) 6600 is not really a gaming card, the 6600GT would be the better choice. You haven't said whether or not that's an AGP card, or a PCI-Express. Give me some details, there may be a BIOS update/hack for your card to get you close to 6600GT speeds.

If not, there's always NVTweak and RivaTuner.

It's a AGP GeForce 6600 (this one to be exact). The GT's are rare in my locality (problem with the Philippines is not as much selection of products available), and the one I did see is PCI-Express so I can't use it (my mobo is AGP).



#7 Relic

Relic

    addict

  • Members
  • 516 posts

Posted 11 December 2005 - 02:04 AM

Found some BIOS updates, but they're in a language I can't understand, possibly Russian, so forget that. :x

Anyhow, I suggest trying some older drivers for your vidcard, start with the 77.77's http://downloads.gur...d.php?det=1145, they work very well with my 6600GT AGP, newer versions suck for me. If the 77's don't work, try the 61.93's http://downloads.gur...oad.php?det=904

While you're at it, grab NVTweak, gives you a lot more options for setting up your vidcard, along with the ability to overclock it. Screen adjustments included. smile

http://downloads.gur...oad.php?det=911

***VERY IMPORTANT***

Always uninstall your nVidia drivers before installing new drivers, then make sure your system has been cleaned of the ditritus left behind by the un-installer, there's ALWAYS something left behind, which will cause conflicts. After uninstalling your old drivers, run Nasty File Remover http://downloads.gur...oad.php?det=582

Hopefully, you'll get something that will help your frame rates. smile




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq