Jump to content
Compatible Support Forums
beautflbrunette1

THE SIMS 2 DIRECTX 9.0C ERROR MESSAGE!! HELP! URGENT!!

Recommended Posts

ok, i am getting very irritated. i got the sims 2 when it first came out for x-mas (maybe a year ago i think?). when i played it the first time, it worked fine. then about 2 weeks or less after i first played it, it came up with an error message when i tried to run it (and every time after that it does), the error message is: areasrxfvzdxfhn9xt.jpg it makes me very mad that i cant play this game, STILL! i have looked on every site out there and tried sooo many things and none of them have worked. please im begging you PLEAES HELP ME !!!! my computer is

-Operating System Microsoft Windows XP Professional

-DirectX 4.09.00.0904 (DirectX 9.0c) *IT SAYS I HAVE 9.0c!!

-System Memory 384 MB (SDRAM)

-Video Adapter Intel® 82810 Graphics Controller (Microsoft Corporation) (32 MB)

-3D Accelerator Intel i752

-Monitor ViewSonic G771 [17" CRT] (80729325)

-DirectX Hardware Support DirectX v6.0

 

i dont know what any of this means i have EVEREST Home Edition, if someone would please be kind to help me?

 

where did i ever go wrong??;( :x x)

Share this post


Link to post
Share on other sites

This is one solution though the best would be to upgrade your card:

 

The following steps can be used to eliminate or minimize the issue(s) reported with the game:

 

1. Set the display to 16-bit color. To make this change, follow these steps:

a. Click on the Start menu and select Settings, Control Panel, and then double-click on Display. If using Microsoft Windows* XP: Click on the Start menu and select Control Panel, "Switch to Classic View" if the category view is shown, and then double-click on Display.

 

b. Select the Settings tab.

 

c. Change the Color Quality (Color Depth) to 16-bit color.

2. Run the game with the -w switch which forces the game to run in a window. To add this switch, follow these steps:

 

a. Right-click on the The Sims 2 game and left-click on Properties. You can do this either on the game's shortcut on the desktop or on the game's entry in the Start menu.

 

b. Add a space and -w to the end of the Target field, so that it looks like this: "C:\Program Files\EA GAMES\The Sims 2\TSBin\Sims2.exe" -w

 

Note: The actual path may vary depending on where the game was installed. Make sure that the -w goes outside the quotation marks and that there is a space between the last quotation mark and the -w.

 

c. Click OK.

 

This applies to:

Intel® 82815 Graphics Controller and Intel® 82810 Graphics Controller

Share this post


Link to post
Share on other sites

I know that Intel no longer supports that graphics controller - see here: http://support.intel.com/support/graphics/intel810/ and Sims 2 is a graphics memory hog. When it says it supports the following cards, it means it:

* ATI RadeonTM series (7000 or better)

o Radeon 7000/VE series (non-T&L; requires 2.0 GHz processor)

o 7200, 7500

o 8500, All-In-Wonder 8500

o 9000, 9200, 9500, 9600, 9700, 9800

o X300, X600, X800

 

* Nvidia® QuadroTM series

o Quadro, Quadro2, Quadro4

 

* Nvidia® Geforce series (GeForce2 and better)

o GeForce2

o GeForce3, 3 Ti

o GeForce4, 4Ti, MX 420, 440

o GeForce FX 5200, 5600, 5700, 5800, 5900, 5950

o GeForce 6600, 6800

 

* Intel® Extreme Graphics (non-T&L; requires 2.0 GHz processor)

o 82845, 82865, 82915

In other words, you should put in a new graphics card with plenty of memory on it. The problem is I can't suggest one since I don't know if your card support AGP 4x or if you will have to install an old PCI card.

 

Even if you can get Sims 2 to work on your machine in its present setup, all the cute bells and whistles graphically will most probably be unavailable to you.

Share this post


Link to post
Share on other sites

can u please help me...i cant figure out what to do.. I am getting this same message..it say that i cant play the sims 2 because i dont have directx 9.0 or sumthing and i cant walk because i broke my foot and all i want is to play this game and i cant because it doesn't work!!HELP!!!!!!

 

 

Share this post


Link to post
Share on other sites

If you have the onboard Intel chipset: Intel® 82815 Graphics Controller and Intel® 82810 Graphics Controller - in theory it will run if you do what is listed above. However, it won't run well if at all. Tell us what your video card is and we may be able to help.

Share this post


Link to post
Share on other sites

I'm sorry about that but i have no idea waht the video chip is or anything like that soyou will have to like majorly help me ok please i really want to play and all i can do is that and watch tv because of my foot so please !! thanks! byee

 

 

frownfrownfrownfrownfrownfrownfrownfrownfrownfrownfrownfrownfrownfrownfrownfrown

Share this post


Link to post
Share on other sites

Right click on My Computer, then click on Properties from the menu that appears, then click on the Hardware tab, then click on the Device Manager button, then click on the "+" next to Display Adapters. This will open up and show you a subentry which should display the name of your card or onboard device.

Share this post


Link to post
Share on other sites

Samantha098 the only way that you will be able to play the game with any facility is to buy one of the boards mentioned above and install it and disable your 82815 Graphics Controller. You can try to lower the resolution and a variety of other things that are often suggested, but it will not be a fun experience and you will come to screen that you won't be able to view or you will need a tool that won't appear.

Share this post


Link to post
Share on other sites

First press start on your computer and click run and in the box type dxdiag. Then in the window that pops up click display. At the botton there are 3 programs with either enabled, disabled, or not available. Next to Direct3D Acceleration I am guessing it says not available. If it says disabled just enable it. If it says enabled and it doesn't work I don't believe I can help. Now if it does say not available you will have to download DirectX 9.0c at this website: http://www.microsoft.com/downloads/detai...;displaylang=en Verify your type of internet connection and click continue and verify it again and click download. Now how you download it is very important! Do not press open you have to save it! Make sure you save it on our desktop! YOU CANNOT SAVE IT ANYWHERE ELSE! After it is downloaded on your desktop minamize the internet to your desktop and you will see its icon. Double click it to run it and follow what it says. After that is done restart your computer and go back to pressing start, run, dxdiag and see if its there now and enabled and try playing Sims 2 now!

 

I hope I was a help and if you have any other questions on it please email them to me at loismustdie_84@yahoo.com Good luck!

Share this post


Link to post
Share on other sites

I really need help like bad and I need head on so if some one can add me on msn I am having the same problem and I cannot figure anything out ..so addd me and help I want to play the sims. animal_diva@hotmail.com

Share this post


Link to post
Share on other sites

You need either:

 

1. A discreet graphics card such as ATI or Nvidea card that supports DX 9 functionality.

 

2. A new laptop with a new graphics chipset e.g. Intel 9xx series or ATI or NVidea

 

3. Play Sims Deluxe instead of Sims 2

 

4. On use the tips above by playing the game in a window using the -w option in the shortcut.

Share this post


Link to post
Share on other sites

Mmkay, so i also have this Sims problem, and when I go to my Device Manager it doesn't have a Display Adapters section so i tried the next solution given, that didn't work either -all three of them were "Not Availale" and even after the download and i restarted it, the game still responded with that message. Any other ideas? Please, your help is greatly appreciated.

 

-Karina

Share this post


Link to post
Share on other sites

Same error for me. I ran dxdiag. I have already updated to the latest driver and also downloaded directx 9.0C. Pls help

--------------------

DirectX Debug Levels

--------------------

Direct3D: 0/4 (n/a)

DirectDraw: 0/4 (retail)

DirectInput: 0/5 (n/a)

DirectMusic: 0/5 (n/a)

DirectPlay: 0/9 (retail)

DirectSound: 0/5 (retail)

DirectShow: 0/6 (retail)

 

---------------

Display Devices

---------------

Card name: Mobile Intel® 945 Express Chipset Family

Manufacturer: Intel Corporation

Chip type: Intel® GMA 950

DAC type: Internal

Device Key: Enum\PCI\VEN_8086&DEV_27A2&SUBSYS_99171584&REV_03

Display Memory: n/a

Current Mode: 1280 x 800 (32 bit) (60Hz)

Monitor: Plug and Play Monitor

Monitor Max Res: 1600,1200

Driver Name: igxprd32.dll

Driver Version: 6.14.0010.4926 (English)

DDI Version: unknown

Driver Attributes: Final Retail

Driver Date/Size: 2/15/2008 13:12:06, 57344 bytes

WHQL Logo'd: Yes

WHQL Date Stamp: n/a

VDD: n/a

Mini VDD: igxpmp32.sys

Mini VDD Date: 2/15/2008 13:12:06, 5854752 bytes

Device Identifier: {D7B78E66-64E2-11CF-0A65-1DB9A2C2CB35}

Vendor ID: 0x8086

Device ID: 0x27A2

SubSys ID: 0x99171584

Revision ID: 0x0003

Revision ID: 0x0003

Video Accel:

Deinterlace Caps: n/a

Registry: OK

DDraw Status: Not Available

D3D Status: Not Available

AGP Status: Not Available

DDraw Test Result: Not run

D3D7 Test Result: Not run

D3D8 Test Result: Not run

D3D9 Test Result: Not run

 

 

Share this post


Link to post
Share on other sites

OK For people who need help with the sims 2 problem. Make sure you have installed Directx 9.0c , make sure with the dxdiag tool. What i did to solve this problem is sat around trying a million things until onw worked! Go to this website:

 

http://support.dell.com/support/downloads/driverslist.aspx?c=us&l=en&s=gen&ServiceTag=&SystemID=DIMENSION%205100&os=WW1&osl=en&catid=&impid

 

when you get there where it says category get the video option. then when it reseives results scroll down to the box that says "Intel-Driver applies to: 945G Graphics controller"

download that. when downloading first click save and save it to our desktop. then run it. when you are done downloading it restart your computor. when you get back you should be able to play.

 

IF NOT FEEL FREE TO EMAIL ME AT ocean.perywinkle@yahoo.com

I WILL HELP YOU...I KNOW WHAT ITS LIKE! grin

Share this post


Link to post
Share on other sites

I LOVE YOU!!!! smile i had the same issue as" beautflbrunette1" and EA could not help me for 2 days i got the same answer "we are sorry blah blah " but im happy i googled this and ran into your first post i have windows vist btw .i joined just to thank you :)becouse i was going to remove the game if i didnt get a remedy.

Share this post


Link to post
Share on other sites

I have approximatively the same problem as edaz:when i run dxdiag,only the direct sound works for me.A few days ago i reformatted my pc,i believe that the problem comes from that.I already downloaded directx 9.c but still nothing.Help me please!!!

Share this post


Link to post
Share on other sites

Hi, I have the same problem. My mum recently got me a laptop and it's a Toshiba Satellite and it's OS is Windows 7. I have DirectX 11 and for some reason the game isn't working.

 

Can anyone help me? Thanks!

Share this post


Link to post
Share on other sites

Hi, I have the same problem. My mum recently got me a laptop and it's a Toshiba Satellite and it's OS is Windows 7. I have DirectX 11 and for some reason the game isn't working.

 

Can anyone help me? Thanks!

 

Either your graphics card/integrated chip is not supported or you have old drivers.

 

Click Start, type dxdiag.

You should see your graphics card name and driver version from Display tab.

Share this post


Link to post
Share on other sites

I am also getting very annoyed.

I currently have downloaded and installed DirectX 9.0c, doing it by installing it normally and opening up Sims and clicking on the DirectX file.

I have an Intel®82865G Graphics Controller and I am a Windows XP User.

I also have an Intel® Celeron® CPU 2.80ghZ Processor.

My memory is 510MB RAM.

 

MORE DETAILS ABOUT MY DIRECTX 9.0C ARE THAT IT SAYS (4.09.0000,0904)???

 

PLEASE HELP!!

Share this post


Link to post
Share on other sites

I have an Intel®82865G Graphics Controller and I am a Windows XP User.

You need a new graphics card.

 

My memory is 510MB RAM.

 

You need at least 1GB RAM.

Share this post


Link to post
Share on other sites

OK, not sure how old your post is, but I had exactly the same problem on my daughter's laptop, which had recently been upgraded to W7 Ultimate, so all I did was this:

Right click on the shortcut to Sims2, choose Properties.

Click on the compatability tab, make sure the "run this program in compatability mode for: is OFF

Click on shortcut tab, make sure the 'target' has a speach mark at the front and end, i.e. "C:Program...blahblah"

and add one space and -w after the last speach march, so will look like this "C:Prog...blahblah" -w

This allows the program to run in windowed mode and stops the error of directx9.0 c happening!

Hope that helps?

Cheers,

Jcp

 

ok, i am getting very irritated. i got the sims 2 when it first came out for x-mas (maybe a year ago i think?). when i played it the first time, it worked fine. then about 2 weeks or less after i first played it, it came up with an error message when i tried to run it (and every time after that it does), the error message is: <img src="http://img31.imageshack.us/img31/8164/areasrxfvzdxfhn9xt.jpg" alt="" /> it makes me very mad that i cant play this game, STILL! i have looked on every site out there and tried sooo many things and none of them have worked. please im begging you PLEAES HELP ME !!!! my computer is

-Operating System Microsoft Windows XP Professional

-DirectX 4.09.00.0904 (DirectX 9.0c) <span style="font-weight: bold">*IT SAYS I HAVE 9.0c!!</span>

-System Memory 384 MB (SDRAM)

-Video Adapter Intel® 82810 Graphics Controller (Microsoft Corporation) (32 MB)

-3D Accelerator Intel i752

-Monitor ViewSonic G771 [17" CRT] (80729325)

-DirectX Hardware Support DirectX v6.0

 

i dont know what any of this means i have EVEREST Home Edition, if someone would please be kind to help me?

 

where did i ever go wrong??;( :x x)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×