Jump to content


Photo

Different distros/ hardware..... same hard freezes?


  • Please log in to reply
7 replies to this topic

#1 rmarkin

rmarkin

    stranger

  • Members
  • 4 posts

Posted 27 September 2005 - 04:34 AM

Hardware:

Soyo KT600 Dragon Plus V2.0
Athlon XP 3200 (Barton)
512 MB PC2700
On-board audio
On-board NIC
80 gig Hitachi SATA (also tried 30 gig Maxtor IDE)
ATI Radeon 7200 (also tried Nvidia GF4 MX 440)
PS2 Keyboard
Microsoft USB Wheel Mouse (also tried generic PS2 mouse)

OS's tried:

Ubuntu 5.04 (Hoary)
Ubuntu 5.10 (Breezy)
Mandriva 2005 LE

Problem:


Sporadic hard freeze requiring a reset. No response from Alt-Ctrl-F* or Alt-Ctrl-Backspace. Freeze would occur during random tasks or while doing nothing at all. Freeze would occur while running random apps or none at all. All available updates installed (when possible). No other software added beyond the base "Desktop" system with Gnome and KDE. Sometimes the system would run for 15 - 20 minutes between freezes, sometimes it would freeze almost immediately. A couple of times it froze while sitting at the login screen. The freezes always were the same in that the system would stop responding although I could still move the mouse. The only difference that I did notice was when I changed to the Nvidia card, the screen would slightly distort when the system froze. With the ATI card the display would stay clear when it froze. Either way it froze.

Each time I made a hardware change I did a clean install of whichever OS I was trying. There seemed to be no difference between the freezing in either Gnome or KDE. All installs went smooth with no apparent issues. All installation media are burned ISO's from reputable mirrors.

The system has been very stable up until installing these OS's. CPU temp in BIOS on average is 42c. Stable OS's include WinXP and Mandrake 8.1 which both work fine with no freezing.

I am very patient and have nothing but time, and am very curious as to what is causing these crashes.

Any help would be appreciated.




#2 dllfile

dllfile

    stranger

  • Members
  • 17 posts

Posted 28 September 2005 - 01:31 AM

Do you have a PS2 Keyboard and Mouse handy? (In case your using USB versions)

you may want to try disabling USB in the BIOS and see if the problem still exists. (be sure to unplug any USB devices you have plugged in as well)

If it clears up after disabling USB, then there is the problem. I have experienced this problem as well on a ABit board. Seems to happen more so in Mandriva 2005 LE and Xandros 3.0 Deluxe

If it clears up after doing the above, I would take that time to add some update resources and be sure to grab updates/bug fixes as there may be a bug fix that will solve the problem once USB is enabled again.

Here is a good site to get some of the newest working resource listings too add to your list.
http://easyurpmi.zarb.org/

If that does not work for you, you may want to try XandrOS 3 or Fedora Core 4

// Regards
dllfile

#3 rmarkin

rmarkin

    stranger

  • Members
  • 4 posts

Posted 29 September 2005 - 02:42 AM

Thank you for your reply,

I am using a PS2 keyboard and I have tried with a PS2 mouse as well. (No USB devices connected). I have not tried disabling USB in the BIOS but I will.

I'll get back with you,

Robert

#4 dllfile

dllfile

    stranger

  • Members
  • 17 posts

Posted 30 September 2005 - 07:23 AM

np, smile if the problem does disappear after disabling USB in the BIOS, then I would grab the updates for your distro and possibly consider compiling the latest Kernel Source and customize it to your system as it may give some better performance as well as stability and may resolve other misc issues with the USB.

Anyways, just lemme know, be glad to try my best in helping you.

#5 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 01 October 2005 - 03:09 PM

I had the same problem with one of my systems recently...never figured out why. It just went away.

I found once that a faulty cdrom drive was at fault. When I looked at the log messages, it showed a problem. Does the freeze happen when accessing a cdrom disk?

There should be no reason to disable USB. More likely, try diabling PNP OS in the bios. Look in the bios under PNP Configuration.

If this does not solve the issue, which bootloader are you using, Grub or Lilo? You may need to add the noapic option to Grub or Lilo. Let us know what bootloader you are using and we can add this to the command options. Newer motherboards sometimes need this option added.



#6 rmarkin

rmarkin

    stranger

  • Members
  • 4 posts

Posted 02 October 2005 - 01:46 AM

Thank you for the replies,

I have went backwards briefly in an attempt to move forward.

In order to make troubleshooting easier, I have performed another clean install as follows:

hda is 80gig hitachi SATA with XP Pro (so that I can reply to posts reliably)

hdb is 80gig SATA hitachi with Ubuntu 5.10 (Breezy) exhibiting the same symptoms described above. I will leave the system as is while troubleshooting.

Bootloader is GRUB.

The rest of the hardware is the same as first post, and I am using the Nvidia GF4 MX 440 video card.

Ubuntu has no additional software added from the base install. The updates have NOT been done because it will not run the 1.5 hours it takes to d/l them.

I have not yet tried disabling USB in BIOS but it doesn't seem likely to fix it because when the system crashes, about the only thing that continues working is the USB mouse! I will try it though just in case.

About the "noapic" parameter, I have done some reading and that looks promising. Which line do I add it to? Am I correct in thinking that if at the GRUB menu I press "e" and edit a line, it is only effective for that particular boot-up?

I also read about "acpi=off" fixing some issues, but again I don't which line to add it to.



danleff,
The freezes occur at random times, and so far have not occurred while accessing a CD. In fact amazingly it did it at a console yesterday. I had logged-in in terminal mode and while just sitting there the normally white text turned different colors and the font became very distorted. I could still interact with the console, but I could not read anything.



Thank you for your ideas,

Robert



#7 rmarkin

rmarkin

    stranger

  • Members
  • 4 posts

Posted 07 October 2005 - 11:52 PM

Which line in the Grub config file do I add the "noapic" or the "acpi=off" parameters?

Robert

#8 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 08 October 2005 - 02:21 AM

Add one or the other command to grub at the kernel line.

Depending on what distro you are using right now, at the grub screen, either you hit the esc key, or "e". Then make sure that the line highlighted is the kernel (hd0,)...line.

Hit "e" again and you will be at the edit mode for that line. Use the forward/backward key to make sure that you are at the end of the line. Add the command, making sure that there is a space after the last entry and your command addition. Hit the enter key, then "b" for boot.

Yes, it is only good for that boot. But if it works, you can add the command to the /boot/grub/menu.lst file, using your favorite text editor. It will then stick. The editor that you use needs to be as root user.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq