Jump to content
Compatible Support Forums
Sign in to follow this  
mjstone03

Linux slave DNS server config

Recommended Posts

Hi. I'm trying to configure a linux(RH Enterprise Server 4) secondary DNS server for a zone that's hosted by a WIndows 2k box, both primary forward and reverse lookup zones. The windows machine has dynamic updates selected and zone transfers enabled by ip address for both zones, and a forwarder enabled- nslookup looks good. The linux machine has it's ip statically set with primary dns server pointing to windows, secondary itself, dns search path set. The windows machine will be promoted to domain controller after successful DNS configs.

 

Windows 2k

IP-192.168.1.254/24 gateway=192.168.1.254 DNS=192.168.1.254

DNS forward zone=abc.com

DNS reverse zone=1.168.192

DNS forwarder= 10.71.100.100 w/recursion

DNS dynamic updates enable for both forward/reverse

DNS zone transfers by IP=192.168.1.253

-nslookup checks out

 

Linux

IP-192.168.1.253/24 gateway=192.168.1.254 DNS Primary=192.168.1.254, Secondary=192.168.1.253, DNS search path= abc.com, DNS Hostname= linux01.mbi.com

 

How should I config the named file? After I configured the file the first time, I then swithed the network config so it pointed to itself for DNS first, then windows 2nd. Any pointers you can give me would be much appreciated. Thanks.

 

 

Share this post


Link to post
Share on other sites

Okay- I configured the named.conf file and the windows server successfully pushes the zones. However when I check the log/messages file it says that the zone was transfered, followed by 'dumping master file-.....-: open: permission denied' something or other, followed by a 'failed while receiving responses, permission denied'. Not sure what to do at this point. It looks right. Here's what I've got-

The global options are default(directory, statistics-file)

 

};

controls {

inet 127.0.0.0 allow { localhost; } keys { rndckey; };

};

zone "." IN {

type hint;

file "named.ca";

};

zone "abc.com" IN {

type slave;

masters { 192.168.1.254;

}

file "slave.abc.com";

};

zone "1.168.192.in-addr.arpa" IN {

type slave;

masters { 192.168.1.254;

}

file "slave.1.168.192";

};

zone "0.0.127.in-addr.arpa" IN {

type master;

file "named.local";

allow-update { none; };

};

include "/etc/rndc.key";

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×