Jump to content


Photo

Motorola SB4200 SUFFboard


  • Please log in to reply
11 replies to this topic

#1 SerJ_G

SerJ_G

    stranger

  • Members
  • 2 posts

Posted 25 September 2005 - 02:39 PM

Hi! Am n00b in Linux, so I'd like to setup my internet connection with your help... I've Cable modem Motorola SB4200 SURFboard, it's connected into USB port... My IP and DNS gives dynamic (DHCP), so I'm asking u for help! pls..
P.S. sorry for my bad English


#2 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 25 September 2005 - 03:41 PM

What distro and version are you using? Fedora Core 4, Mandriva 2005....?

The easiest way is to run your internet connection through an ethernet card, if you have one on your system.

There is a USB module for this modem, but it may be somewhat confusing for a newbie to set up properly.

Look at "Related Links" below and you will see an explanation on the USB method. The link is here.

But, the easiest way would be to disconnect USB, and run a CAT5 cable from the ethernet card to an open slot on the modem.

Then, depending on what distro you are using, use the network wizard to configure the card for auto DHCP.

#3 SerJ_G

SerJ_G

    stranger

  • Members
  • 2 posts

Posted 25 September 2005 - 05:00 PM

ok! I've such cable...
so my linux is - Mandriva Linux Limited Edition 2005...
what'll I do next? if I would like use CAT5 cable...

#4 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 25 September 2005 - 09:27 PM

If you need step-by-step instructions, I can post this later tonight. Essentually, you do ther following (this is from rote memory - I will check this later for accuracy);

1. Disconect the USB cable.

2. If you are on broadband, make sure that the modem is connected to cable.

3. Connect the CAT-5 cable from the ethernet card on the machine to an ampty ethernet port on the modem.

4. In Mandriva, go to start-->system-->configuration-->configure my computer. Pick Network connection/setup.

5. Follow the wizard. It should detect your ethernet card. Choose auto DHCP and follow the prompts. If you have dynamic DHCP from your provider, ignore DNS settings and such and just hit enter to toggle through the menu prompts. Tell Mandriva to connect on boot and complete the setup.

6. The network wizard should restart the network services and you can test the internet connection with Konqueror, or whatever browser that you are using.

7. If it does not work right away, re-boot and see if you get an internet connection.

If you have DSL, it gets a little more complicated. Let us know if you have DSL and need to login to your provider.

On newer systems, Mandriva may not detect your nForce card right off, but Mandriva is pretty good about this support.

Let us know if it works. If not, let us know what motherboard or system that you have, and if possible, what ethernet card is in the system. if in doubt, consult your users manual.

#5 _gnom

_gnom

    stranger

  • Members
  • 5 posts

Posted 23 November 2005 - 05:57 AM

i have the same situation but i use slackware 10.2
i've configured the network but i have DSL,
explane me plz how to log in to my ISP?????

THX!!!!!!!!!!!!

#6 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 23 November 2005 - 09:59 AM

I'll have to try this myself. I have Verizon. It depends on the distro, but you probably need to use the package Roaring Penguin.

This allows easy setup of dsl connections.

I'll look at it and let you know.

#7 _gnom

_gnom

    stranger

  • Members
  • 5 posts

Posted 23 November 2005 - 05:56 PM

ok, let me know!!

#8 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 24 November 2005 - 07:36 PM

OK, I have it up and running. I have not used Slack for a while and have a few problems. However, I am posting from Slackware using DSL right now. I'll keep you informed.

I had to set my DNS to static, but need to disable dhcp at start. Hmm...different from my other distros!

What DSL service are you using?

#9 _gnom

_gnom

    stranger

  • Members
  • 5 posts

Posted 25 November 2005 - 01:46 AM

in windows i have l2tp dialer from my provider, i don't really know if it's DSL or not, provider's support told that it's my problem that i have linux they can only tell me everything i need (IP, etc...)
i can use slack and mandriva 2006!!!
i want to check wich one is better for me...

#10 _gnom

_gnom

    stranger

  • Members
  • 5 posts

Posted 25 November 2005 - 02:31 AM

i can only say that i'm don't have static IP, it works with dhcp

#11 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 25 November 2005 - 08:19 PM

I can only tell you what I found with my provider. They use dynamic ip as well, but you need to know the primary and secondary DNS numbers to get pppoe (Roaring Penguin) to work.

Have them tell you everything and write them down.

I found in Slackware, I had previously set eth0 to dynamic and it did not like that setup. Once I disabled dynamic on eth0 and brought up Verizon with the DNS values added, it worked. If eth0 is up at boot, pppoe does not like it, rather you need to have eth0 brought up through pppoe.

My system is set up with the NIC card wired to the modem provided by Verizon. It works this way with two distros, Slackware and Puppy.

I'll look at Mandriva and let you know as well. I should have something posted this weekend.

#12 _gnom

_gnom

    stranger

  • Members
  • 5 posts

Posted 26 November 2005 - 05:06 AM

look, in win i have such situation in connection ditails:

device name: wan miniport (l2tp)
device type: vpn
server type: ppp
trasports: tcp/ip
authentification : pap
compression: none
ppp multilink framing: off

may be this can help to make some installation-specific settings in linux because i have no idea how to manage with this

i have olso found this http://l3ech.net/~l3....php?reverse=on
but its for debian
it's exectly my isp!!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq