Jump to content
Compatible Support Forums
Sign in to follow this  

boot failure after upgrading from RH9 to FC3

Recommended Posts

Hi after installing(upgrading) FC3 onto my existing RH9 system it now fails show the default grub boot menu ,instead it boots to the grub command shell. my system config is a follows


1x pII 550MHZ 512M RAM

1 x scsi disk drive (only used for linux)

1 x ide hard disk drive (secondary channel/slave)(not used)

1 x floppy drive

1 x ide cdrom

1 x scsi cdrom


note: the scsi disk drive is selected as the default boot device

from within the bios


under the grub device.map file the above devices are seen in the following order


(fd0) floppy

(hd0)Ide disk drive

(hd1) SCSI disk drive


the only way I am able to start linux is to type the following from the grub shell.




Grub>:kernel /vmlinuz-2.6.9-1.667 /root=/dev/sda5

Grub>:initrd /initrd-2.6.9-1.667.img




I have checked the device.map and menu.lst file and they seem to be ok



my partitions for the scsi drive is configured as follows

linux boot partion 500M /BOOT (Linux file system)

linux root partition 4G / (linux file system)

Linux swap partition 1G



Share this post

Link to post
Share on other sites

I don't know much about scsi drives, but can you post your menu.lst file?


It looks like the grub changes got written to the ide drive?

Share this post

Link to post
Share on other sites

thanks for your quick response,but I have resolved this problem by doing the following

disabled the IDE disk drive in the bios

rebooted using fedora cd in rescue mode

and ran the following commands

chroot /mnt/sysimage


grub>: root (hd0,0)

grub>: setup (hd0)


grub-install /dev/sda


but now I have another problem

the default cd audio device has changed in the following way

I have 2 cdrom devices installed

1 x scsi(scd0) cdwriter

1 x ide(hdc) cd/dvd player(connected to soundcard)


before the upgrade the ide cdrom was loaded via fstab as the default device,the scsi cdwriter device was not loaded by default.

now when you run any of the following cd audio programs they default to the scsi cdwriter

for the following apps


gnome audio players

kde audio players

i can resolve this by typing the following command

ln -sf hdc cdrom

but the application ripperX still fails to run with permission errors accessing "dev/cdrom"

this also occurs with the root account as well as default user accounts


the fstab is configured as follows


/dev/scd0 /media/cdrecorder pamconsole,ro,exec,noauto,managed 0 0

/dev/hdc /media/cdrom auto pamconsole,ro,exec,noauto,managed 0 0


any ideas ?



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this