Jump to content


Photo

How do I install Java


  • Please log in to reply
19 replies to this topic

#1 Justbill

Justbill

    member

  • Members
  • 171 posts

Posted 24 June 2005 - 03:54 AM

I would like to install Java on this box. I am currently running FC4. In the release notes they recomend to use jpackage, rather than sun. I tried to install (Sun's Java) prior to installing FC4 on this machine (I tried with CentOS 4.1), and was not successful!
I am at a complete loss on this one. If anyone can point me in the right direction, and also give me a clue as to what I'm looking at when I go to jpackage, I couldn't really tell one package from another on that site. I just want the Java package that I need to look at some web sites (games&such). Any Help would be greatly appreciated.

Thanks
Justbill

Compaq Presario SR1426NX
2.93GHz Pentium 4
512MB PC2-3200 DDR2 SDRAM
160GB 7200RPM Serial ATA hard drive

#2 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 24 June 2005 - 10:01 AM

How about this link.

You may also be interested in the main page offerings here.

#3 Justbill

Justbill

    member

  • Members
  • 171 posts

Posted 24 June 2005 - 02:02 PM

Hi danleff,
For starters, I really appreciate all the help you have been!

I downloaded: jre-1_5_0_04-linux-i586-rpm.bin

I changed permissions successfully, and installed.
when the process finished, it said done, and had me back at the root prompt. I re-started Mozilla, went to one of the pages that requires "Jave Runtime Environment" and it said I needed that plugin. This is the same problem I experienced last time (on CentOS). Am I missing something? do I need to configure Mozilla for this plugin? And if I do need to configure, how would I go about doing that?

Thanks
Justbill

#4 Jerry Atrik

Jerry Atrik

    addict

  • Members
  • 694 posts

Posted 24 June 2005 - 03:50 PM

pretty sure your missing the sym link.
read thru
http://java.com/en/d...0010500.xml#rpm

go down to the "enable and configure" it shows how and where to put that link.

#5 Justbill

Justbill

    member

  • Members
  • 171 posts

Posted 25 June 2005 - 12:02 AM

Hello All,

That is where my problem is! Here are the directions, and I will attempt to explain where I am having my problem:

Mozilla 1.4 and later

1. Go to the plugins sub-directory under the Mozilla installation directory
cd <Mozilla installation directory>/plugins
2. In the current directory, create a symbolic link to the JRE ns7/libjavaplugin_oji.so file Type:
ln -s <JRE installation directory>/plugin/i386/ns7/libjavaplugin_oji.so

Example:
* If Mozilla is installed in this directory:
/usr/lib/mozilla-1.4/
* and if the JRE is installed at this directory:
/usr/java/jre1.5.0
* Then type at the terminal to go to the browser plug-in directory:
cd /usr/lib/mozilla-1.4/plugins
* Enter the following command to create a symbolic link to the Java Plug-in for the Mozilla browser.
ln -s /usr/java/jre1.5.0/plugin/i386/ns7
/libjavaplugin_oji.so .
3. Start Mozilla browser or restart it if it is already running. Note that if you have other Mozilla components (ie: Messenger, Composer, etc) running, you will need to restart them as well.
4. Go to Edit > Preferences. Under Advanced category > Select Enable Java


I can't seem to find my Mozilla installation directory/plugins.
Here is what I did in the terminal:

[bill@68 ~]$ su
Password:
[root@68 bill]# whereis mozzila-1/plugins
plugins:
[root@68 bill]# cd /plugins
bash: cd: /plugins: No such file or directory
[root@68 bill]# cd mozzila-1/plugins
bash: cd: mozzila-1/plugins: No such file or directory
[root@68 bill]# cd /usr/lib/mozilla-1/plugins
bash: cd: /usr/lib/mozilla-1/plugins: No such file or directory
[root@68 bill]# cd /usr/lib/mozilla-1.4/plugins
bash: cd: /usr/lib/mozilla-1.4/plugins: No such file or directory
[root@68 bill]# cd /lib/mozilla-1/plugins
bash: cd: /lib/mozilla-1/plugins: No such file or directory
[root@68 bill]# cd plugins/mozilla-1.4
bash: cd: plugins/mozilla-1.4: No such file or directory
[root@68 bill]# exit

Every thing I knew to try came back "No such file or directory"
So, at this point I'm kind of stuck!
I am running FC4, so I am assuming that I have Mozilla-1.4 or later.

See what you think
Justbill


#6 egorgry

egorgry

    enthusiast

  • Members
  • 315 posts

Posted 25 June 2005 - 01:40 AM

should be in /usr/lib/mozilla/plugins

if not try whereis mozilla leaving of the crazy -1.4 stuff.
btw I'm on a Ubuntu and debian systems so it may be slightly different.

#7 Justbill

Justbill

    member

  • Members
  • 171 posts

Posted 25 June 2005 - 01:46 AM

OK, I followed the directions on the page and this is what I've ende up with, and java still doesn't seem to be working. Here is what I have when I cd into /usr/lib/mozilla/plugins and type ls :

[bill@68 ~]$ su
Password:
[root@68 bill]# cd /usr/lib/mozilla/plugins
[root@68 plugins]# ls
libjavaplugin_oji.so mozplugger.so nphelix.so nphelix.xpt ns7
[root@68 plugins]# ls -l
total 92
lrwxrwxrwx 1 root root 55 Jun 24 17:33 libjavaplugin_oji.so -> /usr/java/jre1.5.0/plugin/i386/ns7/libjavaplugin_oji.so
-rwxr-xr-x 1 root root 22744 Apr 4 14:43 mozplugger.so
-rwxr-xr-x 1 root root 40608 May 3 16:04 nphelix.so
-rwxr-xr-x 1 root root 5086 May 3 16:04 nphelix.xpt
lrwxrwxrwx 1 root root 34 Jun 24 17:29 ns7 -> /usr/java/jre1.5.0/plugin/i386/ns7
[root@68 plugins]#

So does anybody have an idea why my java doesn't seem to be working? I also need to mention that in the shell, when I ls, anything that has to do with the java plugin, is highlighted in red.
I wonder, the file I downloaded and installed said "i586" in it, and in the /usr/lib/mozilla/plugins it says "i386" . Would that make a difference?

Any Thoughts?
Thanks
Justbill


#8 Jerry Atrik

Jerry Atrik

    addict

  • Members
  • 694 posts

Posted 25 June 2005 - 01:58 AM

did u cut and paste the commands?

i did that first and realized that the folder name is different. i had to delete the symlink and type it in using the correct folder name i believe it's 1.5."something" instead of just 1.5.0

#9 Justbill

Justbill

    member

  • Members
  • 171 posts

Posted 25 June 2005 - 02:45 AM

No, I typed everything according to what I downloaded (filenames). I reinstalled everything, and still have the same results as above. i cd'd into /usr/lib/mozilla/plugins the file is there, but it is highlighted in red again, here it is:

[bill@68 ~]$ su
Password:
[root@68 bill]# cd /usr/lib/mozilla/plugins
[root@68 plugins]# ls
libjavaplugin_oji.so mozplugger.so nphelix.so nphelix.xpt
[root@68 plugins]#


libjavaplugin_oji.so is highlighted in red

I really don't know what to do at this point

Justbill

#10 egorgry

egorgry

    enthusiast

  • Members
  • 315 posts

Posted 25 June 2005 - 06:44 AM

The red means you're linking to nothing, it's adead link. How are you issueing the ln -s command?

working directory shoud be /usr/lib/mozilla/plugins
command should be something like this
ln -s /full/path/to/java/lib.so nameoflink.so
ls -l and the linky should be light blue... I think?? wink
I'm on OSX right now so I can't verify and I forget

good luck.

#11 Justbill

Justbill

    member

  • Members
  • 171 posts

Posted 25 June 2005 - 03:39 PM

Well, this is what Iv'e been entering for the "create a symbolic link"command:

cd /usr/lib/mozilla/plugins

then

ln -s /usr/local/jre1.5.0/i386/ns7/libjavaplugin_oji.so

I also tried

ln -s usr/local/jre1_5_0_04-linux-i586.rpm/plugin/ns7/libjavapluginoji.so

and here are the results of these attempts:

[bill@68 ~]$ su
Password:
[root@68 bill]# cd /usr/local
[root@68 local]# ls
bin games jre-1_5_0_04-linux-i586.rpm lib man share
etc include jre-1_5_0_04-linux-i586-rpm.bin libexec sbin src
[root@68 local]# cd /usr/lib/mozilla/plugins
[root@68 plugins]# ls
mozplugger.so nphelix.so nphelix.xpt
[root@68 plugins]# ln -s /usr/local/jre1.5.0/i386/ns7/libjavaplugin_oji.so
[root@68 plugins]# ls
libjavaplugin_oji.so mozplugger.so nphelix.so nphelix.xpt
[root@68 plugins]# rm libjavaplugin_oji.so
rm: remove symbolic link `libjavaplugin_oji.so'? yes
[root@68 plugins]# ln -s /usr/local/jre-1_5_0_04-linux-i586.rpm/plugin/ns7/libjavaplugin_oji.so
[root@68 plugins]# ls
libjavaplugin_oji.so mozplugger.so nphelix.so nphelix.xpt
[root@68 plugins]# exit
exit

again, "libjavaplugin_oji.so" is highlighted in red in the
[root@68 plugins].

Justbill

#12 egorgry

egorgry

    enthusiast

  • Members
  • 315 posts

Posted 25 June 2005 - 03:54 PM

loks like you're not putting in the space between location and target.

ln -s /location/of/lib <space> linkyouwant

so if I have a file in /home/greg/music called descendents.mp3 and I want it linked to /home/music/share I would cd to ../../share and type

ln -s /home/greg/music/descendents.mp3 decendents_link.mp3
^
space

#13 Justbill

Justbill

    member

  • Members
  • 171 posts

Posted 25 June 2005 - 07:11 PM

OK, this is about to make me NUTS!

This is the command that they are calling for:

ln -s /usr/java/jre1.5.0/plugin/i386/ns7
/libjavaplugin_oji.so .

I have "jre1_5_0_04-linux-i586.rpm" installed in /usr/local/ .
so I replace /usr/java/jre1.5.0/ with "/usr/local/jre1_5_0_04-linux-i586.rpm" is this correct?

Should I consider removing everything associated with java, and start from scratch? sometimes I get an error "file already exists", I believe that is because it made a directory at /usr/java/ jre1.5.0_4. If I have to remove this directory, how do I do that (I tried "rm jre1.5.0_04" and it would'nt let me.

WHAT NEXT!

Considering large quantities of alcohol
Justbill

#14 egorgry

egorgry

    enthusiast

  • Members
  • 315 posts

Posted 25 June 2005 - 07:32 PM

first off, I've never used the link command in that way, I'm not even sure what it's doing? if you need to remove a directory and all it's contents you will need to use rm -rf (recursive,force)but I think if you create the link in the manner I described it should be fine. I don't remember java giving me that much trouble on debian. I just installed teh java pkg and made teh symlink. Then I went to firefox about:plugins and booya.

As far as I know your pkg should not have the .rpm at the end, I think, for teh record I hate RPM distros and I don't use one so I'm not really sure if that's a correct statement. You may need to run rpm -i nameofpkg to install it. I'm a little confused myself about what is going on. any rpm guys want in on this? My solution is ubuntu. wink let me know what happens next.
[Edited by egorgry on 2005-06-25 13:36:03]


#15 Justbill

Justbill

    member

  • Members
  • 171 posts

Posted 26 June 2005 - 02:25 AM

welllll, this time,

I re-downloaded jre-1_5_0_04-linux-i586-rpm.bin
I mv jre-1_5_0_04-linux-i586-rpm.bin /usr/java/jre1.5.0_04
then I typed ./jre-1_5_0_04-linux-i586-rpm.bin (this is in light green font)
now I have jre-1_5_0_04-linux-i586.rpm (this is in red font)
I then cd /usr/lib/mozilla/plugins
I then typed
ln -s /usr/java/jre1.5.0_04/jre-1_5_0_04-linux-i586.rpm jre-1_5_0_04-linux-i586.rpm

I did not get any kind of error, so I cd'd to
cd /usr/lib/mozilla/plugins
I then typed ls
my symbolic link seems to be there, it says "jre-1_5_0_04-linux-i586.rpm" and it is in a light blue font.

However, whenever i go to a page that requires "jave runtime environment" they tell me I need the plugins. I do have java enabled, and java script enabled in Mozilla.

I think I'm going to change my Nickname here to I.M.Clueless

at a loss
Justbill



#16 egorgry

egorgry

    enthusiast

  • Members
  • 315 posts

Posted 26 June 2005 - 05:44 AM

Okay the link is good. I can't speak for the install but it sounds fine. I really don't like rpm's I'm not sure why your not getting java. What browser are you using? if a mozilla based browser go to aboout:plugins in the address bar and see if the java plugin is active.

#17 lynn_dylan

lynn_dylan

    stranger

  • Members
  • 2 posts

Posted 26 June 2005 - 10:28 AM

It seems that I'm having the same problem. I've been through almost the same steps as Justbill (I didn't download jre-1_5_0_04-linux-i586-rpm.bin, rather jre-1_5_0_04-linux-i586.bin without the "rpm"), my symbolic link is highlighted in blue, but when I go to "about: plugins" in Firefox, all it says is:

Default Plugin

File name: libnullplugin.so
The default plugin handles plugin data for mimetypes and extensions that are not specified and facilitates downloading of new plugins.

MIME Type Description Suffixes Enabled
* All types .* No


I am using Firefox version 1.0.4 on FC4. If someone can help, I will be grateful. I'm new to linux, so don't be afraid to speak as if I were a child.

Thank you for everything so far,
Lynn

#18 egorgry

egorgry

    enthusiast

  • Members
  • 315 posts

Posted 26 June 2005 - 02:57 PM

Don't know if this is your problem but it reminds me of why I dislike redhat. Redhat changes linux standards, pkg names, and library locations. http://fedora.redhat.../fc4/#id2503931

Fedora Core 4 users are advised not to use the Java RPM provided by Sun. It contains Provides that conflict with names used in packages provided as part of Fedora Core 4. Because of this, Sun Java might disappear from an installed system during package upgrade operations.



#19 Justbill

Justbill

    member

  • Members
  • 171 posts

Posted 26 June 2005 - 03:49 PM

Lynn,

First off, I want to thank egorgry for all his help with this, wow, did I learn some stuff from him!

I stumbled on some directions at:

http://forums.fedora...url]http://www. .com" title="httpwww relnofollow targetblankhttpforumsfedoraforumorgshowthreadphpt59385urlhttpwww com" rel="nofollow" target="_blank">http://www" rel="nofollow" target="...//www. .com

A few things that I did before I started,
1) removed files and symbolic links from previous attempts using the rm command.
2) removed directory jre1.5.0_04 (I had mine in /usr/local/ ,yours may be at /usr/java/ ) using the rm -rf command (thanks again egorgry!)
3) any where the directions say jre-1_5_0_03, replace that 3 with a 4.
4) in step 6, in the middle of that command line it does say i386, which confused me a little, but i typed it in anyway, and it worked.

Be sure to use the bin. download, and NOT the rpm!

in step 6 of the directions, be sure to put a space between
/ns7/libjavaplugin_oji.so <space> /usr/lib/mozilla/plugins/libjavaplugin_oji>so

This worked great for me, I hope it works for you!

Justbill



#20 lynn_dylan

lynn_dylan

    stranger

  • Members
  • 2 posts

Posted 27 June 2005 - 10:02 PM

Thanks man I got it.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq