Jump to content


Photo

Help! CHKDSK runs on every boot and hangs on 0 percent during stage 4


  • Please log in to reply
1 reply to this topic

#1 pwpatton

pwpatton

    stranger

  • Members
  • 2 posts

Posted 12 June 2005 - 01:35 AM

I rebooted my machine today and chkdsk started to run against my D: drive (which is set up as a slave on the primary IDE channel). I'm not sure why it did that as I never requested it.

I have a 80 GB hard drive as my C drive and a 200 GB drive as my D drive.

CHKDSK has been sitting at 0 percent on stage 4 of 5 for over an hour. Stages 1 - 3 ran through just fine.

I shut the machine down, removed my 200 gb drive from the machine, and everything booted just fine. Is there a way to skip the chkdsk of the D: drive? Or some other way of fixing this? I have a lot of data on my D drive so I would like to not lose it.


#2 pwpatton

pwpatton

    stranger

  • Members
  • 2 posts

Posted 12 June 2005 - 03:25 AM

http://support.micro...kb;en-us;160963

Ok, I'll answer my own question. I used this article to help me figure out how to skip the chkdsk on reboot. What causes the chkdsk to run at boot time is a setting in the registry that causes program called autochk to run. That setting gets there if the disk was brought down inappropriately. So, change the registry setting and then it will reboot without running chkdsk.

This article discusses a program called chkntfs that will allow you to change the registry setting. But part of my problem was that chkntfs won't modify the registry setting if the drive isn't available. And ofcourse it wasn't since I couldn't boot my machine with that drive hooked up. So I unhooked that drive, booted the machine, and modified the registry setting by hand.

I just set it to "autocheck autochk *" (w/o quotes). Ofcourse you must be careful if you set anything in the registry by hand. This article also makes note of that.








0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq