Jump to content


Photo

Realtek High Definition Audio compatibility (please help!)


  • Please log in to reply
2 replies to this topic

#1 Koba

Koba

    newbie

  • Members
  • 45 posts

Posted 21 April 2005 - 12:46 PM

Hi,

Could someone please please help me try and get audio working on Ubuntu (or any linux distro for that matter)? I have tried and tried to no avail and I would be really grateful if someone could help me out.

I have an onboard soundcard - a Realtek ALC 880 and I have found some drivers for it here:

http://www.realtek.c.....0Audio CODECs

I have followed the instructions as best I could. First I installed the kernel sources for my system and then followed the instructions to the letter:

***

The source code copy from www.alsa-project.org. ver:R3.1

Linux Source Code for ALC audio codec



Installation:

This Source Code is from www.alsa-project.org.

For driver installation, please follow below steps.



Step 1. unzip source code

tar xfvj azx-021705.tar.bz2



Step 2. Turn on sound support (soundcore module, default turn on)



Step 3. Complied source code

a. ./configure

b. make

c. make install

d. ./snddevices



Step 4. Edit your /etc/modules.conf or conf.modules depending on the distribution

(Please refer to the attached modules.conf)



Step 5. reboot your machine



Note: 1. The most detail information, can refer the alsa-kernel/Documenttation/ALSA-Configuration.txt in the azx-021705.tar.bz2.

2. Kernel Version must be 2.2.14 or later.

3. All mixer channels are muted by default. You must use a native

or OSS mixer program to unmute appropriate channels.

4. If can not compile the source code, try to rename the /usr/src/linux-2.x -> /usr/src/linux.

5. The driver added to support the SPDIF functoin.

6. Suggest use alsamixer to control mixer function. you can find it in the alsa-utils-0.9.4 (www.alsa-project.org).
7. a. You can download the alsa-lib-1.0.8 and alsa-utils-1.0.8 form the www.alsa-project.org, then unzip and install them.

b. Used "alsaconf" can autodetect which drive you need to install (step 4).

***

When I do ./configure I get this:

checking for directory with kernel source... /usr/src/linux
checking for kernel version... The file /usr/src/linux/include/linux/version.h does not exist.
Please, install the package with full kernel sources for your distribution
or use --with-kernel=dir option to specify another directory with kernel
sources (default is /usr/src/linux).

There is no /include/linux/version.h! What should I do?

Thank you,

Koba

#2 pretorian86

pretorian86

    stranger

  • Members
  • 1 posts

Posted 09 December 2005 - 07:22 AM

I have the same problem, dont know how to fix it! frown

#3 actarusnl

actarusnl

    stranger

  • Members
  • 2 posts

Posted 19 December 2005 - 03:04 PM

Originally posted by Koba:
Quote:

There is no /include/linux/version.h!



Have you installed the kernel headers andsource code ?
make sure they are present in usually /usr/src/.

i have problems with this card too tho, even i can compile everything fine. i now use Simply Mepis 3.3
i had it working with Fedora core 4 FYI.
regs,





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq