Jump to content


Photo

Computer EXTREMELY slow, but shouldn't be. HELP!


  • Please log in to reply
18 replies to this topic

#1 OldSpiceAP

OldSpiceAP

    member

  • Members
  • 134 posts

Posted 18 April 2005 - 11:27 PM

Sorry about the duplicate untitled post, I'm not sure where my mind was.


Hey all, I'm having some annoying problems with my work machine.

Specs:
NEC Powermate 2000
PIII 600
128 MB Ram
18 GB HD

The machine is an all in one machine with a flat panel monitor built into it. The monitor base houses all components.

Problem:

This machine is slow!
Very very very slow!

I'm currently running Ubuntu Warty Warthog, but I previously ran SuSE 8.2 and Yoper 2.1 on it with the same issues. It used to have windows 98 on it but I formatted it off.

The problem did not occur in windows but all linux distros run extremely slowly.
GNOME is unbearably slow.
WindowMaker even is slow - 2-4 seconds just to open the Applications menu by right clicking on the desktop. Up to a minute to switch between Firefox and Openoffice, which is extruciating.

What could the problem be? I enabled Unix large disk access mode in the bios but it didn't help, neither did enableing and disabling DMA. There is a 800 MB swap partition also...

Anyone know why this machine is so slow?

#2 matttah

matttah

    member

  • Members
  • 175 posts

Posted 20 April 2005 - 07:49 PM

What do you mean by slow? As in it loads slow? Graphics are slow? If your graphics are slow you might have your x config'd wrong...if it is running very slow try running in a non graphical mode(you can kill x by hitting ctrl alt backspace). See if it runs slow there too. If it does most likely the way you are installing is correct. I am not too familiar with the distros you listed but any distro should be able to run pretty well at the command line in a non graphical mode.
Daum

#3 OldSpiceAP

OldSpiceAP

    member

  • Members
  • 134 posts

Posted 20 April 2005 - 08:54 PM

Everything is slow. Typing, everything. But only when I'm in a windowed environment. Everything works fast in command line only though. Still, I run Ubuntu on a much lesser system at home, and it works quite fast. Here, clicking on the Applications menu can take up to a minute for disk activity to cease and then the menu finally pops up, then it works fast until I open a program from one of the submenus. These can take up to 10 minutes to load, especially firefox and openoffice. But even nautilus takes 30 seconds or so. The performance is equally bad in minimalist window managers, WindowMaker, Blackbox, etc. Moving windows is smooth, once I can grab them (takes a sec but then they move fine). It just seems like everything is proceeded by a long delay full of hard drive activity.

#4 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 20 April 2005 - 10:50 PM

Two issues right off the top. An increase in ram would be useful, as 128 mb is bare minimum to run thse distros. 256 would be much better.

Secondly, is the swap space being utilized at all? Is it in your fstab file?

Finally, in the bios, is PNP OS disabled or off in the bios (PNP configuration)?

#5 martouf

martouf

    enthusiast

  • Members
  • 338 posts

Posted 20 April 2005 - 10:55 PM

when it's being slow, can you open a terminal and type
[size:4][tt]cat /proc/interrupts[/tt][/color]
then count off three seconds and type
[size:4][tt]cat /proc/interrupts[/tt][/color]
once more, then post the output here?


#6 OldSpiceAP

OldSpiceAP

    member

  • Members
  • 134 posts

Posted 21 April 2005 - 12:12 AM

brant@Ubuntu:~ $ cat /proc/interrupts
CPU0
0: 705817760 XT-PIC timer
1: 167400 XT-PIC i8042
2: 0 XT-PIC cascade
5: 18583317 XT-PIC uhci_hcd, Intel 82801AA-ICH, yenta, ndiswrapper 7: 16764342 XT-PIC parport0
8: 1 XT-PIC rtc
10: 11701 XT-PIC yenta, eth0
12: 2882571 XT-PIC i8042
14: 1676441 XT-PIC ide0
15: 4353844 XT-PIC ide1
NMI: 0
Fstab shows a swap partition, and it looks normal

I run the exact same distro on a Compaq Armada Laptop
PII 266
64 MB Ram
8 GB HD
and it works much better than on this machine.

and here is the stuff you asked for martouf


LOC: 698818929
ERR: 0
MIS: 0
brant@Ubuntu:~ $ cat /proc/interrupts
CPU0
0: 705822926 XT-PIC timer
1: 167409 XT-PIC i8042
2: 0 XT-PIC cascade
5: 18583395 XT-PIC uhci_hcd, Intel 82801AA-ICH, yenta, ndiswrapper 7: 16764342 XT-PIC parport0
8: 1 XT-PIC rtc
10: 11701 XT-PIC yenta, eth0
12: 2882571 XT-PIC i8042
14: 1676908 XT-PIC ide0
15: 4353898 XT-PIC ide1
NMI: 0
LOC: 698824044
ERR: 0
MIS: 0
brant@Ubuntu:~ $


#7 martouf

martouf

    enthusiast

  • Members
  • 338 posts

Posted 21 April 2005 - 04:18 AM

hmm..

[size:4][tt]$ dc
705822926 705817760 - p
5166[/tt][/color] timer interrupts processed.

Not that many other interrupts between the two interrupt count samples.
Guess this machine is networked via ndiswrapper, because eth0 didn't have any interrupts.

what version of ndiswrapper are you using?

where is the display driver? it should be shown hooked into one of the interrupt lines.

thought you said the machine runs slowly when X is running and not
so badly otherwise...

would you provide the output of [size:4][tt]free[/tt][/color] ?
we'll be able to see how the system memory (RAM + swap) is configured.

#8 OldSpiceAP

OldSpiceAP

    member

  • Members
  • 134 posts

Posted 21 April 2005 - 02:23 PM

Yep, both my older laptop and this machine are using a WPC54G wireless card with ndiswrapper. I'm sure its a recent version as Ubuntu comes with in in the kernel of as a kernel module.

Not sure why there isn't a display driver listed, I was running Open Office and Firefox at the time in X so ....

What do you mean the output of free - is it a command I'm not familiar with? smile

#9 martouf

martouf

    enthusiast

  • Members
  • 338 posts

Posted 21 April 2005 - 03:05 PM

you ought to find the ndiswrapper version information
in the output of [size:4][tt]dmesg[/tt][/color].

try: [size:4][tt]dmesg | grep ndis[/tt][/color]

for memory config, there's [size:4][tt]free[/tt][/color] and [size:4][tt]procinfo[/tt][/color].
procinfo gives a nicely concise memory and interrupt report.
free gives just the memory report.

( raw data may be obtained using:
[size:4][tt]cat /proc/interrupts
cat /proc/meminfo[/tt][/color] )


#10 martouf

martouf

    enthusiast

  • Members
  • 338 posts

Posted 21 April 2005 - 03:08 PM

oh, about the lack of display driver hooked to an interrupt:
it means you're not using an accelerated driver.

#11 OldSpiceAP

OldSpiceAP

    member

  • Members
  • 134 posts

Posted 21 April 2005 - 03:34 PM

dmesg | grep ndis
completes with no output.

I should't be using an accelerated driver as this card doesn't support it.

Output of free is:

total used free shared buffers cached
Mem: 126184 122256 3928 0 672 33276
-/+ buffers/cache: 88308 37876
Swap: 437432 121408 316024

cat /proc/meminfo gives me

MemTotal: 126184 kB
MemFree: 3340 kB
Buffers: 544 kB
Cached: 33772 kB
SwapCached: 27988 kB
Active: 82864 kB
Inactive: 3640 kB
HighTotal: 0 kB
HighFree: 0 kB
LowTotal: 126184 kB
LowFree: 3340 kB
SwapTotal: 437432 kB
SwapFree: 315892 kB
Dirty: 0 kB
Writeback: 0 kB
Mapped: 81388 kB
Slab: 21476 kB
Committed_AS: 412812 kB
PageTables: 1468 kB
VmallocTotal: 909232 kB
VmallocUsed: 3584 kB
VmallocChunk: 905476 kB


Swap seems smaller than I thought but still should be fine I'd think



#12 martouf

martouf

    enthusiast

  • Members
  • 338 posts

Posted 21 April 2005 - 09:16 PM

huh.. really? here's what I've got on my test system:

[size:4][tt]$ dmesg | grep ndis
ndiswrapper version 0.6+CVS loaded[/tt][/color]

(second command run as root, many distros don't allow regular
users to read /var/log/messages)

[size:4][tt]# grep ndis /var/log/messages
Apr 21 14:58:33 testsys kernel: ndiswrapper version 0.6+CVS loaded[/tt][/color]

Ok, no accelerated display driver. confirmed. good - it had the
potential to be the source of the problem. unlikely, but potential.

the swap config looks OK. Nothing looks bad there.

the one big difference between your system and mine is the really
large number of LOC interrupts. Mine is 0. Even after millions
and millions of timer interrupts. it's the local interrupt counter
in the APIC. your APIC must be on.

hmmm..

have you (or would you) try booting with "noapic" ?
booting with both "noapic" and "nolapic" ?



#13 blackpage

blackpage

    member

  • Members
  • 120 posts

Posted 22 April 2005 - 02:25 PM

gidday ppl

I would almost place a bet on martouf's last two lines. booting into "noapic"-mode could indeed solve the slow response times (I dimly remember this issue from my Mandrake times).

good luck, and if it helps, buy martouf a beer smile

#14 OldSpiceAP

OldSpiceAP

    member

  • Members
  • 134 posts

Posted 22 April 2005 - 04:04 PM

I booted with noapic and no|apic

did I do something wrong here?

brant@Ubuntu:~ $ cat /proc/interrupts
CPU0
0: 199274 XT-PIC timer
1: 49 XT-PIC i8042
2: 0 XT-PIC cascade
5: 10269 XT-PIC uhci_hcd, Intel 82801AA-ICH, yenta, ndiswrapper 7: 0 XT-PIC parport0
8: 1 XT-PIC rtc
10: 11 XT-PIC yenta, eth0
12: 903 XT-PIC i8042
14: 7384 XT-PIC ide0
15: 719 XT-PIC ide1
NMI: 0
LOC: 199210
ERR: 0
MIS: 0

I went to the grub menu, hit e to edit the boot option

after kernel blahblah.386 ro splash

I added noapic and no|apic

then hit b to boot

Did I mess up or do it wrong?


#15 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 22 April 2005 - 10:28 PM

Try noapic first only. Then if that does not work nolapic only.

That is nolapic...the letter l with no spaces.

#16 OldSpiceAP

OldSpiceAP

    member

  • Members
  • 134 posts

Posted 25 April 2005 - 11:47 PM

the letter I as in EYE?

or the char | obtained by pressing the Shift + \ key?



#17 martouf

martouf

    enthusiast

  • Members
  • 338 posts

Posted 26 April 2005 - 03:57 AM

the letter you need to use (in ITU phonetics) is "Lima"

Alpha == A
Bravo == B
Charlie == C
Delta == D
Echo == E
.
.
and so on..
.
.
Lima == L

nolapic ::= Nancy Oscar Lima Alpha Papa India Charlie

ok? smile

#18 OldSpiceAP

OldSpiceAP

    member

  • Members
  • 134 posts

Posted 27 April 2005 - 04:32 PM

Hehe ok, thanks

I feel reaaaalllly smart now. smile

#19 OldSpiceAP

OldSpiceAP

    member

  • Members
  • 134 posts

Posted 03 May 2005 - 06:50 PM

Update! It worked! Thanks so much!

I owe martouf a beer for sure!

Visit Kansas sometime and feel free to take me up on it!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq