Jump to content
Compatible Support Forums
Sign in to follow this  
Perivale

Can't connect to Linux Share on XP PC

Recommended Posts

Hi,

 

I am trying to add a Linux (SUSE 9.2) PC (Host name Green) to a TCP/IP network using SAMBA. I have configured Samba to join the workgroup Spectrum which is the workgroup containing my XP PC (Host name Blue).

 

On the XP machine under network tasks>>View workgroup computers I see computers “Blue” and “Samber Server (Green)”. Double clicking the “Blue” icon I get the drives and printers on the XP PC but when I double click on the “Samber Server (Green)” icon I get, after a delay, the following error message:

 

\\Green is not accessible. You might not have permission to use this network resource. Contact the administrator of the server to find out if you have access permissions.

 

The network path was not found.

 

The network card in the Linux PC has an IP of 192.168.0.5

My router (Netgear DG834G with latest firmware) acts as a DHCP for the XP PC allocating it 192.168.0.2 I can ping each PC from the other.

 

I am using a “limited” account (Anybody) on the XP PC with a password. On the Linux PC I have created a user account of the same name (Anybody) and generated a SMB password using:

 

smbpasswd –a Anybody

 

On the Linux PC the smb.conf is as follows:

 

[global]

workgroup = Spectrum

server string = Samba Server

encrypt passwords = yes

smb passwd file = /etc/samba/smbpasswd

wins support = yes

[test]

comment = For testing only, please

path = /usr/local/samba/tmp

read only = no

guest ok = yes

 

(From a worked example in a book “Using Samba” I found in a SUSE document package)

 

running testparm reveals no errors in smb.conf although it ignores the 3rd and 4th lines in [global] I assume because they are defaults.

 

I run samba as a superuser as follows:

 

/etc/rc.d/smb start

/etc/rc.d/nmb start

 

(both respond with ‘done’)

 

The log files log.smbd and log.nmbd contain no error reports.

 

I expect to see a network folder “test” under computer Samba Server (Green) under workgroup Spectrum.

 

Any ideas?

 

Share this post


Link to post
Share on other sites

Hu, I see. I'm guessing you are trying to use samba to access a windows 2003 server, right? If this correct, then this requires a different deal or way to access your shares through Samba for win2003/XP.

 

I found these links helpful. I think you can pull out some info:

http://www.linuxforum.com/forums/index.p...mp;#entry534086

Also check out this

http://asia.cnet.com/enterprise/netadmin/0,39035505,39081966-39000223c-1,00.htm

and finally

http://mandrake.vmlinuz.ca/bin/view/Main/SambaDomainMember

 

I hope that helps a little. Let us know how it went.

Share this post


Link to post
Share on other sites

Thanks for the reply,

 

My set up contains no dedicated server. There is one PC running XP Profesional +SP2 OS conected via wired ethernet to a router acting as a hub and a DHCP and a PC running Linux also conected via wired ethernet to the same router. I have successfully added other Windows PCs to the network by plugging them into the router plus appropriate setup.

Share this post


Link to post
Share on other sites

I don't run SUSE but if your version of samba is relatively current (I assume it is) you may want to look at the following:

 

I see a couple of possible problems in your smb.conf file. You fail to set a netbios name. (You are running NETBIOS or CIFS and XP wants your machine named). Also, in your [test] specification you are pointing to an area which does not normally have access permissions for a casual user. You may want to modify [test] so that you bypass this (temporarily) by saying admin users Anybody.

Also, in general, you must have a Linux user Anybody as well as a smb user Anybody. This is not true for all releases, but keep it in mind.

 

Here is a copy of my smb.conf file, modified for your network and testing. I run this with XP SP2 and Samba on FC3.

 

[global]

workgroup = SPECTRUM

netbios name = GREEN

server string = Green - Samba Server

printcap name = /etc/printcap

load printers = yes

printing = lprng

socket options = TCP_NODELAY

dns proxy = no

browseable = yes

 

[test]

comment = Green - Samba test area

path = /usr/local/samba/tmp

browseable = yes

writeable = yes

printable = no

admin users = Anybody

create mask = 0777

 

Hope this helps.

 

Bill

Share this post


Link to post
Share on other sites

Thanks for your suggestions Bill

 

- I must declare a typo in my dialog my samba and windows user name is Anyone not Anybody.

With this realised I implemented your code (cut and paste!) and also created a Linux user Anyone.

 

Running testparm I got

 

# Global parameters

[global]

workgroup = SPECTRUM

server string = Green - Samba Server

printcap name = /etc/printcap

dns proxy = No

printing = lprng

print command = lpr -r -P'%p' %s

lpq command = lpq -P'%p'

lprm command = lprm -P'%p' %j

lppause command = lpc hold '%p' %j

lpresume command = lpc release '%p' %j

queuepause command = lpc stop '%p'

queueresume command = lpc start '%p'

 

[test]

comment = Green - Samba test area

path = /usr/local/samba/tmp

admin users = Anyone

read only = No

create mask = 0777

 

which I presume is ok.

 

So I have in summary a Windows user, a Linux user and a samba user all called Anyone and all with exactly the same password.

 

My session was as follows:

 

Logged into Linux on Linux Box (Green)

user Anyone

Password XXXXX

 

Logged into windows on XP Box (Blue)

User Anyone

Password XXXXX

 

On XP Box went to Start>My Network Places>View workgroup computers this put me into the Spectrum workgroup which had two computer icons:

Blue

Green – Samba Server (Green)

 

Double clicking on Green gave after a delay the \\ Green not accessible…… error as detailed in my first posting.

 

On the Linux Box I found a Network Browsing icon on the desktop which put me through to a services folder containing two items

 

“All SLP Services” and “Windows Network”.

 

I clicked on “Windows Network” which put me through to

 

smb:/

 

an empty folder

after a short period the message

 

“Error while connecting to server responsible for smb:/”

 

appeared.

 

Note: regarding the comment about netbios I set up the Host name and Domain name/DNS in SUSE Yast. My Linux Box host/domain name is set as Green.Home with the DNS set to Home.

The XP Box has the Host/Domain name blue.Home.

 

Any suggestions for a way forward?

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×