Jump to content


Photo

Linux won't install (Both SuSE and Mandrake)


  • Please log in to reply
5 replies to this topic

#1 good_ol_dv

good_ol_dv

    stranger

  • Members
  • 2 posts

Posted 01 April 2005 - 03:58 AM

I've run into problems installing linux.
I first tried Mandrake 10.1 but right after the first screen when you push enter to install it locks up with a blue bar at the top and bottom. The bottom says something like <Alt+F1 for here> and a few other options. Hitting any key combo it has on the bottom does nothing.
I then tried SuSe 9.2 this also locks up. This locks up when it says initializing hardware.
I have disabled alot of things on the motherboard and disconnected alot of extra cards. Tried to isolate exactly what piece of hardware was making it freeze. Nothing worked.
Any ideas?

My system specs:
MSI 865PE Neo2-FIS2R Motherboard
Intel Pentium 4 2.8C
2-512MB Corsair XMS DDR400 memory (1 GB)
ATI Radeon 9000 series (64MB DDR)

The motherboard has a SATA/RAID controller. Also has one additional IDE onboard (think it's a Promise controller)

#2 LinuxCrusader

LinuxCrusader

    member

  • Members
  • 165 posts

Posted 01 April 2005 - 09:16 AM

Have you tried booting up your computer with linux liveCDs. I know Mandrake is a really good distro out there, but if I were you I would try booting up your PC with a liveCD out there and see if it works with your computer...if everything went well and you are able to play with it, with the sound, videos, etc., then this means that proably all your hardware was recognized, and you can also install it to your HD if you desired.

Visit http://distrowatch.com/ and I would recommend you play with Mepis, knoppix, BeatrIX, morphix, etc...al the ones that are liveCds. Good thing about liveCDs is that they come in only one CD.

I'm not trying to evade you from Mandrake since Mandrake is one of my favorites distros nad it is well solid distro also, but my hunch is tellimg me that most likely your video card may have not been recognized. I could be wrong, but hopefully someone else will have a solution to your problem described above. Let us know if you were able to solve it or you are stil having problems.

Good luck.

#3 iamroot

iamroot

    addict

  • Members
  • 501 posts

Posted 02 April 2005 - 10:56 AM

The video card is my hunch as well. Tried any other OSes on that system?

#4 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 02 April 2005 - 05:23 PM

The two installs points (hopefully) to a couple of issues.

One likes the video card (Suse) and one does not (Mandrake). The latter is giving you video issues.

Installation problems are often due to burning the cd disks incorrectly. The installation hangs at some point durng the install. Make sure that you are burning the iso images correctly (if you burned your own). Se my quick quide here.

I am just playing with my sata based motherboard (Asus) and Mandrake 10.2 (RC2) is giving it fits. The install failed multiple times, either to the sata drive or ide drive in the system. One most install attempts, the sata drive was found, on others, it was ignored.

The point is that this may be the apparent hardware issue. If possible make sure that there are no USB devices plugged into the board, say like a USB pen drive or multicard reader.

I plug in a pen drive (with sata enabled) and Mandrake goes nuts. On reboot, mandrake hangs and the bios does not recognize the sata drive on reboot detection.

Get into the bios and look under PnP configuration and choose no PnP as an option - disable PnP bios.

Do you have a sata drive in the system? If not also disable the sata setting in the bios for active raid. If you are installing (or attempting to) to a sata drive, let us know.

I would also be interested if Knoppix, Mepis or one of the cd based distros work on your system. this will tell us something as well.

Linux questions.org states that the motherboard should be fine and other references that i found state that the ATI card should work, as well. However, ATI crads, especially the newer ones, are problematic for Linux in general.

#5 good_ol_dv

good_ol_dv

    stranger

  • Members
  • 2 posts

Posted 04 April 2005 - 11:13 AM

Tried Mepis
Started giving a whole bunch of messages though:
Disabling IRQ #10
irq 10: nobody cared!
So i checked the system information screen that's on very briefly after the bios and all the integrated components were set to that (IDE, S-ATA, Firewire, USB)
So I started to check around in those settings, on the IDE I changed it from Native mode to Legacy Mode.
Just changing that got rid of all the irq 10 errors and I was able to get into Mepis.
Tried Mandrake install again but still ran into the same problems.
But this one thing made me curious to how much it could just be related to the motherboard components and bios itself.
So I did something I should have thought of doing before.
My board is a MSI with AMI BIOS. I used MSI's live update tool to update the mainboard drivers, bios, etc..
After I flashed it, tried it again and it worked!
Haven't actually installed it yet, but perhaps will tomorrow.
Thanks for all the suggestions. Using Mepis and it giving me that error lead me on the correct path to finding the source of the problem smile

#6 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 04 April 2005 - 10:09 PM

..and the bios would have been the last thing that i would suggest to mess with. But, since you had a live update function and did not have to go though the tedious and dangerous floppy method to update the bios, it worked. Apparently MSI fixed some issues with the stock bios. It would be interesting to see what the changelog said on the updated bios. Since such live updates default to the default bios settings, this may have also done the trick. In any case, nice work!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq