Jump to content


Photo

Intel Sound Drivers Problem


  • Please log in to reply
8 replies to this topic

#1 charlesinbam

charlesinbam

    stranger

  • Members
  • 1 posts

Posted 22 March 2005 - 05:44 PM

I've recently installed Mandrake 10 on my PC along with Windows XP. I MB is intel D915GAV. I'm unable to play any audio files .. unable to configure sound drivers .. intel's website doesn't have drivers for Mandrake 10 but has drivers for suse 9.x. How do i proceed? Please help me out.



#2 BARTICLE

BARTICLE

    newbie

  • Members
  • 25 posts

Posted 26 March 2005 - 05:01 AM

I am having a similar problem with a different sound chip. I have a VIA AC97. According to Mandrake diagnostics, it's installed correctly. I get no error messages - just no sound. I am wondering if Mandrake may have automatically installed a wrong audio driver? shocked

#3 iamroot

iamroot

    addict

  • Members
  • 501 posts

Posted 26 March 2005 - 10:38 AM

When you say that you cannot play audio files do you mean that an error msg comes up when you try to play them or there is simply no sound?

#4 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 26 March 2005 - 12:38 PM

In terms of the ntel board, the drivers are currently being worked on by Intel, according to some sources.

AC97 means a bunch of things. It may be that the sound is not turned up all the way for the alsa sound driver. What motherboard or system is this in your system, barticle?

Also, try to see if the alsa sound is turned on by typing alsamixer in a terminal window, as root user. Is the graphic bar all the way up on the first bar? Then take a look at kmix and see if the same.

#5 BARTICLE

BARTICLE

    newbie

  • Members
  • 25 posts

Posted 26 March 2005 - 09:16 PM

Thanks, Danleff, I will try that. My cpu is an AMD Sempron 2800. The chip is on-board a VIA KM400A. I don't know if this is related, but when I try to start Rosegarden it starts initializing but never opens. There are no error messages.

#6 BARTICLE

BARTICLE

    newbie

  • Members
  • 25 posts

Posted 27 March 2005 - 02:36 AM

OK, I tried alsamixer - I set all the bars up into the green zones. Kmix is set at 100% volume. None of my audio programs do anything. I tried playing a music CD with KsCD - the program says the first track is playing, but there's no sound. Anything else I can try??

#7 BARTICLE

BARTICLE

    newbie

  • Members
  • 25 posts

Posted 29 March 2005 - 08:16 AM

Well, my sound chip is now working, but I'm not sure why. Mandrake said there were two possible drivers I could use - I had tried both of them with no result. Yesterday I downloaded all the bug fixes & updates. Once again I tried the alternate sound driver (not the default). Now it's working fine, at least with the audio programs I've tried so far. I can only guess this is the result of one of the bug fixes, but anyhow I'm happy. Now if I could only get the Lexmark printer to work... 8)

#8 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 29 March 2005 - 10:25 AM

Two things about alsamixer. By default, the sound is sometimes turned off. I don't knmow why. Set the value(s) to 100%. Also make sure that in the description text on the top, the value does not say....master (off). If it does, use the "greater than" > key to change that. Just click on the bottom of the mixer bar that needs to be changed and apply the > keystroke.

The other problem is that sound is not added as a group to user. Depending on the distro, you can add the audio group to your user account, by using the following command, as root user, in a terminal window (command line);

adduser <your login name> audio (hit the enter key).

So, for me it would be (assuming my login name is danleff);

adduser danleff audio

This adds your current login account to the audio group.

#9 BARTICLE

BARTICLE

    newbie

  • Members
  • 25 posts

Posted 01 April 2005 - 03:56 AM

danleff,

My sound card is still working. However, since downloading the updates & bug fixes I have discovered I can no longer access alsamixer. When I type in "alsamixer" as root user in Konsole, I keep getting "no such directory or file." The file is still there, in /usr/bin. But it won't do anything. Any reason you know of?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq