Jump to content
Compatible Support Forums
Sign in to follow this  
agalmat

Nvidia driver Mandrake10.1

Recommended Posts

Hello,

 

I´ve installed NVIDIA-Linux-x86-1.0-5336-pkg1.mun in Mandrake 10.1

 

sh NVIDIA-Linux-x86-1.0-5336-pkg1.mun

 

I wrote "nvidia" instead of "nv" in XF86Config

 

Here is a piece of the log file:

 

(II) Setting vga for screen 0.

(II) Loading sub module "vgahw"

(II) LoadModule: "vgahw"

(II) Loading /usr/X11R6/lib/modules/libvgahw.a

(II) Module vgahw: vendor="X.Org Foundation"

compiled for 6.7.0, module version = 0.1.0

ABI class: X.Org Video Driver, version 0.7

(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32

(==) NVIDIA(0): RGB weight 888

(==) NVIDIA(0): Default visual is TrueColor

(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)

(--) NVIDIA(0): Linear framebuffer at 0xD0000000

(--) NVIDIA(0): MMIO registers at 0xE4000000

(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!

(EE) NVIDIA(0): *** Aborting ***

(II) UnloadModule: "nvidia"

(II) UnloadModule: "vgahw"

(II) Unloading /usr/X11R6/lib/modules/libvgahw.a

(EE) Screen(s) found, but none have a usable configuration.

 

Fatal server error:

no screens found

 

Please consult the The X.Org Foundation support

at http://wiki.X.Org

for help.

Please also check the log file at "/var/log/Xorg.0.log" for additional information.

 

 

Can anyone tell me what´s wrong?

 

Thank you,

Share this post


Link to post
Share on other sites

I think you're having a monitor problem. What is the make and model of your monitor? Do you have the vertical and horizontal rates for in in a manual? Did you run XFdrake?

 

Run:

 

Code:
XFdrake

 

And press enter. Try different resolutions but see if your monitor is in the list and make sure to choose it. If it isn't, you may have to configure your monitor by hand which isn't that difficult, I can show you how. Try XFdrake first though...

Share this post


Link to post
Share on other sites

My monitor is LG Flatron F700B, I executed XFdrake and it´s not in the list of monitors. I selected custom with Horz. freq. 30-70 and Vert. freq. 50-160 as the monitor´s manual recommends. I´ve try with different resolutions but always the same error:

 

(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!

(EE) NVIDIA(0): *** Aborting ***

 

With the driver "nv" I don´t have any problems.

 

 

Share this post


Link to post
Share on other sites

I get this error installing 6111:

"Your kernel was configured to include a rivafb support as a loadable kernel module"

and then an error related to the kernel source. I have 2.6.8.1-12 and installing 5336 was ok so I don´t know if I need to install another kernel.

I did a lsmod and there wasn´t rivafb module so I think is a kernel problem.

Share this post


Link to post
Share on other sites

I ran into the same warning when running Slackware 10, but it had no effect on my 3d acceleration. I'm having Nvidia problems myself. 6629 gives the Nvidia splashscreen with no way to access the DE and 6111 won't compile. It says it can't find the right kernel source even though it is installed and I've pointed it right to it. Can't play Half-Life or Team Fortress... frown

 

Which card are you running?

Share this post


Link to post
Share on other sites

I have the exact same video ard in my system and just did an install of the 6629 version in Mandrake 10.1. Let me ask a few questions.

 

Did you do the install of the drivers after exiting X?

 

Are the kernel sources installed?

 

Did you make sure that load "glx' was not commented out in the xorg file?

 

Did you install the Linux IA32 drivers?

Share this post


Link to post
Share on other sites

This is my XFConfig I don´t know if I have to change something in Section "Monitor"

 

 

Section "Files"

# Multiple FontPath entries are allowed (they are concatenated together)

# By default, Mandrake 6.0 and later now use a font server independent of

# the X server to render fonts.

FontPath "unix/:-1"

EndSection

 

Section "ServerFlags"

#DontZap # disable <Crtl><Alt><BS> (server abort)

AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work

#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)

EndSection

 

Section "Module"

Load "dbe" # Double-Buffering Extension

Load "v4l" # Video for Linux

Load "extmod"

Load "type1"

Load "freetype"

Load "glx" # 3D layer

EndSection

 

Section "InputDevice"

Identifier "Keyboard1"

Driver "keyboard"

Option "XkbModel" "pc105"

Option "XkbLayout" "es"

Option "XkbOptions" ""

EndSection

 

Section "InputDevice"

Identifier "Mouse1"

Driver "mouse"

Option "Protocol" "ExplorerPS/2"

Option "Device" "/dev/mouse"

Option "ZAxisMapping" "6 7"

EndSection

 

Section "Monitor"

Identifier "monitor1"

VendorName "Plug'n Play"

HorizSync 30-70

VertRefresh 50-160

 

# Sony Vaio C1(X,XS,VE,VN)?

# 1024x480 @ 85.6 Hz, 48 kHz hsync

ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

 

# Dell D800 and few Inspiron (16/10) 1280x800

ModeLine "1280x800" 147.89 1280 1376 1512 1744 800 801 804 848

 

# Dell D800 and few Inspiron (16/10) 1680x1050

ModeLine "1680x1050" 214.51 1680 1800 1984 2288 1050 1051 1054 1103

 

# Dell D800 and few Inspiron (16/10) 1920x1200

ModeLine "1920x1200" 230 1920 1936 2096 2528 1200 1201 1204 1250 +HSync +VSync

 

# TV fullscreen mode or DVD fullscreen output.

# 768x576 @ 79 Hz, 50 kHz hsync

ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

 

# 768x576 @ 100 Hz, 61.6 kHz hsync

ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616

EndSection

 

Section "Device"

Identifier "device1"

VendorName "nVidia Corp."

BoardName "NVIDIA GeForce4 (generic)"

Driver "nvidia"

Option "DPMS"

EndSection

 

Section "Screen"

Identifier "screen1"

Device "device1"

Monitor "monitor1"

DefaultColorDepth 24

 

Subsection "Display"

Depth 8

Virtual 1024 780

EndSubsection

 

Subsection "Display"

Depth 15

Virtual 1024 780

EndSubsection

 

Subsection "Display"

Depth 16

Virtual 1024 780

EndSubsection

 

Subsection "Display"

Depth 24

Virtual 1024 780

EndSubsection

EndSection

 

Section "ServerLayout"

Identifier "layout1"

InputDevice "Keyboard1" "CoreKeyboard"

InputDevice "Mouse1" "CorePointer"

Screen "screen1"

EndSection

 

Share this post


Link to post
Share on other sites

Try this. Add nvidia to the /etc/modprobe.preload file, then reboot. Or you can try testing it by changing to root user at the terminal window (since you are not in X) and type in modprobe nvidia (hit the enter key), then type in startx. If you get a message that you are unable to open a screen, then type in login, sign in as normal user and type the startx command.

Share this post


Link to post
Share on other sites

I tried that with the versions 6111 and 6629, and I got an error:

Fatal Error inserting NVIDIA (...) no such device.

 

With 5336 I can load the module but when I change to my username and execute startx I get the same problem:

 

(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!

 

Perhaps is a kernel problem, should I download a nvidia kernel or it´s better to compile it from my kernel source?

Share this post


Link to post
Share on other sites

I did a dmesg and I found the next output:

 

Linux agpgart interface v0.100 © Dave Jones

agpgart: Detected VIA KT266/KY266x/KT333 chipset

agpgart: Maximum main memory to use for agp memory: 439M

agpgart: AGP aperture is 64M @ 0xe0000000

nvidia: module license 'NVIDIA' taints kernel.

0: nvidia: Can't find an IRQ for your NVIDIA card!

0: nvidia: Please check your BIOS settings.

0: nvidia: [Plug & Play OS ] should be set to NO

0: nvidia: [Assign IRQ to VGA] should be set to YES

0: nvidia: loading NVIDIA Linux x86 NVIDIA Kernel Module 1.0-5336 Wed Jan 14 18:29:26 PST 2004

 

Perhaps my card is not detected, how can I change the IRQ configuration?

 

I checked BIOS settings and were ok

Share this post


Link to post
Share on other sites

The problem is not in detecting the card, but in assigning an irq for video. So, if both PNP OS is set to no and an irq is set for vga in the bios, you need to look at what hardware is on the system. Can you post what your system specs. are? What motherboard and if all your pci/isa slots are filled.

 

By any chance is this a Dell or Gateway?

Share this post


Link to post
Share on other sites

Hello,

 

Please dont give up yet! I've been hassled with the exact same problem and i'm really trying to find a way to fix it.

 

I wont want to step down Mandrake 9.1 since alot of my friends have been harping about 10.1. So please help me find a fix to this problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×