Jump to content


Photo

Knoppix Wireless


  • Please log in to reply
8 replies to this topic

#1 zfirestone

zfirestone

    stranger

  • Members
  • 4 posts

Posted 13 February 2005 - 06:22 AM

I am using a Toshiba laptop.  I have an Orinoco 802.11b wireless card here plugged into the laptop.  It works perfectly with Windows.  In fact, when I went to my friends house, who has no encryption on his wireless network, my network card automatically worked fine with Knoppix there!!  Here the name of the network is 2c8313 and the password is c8313.
How do I tell it that in Knoppix?  I have tried all of the network configuration settins.  I have eth0 and eth1 in the list and i try configuring it.  I've tried using and not using DHCP.  I go to terminal and type netcardconfig to get that.  I try typing su to log in as root, then typing wlcardconfig. I fill in everything (at least I think it is correct) yet when I open the Mozilla browser it cannot connect. I tried going to the WaveLan settings, same problem. Don't forget-it automatically worked perfectally at my friends house who has no encryption, and I do not want to turn off encryption on my router.  I am new to Linux.  What should I do?  

#2 Dapper Dan

Dapper Dan

    Pooh-Bah

  • Moderators
  • 1703 posts

Posted 13 February 2005 - 07:12 AM

I also have a Toshiba laptop with an Orinoco Gold PCMCIA and it works perfectly with either a Linksys wireless "b" or wireless "g" router. What type of router are you using? Is it a "g" or a "b?" Where do you put in this password? If you are using 128 WEP encryption have you configured your router for such? In wlcardconfig did you enter the WEP key your router gives? Have you tried getting your router to work without encryption?

By the way, tell your friend he really should be using WEP encryption, otherwise he's wide open to be exploited! wink

#3 zfirestone

zfirestone

    stranger

  • Members
  • 4 posts

Posted 13 February 2005 - 07:15 AM

it is only a B router is 128 wep i do not want to turn off encryption for security reasons

#4 Dapper Dan

Dapper Dan

    Pooh-Bah

  • Moderators
  • 1703 posts

Posted 13 February 2005 - 07:17 AM

What about that password? Where does it go? Are you using 64 or 128 WEP?

#5 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 13 February 2005 - 12:49 PM

Also, look at your WEP settings for the router. Is the password/WEP key in HEX or ASCI?

#6 zfirestone

zfirestone

    stranger

  • Members
  • 4 posts

Posted 13 February 2005 - 05:34 PM

ASCI

#7 Dapper Dan

Dapper Dan

    Pooh-Bah

  • Moderators
  • 1703 posts

Posted 13 February 2005 - 05:48 PM

My Linksys router has a Wireless Network Name(SSID) and a "passphrase" from which to generate the WEP key. What is the make of your router? Can you enable 10 or 26 HEX?

#8 zfirestone

zfirestone

    stranger

  • Members
  • 4 posts

Posted 13 February 2005 - 07:30 PM

i cant figure out how to change my password! i go to 192.168.1.1 but its not there 9but i know for a fact that its ASCI) my old router-a DLINK-was HEX and it was very easy to change!

#9 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 13 February 2005 - 11:39 PM

I am reaching into my remote memory on this, but if it is an asci WEP key, you may need to modify the passkey phrase with an s:prefix.

At the appropriate key line try;

...key=s:1234...

Where 1234...is replaced with the actual WEP key.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq