Jump to content


Photo

Cant log on XP with Samba Domain Controller


  • Please log in to reply
6 replies to this topic

#1 Blaktyger

Blaktyger

    stranger

  • Members
  • 19 posts

Posted 17 January 2005 - 09:09 AM

So I manage to set my Linux Box as a Samba Domain controller and I was able to join the domain.
Now thw problem is that I cant log on XP using the domain name a set up.
Upon login in my XP box tells me it could not contact the DC, that the DC was down or that I supplied a wronf usrname/password.

I know the DC is running and that I typed in the correct username and password. I dont know what could be wrong...
Help!!!!!

Thanks

#2 clutch

clutch

    Carpal Tunnel

  • Moderators
  • 3859 posts

Posted 17 January 2005 - 09:51 AM

Have you applied any security templates, or many any security adjustments to your XP box? NTLMv2 could be in the way if it is setup on the XP box, and you would need to manually enable that on the SAMBA DC. Was your firewall off during the testing? smile

#3 Blaktyger

Blaktyger

    stranger

  • Members
  • 19 posts

Posted 17 January 2005 - 07:30 PM

Yes my firewall was off hehehhe
And I applied the registry patch "require..."
But I dont think I applied any security templates on XP or the NTLMv2 for that matter but I'll check it out!
Thanks!

#4 Blaktyger

Blaktyger

    stranger

  • Members
  • 19 posts

Posted 18 January 2005 - 04:04 AM

I enabled NTLMv2 on Samba but still doesn't solve the problem...

#5 Blaktyger

Blaktyger

    stranger

  • Members
  • 19 posts

Posted 18 January 2005 - 06:11 AM

Solved!
I had to remove all user created with smbpass before the creation on the domain and re-add them after the domain was created... works like a charm =)
Thanks again clutch!


#6 clutch

clutch

    Carpal Tunnel

  • Moderators
  • 3859 posts

Posted 18 January 2005 - 06:12 AM

Please be specific as to what registry patch you applied.

#7 Blaktyger

Blaktyger

    stranger

  • Members
  • 19 posts

Posted 18 January 2005 - 06:38 AM

Sorry...
I applied the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters
requiresignorseal key,
I changed the value to 0.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq