Jump to content


Photo

unable to shutdown with Fedora Core 3


  • Please log in to reply
12 replies to this topic

#1 iamroot

iamroot

    addict

  • Members
  • 501 posts

Posted 14 January 2005 - 07:39 AM

I just installed FC3 yesterday and i discovered that i'm unable to shutdown. Whenever i attempt to shutdown, i get this error msg

psmouse.c : bad data from KBC - timeout

Btw, I faced this problem as well when i upgraded to a 2.6.9 kernel on my old FC2 installation so im guessing that its a kernel issue. Can anyone here help me out? I don't want to have to do a hard shutdown everyday...

#2 Dapper Dan

Dapper Dan

    Pooh-Bah

  • Moderators
  • 1703 posts

Posted 14 January 2005 - 04:31 PM

I'm using the 2.6.9 kernel in ProMepis Beta 3 and not having many of the problems folks are reporting with the same kernel in FC3 so I don't think it's a kernel problem per se. I'm staying away from Core three for another few months... wink

#3 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 14 January 2005 - 08:00 PM

From the threads that I have seen, this is mostly an issue with laptops and synaptic touchpads. However, there are also references to desktops also. I am curious, do you have both a usb mouse and keyboard? What make/model pc is it?

I bet it is a Fedora and hardware issue.

I have also seen some patches posted by the kernel experts, but with varied results. Fedora just posted an updated kernel, but it does not make mention of this issue that I could see in the changelog.

#4 iamroot

iamroot

    addict

  • Members
  • 501 posts

Posted 15 January 2005 - 09:45 AM

I m using a custom-built pc. Using BENQ USB keyboard and Microsoft Intellimouse Optical.

#5 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 15 January 2005 - 12:06 PM

psmouse.c : bad data from KBC - timeout

This is a keyboard controller issue. Do you have a PS/2 keyboard that you can plug-in and see if the issue goes away? I don't know the solution, but it would be interesting if this solves it.

#6 iamroot

iamroot

    addict

  • Members
  • 501 posts

Posted 16 January 2005 - 09:04 AM

Yeah. I'm going to try it out and we'll see. I'll post the result here when i'm done...

#7 iamroot

iamroot

    addict

  • Members
  • 501 posts

Posted 16 January 2005 - 09:24 AM

The problem persisted when i switched keyboard but when i switched my USb mouse with a PS2 one, the error msg disappeared but i still cant shutdown. Everything proceeds as per normal except for the fact that my com doesn't turn off. Weird...

#8 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 17 January 2005 - 12:33 PM

What motherboard/system is this?

I had to add acpi=off to my lilo config. to solve the shutdown issue. I forget what Fedora uses (or if it gives you a choice), since I use lilo from my Lindows install as my bootloader.

#9 iamroot

iamroot

    addict

  • Members
  • 501 posts

Posted 17 January 2005 - 02:22 PM

I'm using an ECS motherboard. Btw, do u know where i can get my shutdown logs?

#10 iamroot

iamroot

    addict

  • Members
  • 501 posts

Posted 17 January 2005 - 02:54 PM

I just upgraded to the 2.6.10 kernel and the shutdown problem has been resolved.

#11 taeuler

taeuler

    journeyman

  • Members
  • 94 posts

Posted 17 January 2005 - 10:16 PM

I had a similar issue with shutdown hanging on my Gentoo box running 2.6.9, which was also fixed by upgrading to 2.6.10.

#12 iamroot

iamroot

    addict

  • Members
  • 501 posts

Posted 18 January 2005 - 04:37 AM

Must be some hardware compatibility issue with my motherboard and kernel 2.6.9.

#13 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 18 January 2005 - 01:55 PM

I bet the apci problem was fixed with the new kernel. Good going! 8)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq