Jump to content
Compatible Support Forums
Sign in to follow this  
LinuxCrusader

MPlayer help

Recommended Posts

I've just installed MPlayer on Kknoppix 3.7 and I'm getting an error when I try to play a dvd. I can see the dvd playing, but all I hear is a steady gibberish sound. Here's the error that I get in the terminal, does anyone know why I'm getting this error (Couldn't find matchinf filter!). My dvd is working Perfectly fine with XINE, please help:

 

-----------------------------------------------------------------

MPlayer 1.0pre6-3.3.5 © 2000-2004 MPlayer Team

CPU: Intel Pentium 4/Xeon/Celeron Foster (Family: 8, Stepping: 7)

Detected cache-line size is 64 bytes

CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1

Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

 

 

 

vo: X11 running at 1024x768 with depth 16 and 16 bpp (":0.0" => local display)

77 audio & 188 video codecs

Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied

Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.

Playing dvd://1.

Reading disc structure, please wait...

There are 10 titles on this DVD.

There are 21 chapters in this DVD title.

There are 1 angles in this DVD title.

DVD successfully opened.

MPEG-PS file format detected.

VIDEO: MPEG2 720x480 (aspect 2) 29.970 fps 9801.6 kbps (1225.2 kbyte/s)

==========================================================================

Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders

Cannot find codec 'dts' in libavcodec...

ADecoder init failed frown

ADecoder init failed frown

Opening audio decoder: [hwac3] AC3/DTS pass-through SP/DIF

No accelerated IMDCT transform found

hwac3: switched to DTS, 768000 bps, 48000 Hz

AUDIO: 48000 Hz, 2 ch, 16 bit (0x400), ratio: 96000->192000 (768.0 kbit)

Selected audio codec: [hwdts] afm:hwac3 (DTS through SPDIF)

==========================================================================

==========================================================================

Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough

VDec: vo config request - 720 x 480 (preferred csp: Mpeg PES)

Could not find matching colorspace - retrying with -vf scale...

Opening video filter: [scale]

The selected video_out device is incompatible with this codec.

VDecoder init failed frown

Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b

Selected video codec: [mpeg12] vfm:libmpeg2 (MPEG 1 or 2 (libmpeg2))

==========================================================================

Checking audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/8bit...

AF_pre: af format: 2 bps, 2 ch, 48000 hz, big endian AC3

AF_pre: 48000Hz 2ch AC3

[AO OSS] Can't set audio device /dev/dsp to AC3 output, trying S16...

AO: [oss] 48000Hz 2ch Signed 16-bit (Little-Endian) (2 bps)

Building audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...

[format] Sample format big endian AC3 not yet supported

[libaf] Reinitialization did not work, audio filter 'format' returned error code -2

Couldn't find matching filter/ao format!

Starting playback...

VDec: vo config request - 720 x 480 (preferred csp: Planar YV12)

VDec: using Planar YV12 as output csp (no 0)

Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.

VO: [xv] 720x480 => 720x540 Planar YV12

A: 1.6 V: 1.6 A-V: -0.023 ct: 0.059 42/ 40 9% 22% 25.0% 8 0

demux_mpg: 24fps progressive NTSC content detected, switching framerate.

A: 3.8 V: 4.0 A-V: -0.172 ct: 0.080 99/ 96 12% 25% 12.3% 11 0

 

 

-----------------------------------------------------------

 

Intel Pentium 4, 2.40Ghz

768 Mb Ram

80 Gb Hard Drive

Knoppix 3.7

bold textbold textbold textbold text

Share this post


Link to post
Share on other sites

look into the settings, audio and codecs & demuxers tab inteh Mplayer prefs. You can mess with those. I'm not 100% sure but I had the same problem and I fixed it in there. post the fix her. I gotta start documenting stuff. frown

Share this post


Link to post
Share on other sites

I've tried many of the combinations there in the audio and demuxers tab and I can't still get the right sound. Actually now there's not even a sound and I already defaulted to the way it was, which was making the buzzing sound. Any more ideas, please help.

Share this post


Link to post
Share on other sites

It's funny. This buzzing sound does it for only one specific movie under MPlayer. I tested out other movies and MPlayer plays perfectly fine. I guess I can live with that. The thing I don't like about is that it goes right into playing the dvd and doesn't give the screen options where you can choose features, languages, etc.

Share this post


Link to post
Share on other sites

Originally posted by LinuxCrusader:

I've just installed MPlayer on Kknoppix 3.7 and I'm getting an error when I try to play a dvd. I can see the dvd playing, but all I hear is a steady gibberish sound. Here's the error that I get in the terminal, does anyone know why I'm getting this error (Couldn't find matchinf filter!). My dvd is working Perfectly fine with XINE, please help:

 

Cannot find codec 'dts' in libavcodec...

ADecoder init failed frown

 

==================================================================

 

Download and install the libdts (http://ftp.debian.org/debian/pool/main/libd/libdts/libdts_0.0.2-svn.orig.tar.gz) and re-compile the MPlayer with the --enable-libdts option.

 

smile

Share this post


Link to post
Share on other sites

Try this. Download it, burn it and boot the machine with it. Boots in about 30 seconds (depending on hardware of course). No install to the harddrive. Played lots of different files for me and has a dvd player. I am using it till I settle on a distro to use fulltime and get mplayer installed.

 

http://www.geexbox.org/en/index.html

Share this post


Link to post
Share on other sites
Quote:
Posted - 2005-01-07 19:17:01
ReFoRMaT
Member

Posts: 58
Joined: 2004-10-17
From: Toronto, Ontario, Canada
Member No.: 44266
Try this. Download it, burn it and boot the machine with it. Boots in about 30 seconds (depending on hardware of course). No install to the harddrive. Played lots of different files for me and has a dvd player. I am using it till I settle on a distro to use fulltime and get mplayer installed.

http://www.geexbox.org/en/index.html


Well, I tried geexbox. I tell you what...it seems to a pretty cool OS, but there was a problem when boot it up in my computer. The screen on my computer kept flickering. I could see the main menu and loaded up a dvd to see if I would get past that flickering. I could see the movie but, of course, my screen was..how do I describe it...scribbish and flickering. Any ideas what was happenning?

I used GeeXboX 0.98.5 - English Version.

---------------------
Pentium 4, 2.4Ghz
768 Ram
Duel 80Gb HD

Share this post


Link to post
Share on other sites

The problem you have is only the matter of selecting right audio track. In "menu/DVD/audio language/" you should select another one audio. The 'dts' encoding is only the encoding for home theatre systems, used by DVD-players. When you watch films on PC, you should use something like dobly digital.

Share this post


Link to post
Share on other sites

Thanks for posting a reply for this problem, but note that this thread is over one year old. If you respond to a thread question, make sure that you note the date of the last post, so you don't waste your time!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×