Jump to content
Compatible Support Forums
Sign in to follow this  
RichardLOZ

Not recognising second processor

Recommended Posts

I have just installed Fedora Core 2 on a Compaq Proliant 1600 dual P II 300 server. All seemed to go well except that I dont appear to have the second processor recognised. Is there any definitive way that I can tell whether it is and if it isnt does anyone have any ideas as to how to fix this. Thanks

 

Richard

Share this post


Link to post
Share on other sites

Greetings RichardLOZ

 

You can tell whether your box is running in dual-CPU-mode in a couple of ways. Here are the two most common indicators:

 

During boot-up sequence

In case you are booting in a VESA-mode you should see some sort of logo in th upper left corner of the screen. Most distros use this space to indicate the number of found CPUs. That means: 1 logo = 1 CPU found, 2 logos = 2 CPUs found.

 

On the shell

In case FC2 doesn't show any logos, just boot the OS, launch a console and type ps fax. This should deliver an output similar to this (without the dots):

 

Code:
PID TTY .... STAT . TIME COMMAND..1 ? ...... S .... 0:01 init [5]..2 ? ...... S .... 0:00 [migration/0]..3 ? ...... SN ... 0:00 [b][ksoftirqd/0][/b]..3 ? ...... SN ... 0:00 [b][ksoftirqd/1][/b]

 

If you only see the "ksoftirqd/0"-entry, the OS only utilizes 1 CPU. If you have both ksoftirqd-entries, then you're using both processors.

 

Some distros also come with "custom-kernels" that have SMP-support (Symmetric Multi Processing) already compiled in. Dunny if FC2 does likewise.

 

If you don't hae an SMP-enabled kernel, you just have to build one. D/L or install the kernel-sources, cd to /usr/src/linux and type make xconfig of make menuconfig. You'll find the SMP-options under "Processor type and features".

 

Hope that helps

 

Share this post


Link to post
Share on other sites

I did as you suggested and it is definately only running one processor. When I installed as far as I know it built the SMP kernel, as on GRUB I have 2 choices when I boot.....either 2.6.x or 2.6.x smp, which is the one I choose.

 

Are you suggesting that I should recompile the kernel again now to see if I can get it working......that should be fun, a new experience for me. Thanks

 

Richard

Share this post


Link to post
Share on other sites

'lo again

 

That is a bit strange ... if you do actually boot the SMP-kernel and yet the OS does still not recognise the second processor, then something seems to be wrong. It would maybe help if you post what your current kernel-config is. You can get these infos this way ...

 

1. Install the kernel-sources ...

of the kernel you are using (should be "kernel v2.6.x")

 

2. cd to /usr/src/linux

In case you don't have "/usr/src/linux" but something like this: "/usr/src/linux-2.6.x" you need to make a symlink under /usr/src first ("user@machine /usr/src: ln -s linux-2.6.x linux")

 

3. Launch kernel-configuration ...

by typing "make xconfig"

 

4. Load your current configuration-file ...

which is usually located in /boot and should be named (in your case) something like "config-2.6.x-smp". This will ensure the settings as used for the SMP-kernel will be displayed in xconfig.

 

Now check under "Processor type and family" what family is selected. The Proliant is from 1999 or so and according to google it uses P2 or P3-cpus. So in your case it should be either the general "586/K5/5x86/6x86/6x86MX", "Pentium II/Celeron (pre Coppermine)", or "Pentium III/Celeron (Coppermine)/Pentium III Xeon"-family.

 

Keep us informed

Share this post


Link to post
Share on other sites

I have a symlink from linux-2.4 -> linux-2.4.18-14

 

In that same directory I also have directories

 

linux-2.6.5-1.358

redhat

 

When I looked in the /boot directory I do have a config-2.6.5-1.358 & config-2.6.5-1.358smp. I had a look through these files and couldnt see any reference to processor in it under the Procerror section.

 

so where to from there.

 

Thanks for the help

 

Richard

Share this post


Link to post
Share on other sites

howdy

 

If you have a "linux-2.6.5-1.358"-folder under "/usr/src" then just make a "linux"-symlink to that one, "cd" into it and launch the kernel-configuration (see posting above).

 

Then, choose "File-Load" and load the "config-2.6.5-1.358smp" from "/boot". If no processor type is selected, choose the PII-family (pre Coppermine). Also make sure the following options are checked ...

 

*) Generic x86 support

*) Symmetric multiprocessing support

 

And set the the nr of CPUs to "2" (double clicking the item).

 

Still though if you load the smp-config file and none of these are selected or checked then something's wrong with the config, in which case I would not recommend to even make an attempt to compile the kernel (who knows what other options are missing too? smile If this is indeed the case, you should maybe ask some folks here who actually use FC2 (DepperDan does, as far as I know, and he's quite a knowledgable powerhouse as it goes for FC).

 

In any case do not just "save" the configuration. Either discard the changes if you don't want to compile anyway, or choose "File - Save As" first, and save the configuration under "/boot/custom-config-2.6.5-1.358smp" or whatever. After that you can use "File save", and exit xconfig.

 

From there on it's down to compiling. But please! If you've never done that before, grab a few pages from the internet that describe how a v2.6.x-kernel is compiled and installed. The info according this would by far exceed the limits of a usual forum-posting and still not cover all possibilities (chipset, device-support, filesystem-support etc.)

 

Share this post


Link to post
Share on other sites

Thanks for all of the very useful information....just one further question....I noticed that you suggested for the config to run

 

make xconfig

 

I assume this is the xwindows version of config. I have not installed x as didnt want to clutter the poor old beast with a gui so am just running the shell. Do I assume I just run the shell version and select the same parameters to change.

 

Richard

Share this post


Link to post
Share on other sites

Goodness me, the postings here are replied to faster than on IRC smile

 

ad xconfig:

if you don't have X installed yet, you will have to use "make menuconfig" which is the commandline-version of the kernel-configuration. The grouping of the items and branchings should be fairly the same.

 

good luck

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×